Highlighted
Posted by ebrunet44
Henagon

Teamviewer don't start on Debian stretch/testing

Hello,

The application don't start and display only in terminal:

Init...
Checking setup...
Launching TeamViewer ...

 

This is the /opt/teamviewer9/logfiles/TeamViewer9_Logfile.log

2017/05/05 12:03:02.946 25799 4147275648 S0   Starting as daemon
2017/05/05 12:03:02.948 25799 4147275648 S0   UpdateOnlineState newOnlineValue 0
2017/05/05 12:03:02.952 25799 4147275648 S0   MID: Read from disk failed.
2017/05/05 12:03:02.952 25799 4147275648 S0   MachineID m=0 - 0



Start:              2017/05/05 12:03:02.952 (UTC+2:00)
Version:            9.0.32150
ID:                 0
Loglevel:           Info (100)
License:            0
Server:             master10.teamviewer.com
IC:                 818636030
CPU:                Intel(R) Core(TM) i7-6600U CPU @ 2.60GHz
CPU extensions:     h9
OS:                 Lx Debian stretch/si (32-bit)
IP:                 10.142.159.7
MID:                0xf48c50e7c3b3_b5aa2fa9_d41d8cd98f00b204
MIDv:               0
Proxy-Settings:     Type=1 IP= User=

2017/05/05 12:03:02.953 25799 4147275648 S0   Using IPC-Port 5939
2017/05/05 12:03:02.955 25799 4147275648 S0   SystemdSessionInfoProvider: systemd-logind service available
2017/05/05 12:03:02.956 25799 4147275648 S0   systemd: updating session info by inotify
2017/05/05 12:03:02.956 25799 4120378176 S0   Using systemd-logind for suspend/resume monitoring
2017/05/05 12:03:02.956 25799 4147275648 S0   SystemdSeat: New seat seat0 [path=/org/freedesktop/login1/seat/seat0, activeSession='2', canGraphical=1, canTTY=1, canMultiSession=1]
2017/05/05 12:03:02.957 25799 4147275648 S0!  DBus: expected optional property DefaultControlGroup not found
2017/05/05 12:03:02.957 25799 4147275648 S0!  DBus: expected optional property KillProcesses not found
2017/05/05 12:03:02.957 25799 4147275648 S0   SystemdSession: New session c1 [path=/org/freedesktop/login1/session/c1, TTY=/dev/tty1 seat=seat0 display= vtnr=1 uid=SysUser_Lin: Debian-gdm [uid=114, gid=123 home=/var/lib/gdm3 gecos=Gnome Display Manager shell=/bin/false] idle=1(1493976674473894) active=0 type=wayland class=greeter state=online timestamp=1493382397797112 service=gdm-launch-environment defaultCG= leader=1475 audit=0 remote=0 rHost= rUser= killProc=0] SysSession_Lin: 9999 [id=c1, type=3 user=Debian-gdm tty=1 pseudotty=0 state=greeter active=0 reliable=1 info=0]
2017/05/05 12:03:02.958 25799 4147275648 S0!  DBus: expected optional property DefaultControlGroup not found
2017/05/05 12:03:02.958 25799 4147275648 S0!  DBus: expected optional property KillProcesses not found
2017/05/05 12:03:02.958 25799 4147275648 S0   SystemdSession: New session 2 [path=/org/freedesktop/login1/session/_32, TTY=/dev/tty2 seat=seat0 display= vtnr=2 uid=SysUser_Lin: ebr [uid=1000, gid=1000 home=/home/ebr gecos=Eric Brunet,,, shell=/bin/bash] idle=0(1493968135267869) active=1 type=x11 class=user state=active timestamp=1493382507186962 service=gdm-password defaultCG= leader=2395 audit=2 remote=0 rHost= rUser= killProc=0] SysSession_Lin: 10002 [id=2, type=3 user=ebr tty=2 pseudotty=0 state=user active=1 reliable=1 info=0]
2017/05/05 12:03:02.958 25799 4147275648 S0   Session Information provided by systemd
2017/05/05 12:03:02.958 25799 4147275648 S0   XSocketSessionObserver: watching /tmp/.X11-unix
2017/05/05 12:03:03.031 25799 4147275648 S0!  Unable to get XAuth for :1024
2017/05/05 12:03:03.031 25799 4147275648 S0!  XSession: Unable to open XAuthority file ""
2017/05/05 12:03:03.031 25799 4147275648 S0!  DBus: expected optional property DefaultControlGroup not found
2017/05/05 12:03:03.031 25799 4147275648 S0!  DBus: expected optional property KillProcesses not found
2017/05/05 12:03:03.032 25799 4147275648 S0!  DBus: expected optional property DefaultControlGroup not found
2017/05/05 12:03:03.032 25799 4147275648 S0!  DBus: expected optional property KillProcesses not found
2017/05/05 12:03:03.032 25799 4147275648 S0   UpdateOnlineState newOnlineValue 0
2017/05/05 12:03:03.032 25799 4147275648 S0!  DBus: expected optional property DefaultControlGroup not found
2017/05/05 12:03:03.032 25799 4147275648 S0!  DBus: expected optional property KillProcesses not found
2017/05/05 12:03:03.956 25799 4120378176 S0   TerminalServer::SessionLogin for session 0
2017/05/05 12:03:03.957 25799 4120378176 S0   CTerminalServer::RepeatedlyCheckForUserLogin() Don't start GUI for session 0
2017/05/05 12:03:18.660 25799 4145556288 S0   CAcceptServer::HandleAccept: new connection from 127.0.0.1:40470
2017/05/05 12:03:18.702 25799 4145556288 S0   UpdateOnlineState newOnlineValue 1

It is a xauth problem?

Thank you in advance.

4 Replies
4 Replies
Posted by ebrunet44
Henagon

Re: Teamviewer don't start on Debian stretch/testing

Ok I complete with the wine.log

vim ~/.config/teamviewer9/logfiles/winelog

 

fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
wine: configuration in '/home/ebr/.config/teamviewer9' has been updated.
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessDEPPolicy (3): stub
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
fixme:resource:GetGuiResources (0xffffffff,0): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x32f724,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x32f3dc,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x32f724,0x00000000), stub!
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x40c040c, 0000: semi-stub!
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x40c040c, 0000: semi-stub!

And when I launch manually Teamviewer inaty like this:

/opt/teamviewer9/tv_bin/wine/bin$ ./wine ../drive_c/TeamViewer/TeamViewer.exe

It appear a dialog box with messages: could not load ... tvwine.dll.so

Anyone can help please?

Posted by TeamViewer Staff
TeamViewer Staff

Teamviewer 9 doesn't start on Debian stretch/testing

May I ask why you are trying to run a 3-year-old TeamViewer release on a bleeding-edge distribution? We do not support that. I'd recommend to uninstall this version and install TeamViewer 12.

You can either use the new (wine-free!) TeamViewer HOST, or the full package. You can get them here: TV Download Linux

Linux Developer
Posted by ebrunet44
Henagon

Re: Teamviewer 9 doesn't start on Debian stretch/testing

Hello,

I have open a Ticket (ID: 3175774). I need this version because our licenses are in version 9 for my enterprise.

TV12 not work too (but TV10 is ok!).

 

Posted by kanakamedala
Electron

Re: Teamviewer 9 doesn't start on ubuntu 18.04 lts

hi

im using teamviewer9 paid version. when ever i start teamviewer in my UBUNTU 18.04

its not working. if i run it from terminal with root privilages the i can see this log...

2018/07/10 18:28:52.747  5648 3706197824 g0   Session Information provided by systemd
2018/07/10 18:28:52.747  5648 3706197824 g0   XSocketSessionObserver: watching /tmp/.X11-unix
2018/07/10 18:28:52.782  5648 3706197824 g0!  Unable to get XAuth for :1024
2018/07/10 18:28:52.782  5648 3706197824 g0!  XSession: Unable to open XAuthority file ""
2018/07/10 18:28:52.811  5648 3706197824 g0!  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.811  5648 3706197824 g0!  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.811  5648 3706197824 g0!  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.811  5648 3706197824 g0!  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.811  5648 3706197824 g0!  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.811  5648 3706197824 g0!  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.811  5648 3706197824 g0   systemd: no active session found for display :1024, assuming login screen
2018/07/10 18:28:52.811  5648 3706197824 g0   systemd: no active session found for display :1024, assuming login screen
2018/07/10 18:28:52.812  5648 3706197824 g0!  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.812  5648 3706197824 g0!  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.812  5648 3706197824 g0!  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.812  5648 3706197824 g0!  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.812  5648 3706197824 g0!  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.812  5648 3706197824 g0!  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.814  5648 3706197824 g0   XSocketSessionObserver: thread_interrupted
2018/07/10 18:28:52.814  5648 3706197824 g0   TVGuiSlave: Running
2018/07/10 18:28:52.814  5648 3639944960 g0   XClipboard: Plain data for 'CLIP_TEMPORARY'
2018/07/10 18:28:52.814  5648 3556767488 g0   Audio: PulseAudio enabled
2018/07/10 18:28:52.815  5648 3648337664 g0   PulseAudio: Connected to server 'unix:/run/user/1000/pulse/native' (protocol version 32, library version 11.1.0
2018/07/10 18:28:52.815  5648 3556767488 g0   PulseAudio: Connection established
2018/07/10 18:28:52.815  5648 3648337664 g0   PulseAudio: Exit main loop (0), err=-2
2018/07/10 18:28:52.815     8    21 G0   Slave connected to GUI master
2018/07/10 18:28:52.989     8     9 G0!!!CRASH: Saved dump file to '/opt/teamviewer9/logfiles/TeamViewer_9_0_32150__20180710T182852.mdmp'