Posted by flies
Henagon

Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Hi,

the problem is teamviewer 12 started crashing recently (almost everyday). It happens after some time. Never had this issue with teamviewer11. VNC (other software) is still responsive at this time.

Here are the logs: 

 

2017/01/08 01:55:01.485  9829 4055886656 NX1   SysSessionInfoManager: assigned session 99 to info provider 'None'
2017/01/08 01:55:01.693  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 01:56:01.713  9829 4074453824 NX1   XSocket observer: adding XSession: 99
2017/01/08 01:56:01.715  9829 4055886656 NX1   XSession[99]: Retrieved XAuth from commandline
2017/01/08 01:56:01.744  9829 4055886656 NX1!  VTSessionInfoProvider: Failed setting TTY for session 99 on display ':99'
2017/01/08 01:56:01.744  9829 4055886656 NX1   SysSessionInfoManager: assigned session 99 to info provider 'None'
2017/01/08 01:56:01.963  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 01:57:01.983  9829 4074453824 NX1!! XSocket observer: stat failed /tmp/.X11-unix/X99, Errorcode=2
2017/01/08 01:57:01.984  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 01:58:02.004  9829 4074453824 NX1   XSocket observer: adding XSession: 99
2017/01/08 01:58:02.006  9829 4055886656 NX1   XSession[99]: Retrieved XAuth from commandline
2017/01/08 01:58:02.036  9829 4055886656 NX1!  VTSessionInfoProvider: Failed setting TTY for session 99 on display ':99'
2017/01/08 01:58:02.036  9829 4055886656 NX1   SysSessionInfoManager: assigned session 99 to info provider 'None'
2017/01/08 01:58:02.254  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 01:59:01.274  9829 4074453824 NX1!! XSocket observer: stat failed /tmp/.X11-unix/X99, Errorcode=2
2017/01/08 01:59:01.274  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 02:00:01.294  9829 4074453824 NX1   XSocket observer: adding XSession: 99
2017/01/08 02:00:01.296  9829 4055886656 NX1   XSession[99]: Retrieved XAuth from commandline
2017/01/08 02:00:01.327  9829 4055886656 NX1!! XClient fatal XIOError - X server connection lost, Errorcode=11
2017/01/08 02:00:01.427    39    20 GX1   CTcpProcessConnector::HandleRead(): Socket gracefully closed (PID=9829)
2017/01/08 02:00:01.427    39    20 GX1   CTcpProcessConnector::CloseConnection(): PID=9829
2017/01/08 02:00:01.427    39    20 GX1!  InterProcessBase::EventFunctionInternal(): IPC-Connection Closed
2017/01/08 02:00:01.427    39    20 GX1   CTcpProcessConnector::CloseConnection(): PID=9829
2017/01/08 02:00:01.427    39    20 GX1   CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 10058: Unknown error
2017/01/08 02:00:01.428    39    20 GX1!! CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 10009: Unknown error, Errorcode=317

 

$ ./teamviewer

Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process started (18848)
Launching TeamViewer GUI ...
terminate called without an active exception
fixme:nls:GetGeoInfoW -1 4 0x1bedd74 3 0
QMetaObject::invokeMethod: No such method QSystemTrayIcon::isVisible()
QMetaObject::invokeMethod: No such method QSystemTrayIcon::isVisible()
fixme:nls:GetGeoInfoW -1 4 0x1cee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1cee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1cee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1cee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1dee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1dee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1dee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1dee2ec 3 0
fixme:nls:GetGeoInfoW -1 8 (nil) 0 0
TeamViewer: Fatal IO error: client killed
terminate called without an active exception
fixme:console:CONSOLE_DefaultHandler Terminating process 27 on event 0

 

Is it something that you are familiar with? How can I help you more to troubleshoot the issue?

 

--
Best regards,

flies

10 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Dear flies,

Thank you for your post.

Did you upgrade your TeamViewer 11 to 12 or it was a new installation?

If so, please run these commands to delete any TeamViewer trace, update your system and re-install the software.

cd /
sudo rm -rf /home/*/.local/share/teamviewer* /home/*/.config/teamviewer /opt/teamviewer
cd ~
sudo apt-get update
sudo apt-get upgrade
wget download.teamviewer.com/download/teamviewer_i386.deb
dpkg -i teamviewer_i386.deb
sudo apt-get install -f -y

Hope that solution works for you.

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by flies
Henagon

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Hi Christian,

thank you for your reply, appreciate it.

 

Unfortunately - it doesn't apply to my case since I am using standalone version tar.xz inside screen session. There are no leftovers - I have used cleanly unpacked files.

 

It works fine for a few hours and then stops at some time.

Posted by TeamViewer Staff
TeamViewer Staff

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Hi flies,

Make sure you have the latest build of tar.xz

You may check that running the command:

 

./teamviewer info

Don't forget to run it from the extracted directory.

At the moment this reply was created latest version is v12.0.71510

You may also check the latest build from our website

http://www.teamviewer.com/download/linux

Best regards,

Christian

 

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by flies
Henagon

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Hi Christian,

yes it's the newest one:

 

flies@xxx:~/teamviewer$ ./teamviewer info

TeamViewer 12.0.71510 (TAR_NI)

Posted by flies
Henagon

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Newest crash gave other error:

 

Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process started (5810)
Launching TeamViewer GUI ...
Invalid MIT-MAGIC-COOKIE-1 keyterminate called without an active exception
Posted by TeamViewer Staff
TeamViewer Staff

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Hi flies,

If you have the latest version, please make sure that all dependencies are satisfied using the following command

sudo ./tv-setup checklibs

The application will give you an example on how to install the missing dependencies.

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Highlighted
Posted by flies
Henagon

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Hello again Christian,

everything is intact.

 

Is there any debug mode I can use to pinpoint the issue or at least allow you to make troubleshooting easier for you?

 

 

flies@xxx:~/teamviewer$ sudo ./tv-setup checklibs

    -=-   TeamViewer tar.gz check   -=-      

  In order to use the tar.gz version of TeamViewer, 
  you have to make sure that the necessary libraries are installed.
  NOTE: Most needed libraries are 32 bit libraries, even if you are on a 64 bit system!   

    Writing raw output to /home/flies/teamviewer/logfiles/DependencyCheck32.log
    Writing raw output to /home/flies/teamviewer/logfiles/DependencyCheck64.log

 Analyzing dependencies (64 bit)...    

	All 64 bit dependencies seem to be satisfied!

 Analyzing dependencies (32 bit)...    

	All 32 bit dependencies seem to be satisfied!

 

 

2 Replies
Posted by flies
Henagon

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Hello again Christian,

everything is intact.

 

Is there any debug mode I can use to pinpoint the issue or at least allow you to make troubleshooting easier for you?

 

 

flies@xxx:~/teamviewer$ sudo ./tv-setup checklibs

    -=-   TeamViewer tar.gz check   -=-      

  In order to use the tar.gz version of TeamViewer, 
  you have to make sure that the necessary libraries are installed.
  NOTE: Most needed libraries are 32 bit libraries, even if you are on a 64 bit system!   

    Writing raw output to /home/flies/teamviewer/logfiles/DependencyCheck32.log
    Writing raw output to /home/flies/teamviewer/logfiles/DependencyCheck64.log

 Analyzing dependencies (64 bit)...    

	All 64 bit dependencies seem to be satisfied!

 Analyzing dependencies (32 bit)...    

	All 32 bit dependencies seem to be satisfied!

 

 

Posted by TeamViewer Staff
TeamViewer Staff

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time

Dear flies,

Please try the following command and let us know if this solution works for you.

cd ~/.config
# rm -rf teamviewer
sudo teamviewer daemon restart

Please note that # means that you may need sudo or root permissions.

Hope this solution works for you.

 

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by hassankarimg
Photon

Re: Ubuntu 16.04 Server - Teamviewer 12 crashes from time to time


@flies wrote:

Hi,

the problem is teamviewer 12 started crashing recently (almost everyday). It happens after some time. Never had this issue with teamviewer11. VNC (other software) is still responsive at this time.

Here are the logs: 

 

2017/01/08 01:55:01.485  9829 4055886656 NX1   SysSessionInfoManager: assigned session 99 to info provider 'None'
2017/01/08 01:55:01.693  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 01:56:01.713  9829 4074453824 NX1   XSocket observer: adding XSession: 99
2017/01/08 01:56:01.715  9829 4055886656 NX1   XSession[99]: Retrieved XAuth from commandline
2017/01/08 01:56:01.744  9829 4055886656 NX1!  VTSessionInfoProvider: Failed setting TTY for session 99 on display ':99'
2017/01/08 01:56:01.744  9829 4055886656 NX1   SysSessionInfoManager: assigned session 99 to info provider 'None'
2017/01/08 01:56:01.963  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 01:57:01.983  9829 4074453824 NX1!! XSocket observer: stat failed /tmp/.X11-unix/X99, Errorcode=2
2017/01/08 01:57:01.984  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 01:58:02.004  9829 4074453824 NX1   XSocket observer: adding XSession: 99
2017/01/08 01:58:02.006  9829 4055886656 NX1   XSession[99]: Retrieved XAuth from commandline
2017/01/08 01:58:02.036  9829 4055886656 NX1!  VTSessionInfoProvider: Failed setting TTY for session 99 on display ':99'
2017/01/08 01:58:02.036  9829 4055886656 NX1   SysSessionInfoManager: assigned session 99 to info provider 'None'
2017/01/08 01:58:02.254  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 01:59:01.274  9829 4074453824 NX1!! XSocket observer: stat failed /tmp/.X11-unix/X99, Errorcode=2
2017/01/08 01:59:01.274  9829 4074453824 NX1   XSocket observer: removing XSession: 99
2017/01/08 02:00:01.294  9829 4074453824 NX1   XSocket observer: adding XSession: 99
2017/01/08 02:00:01.296  9829 4055886656 NX1   XSession[99]: Retrieved XAuth from commandline
2017/01/08 02:00:01.327  9829 4055886656 NX1!! XClient fatal XIOError - X server connection lost, Errorcode=11
2017/01/08 02:00:01.427    39    20 GX1   CTcpProcessConnector::HandleRead(): Socket gracefully closed (PID=9829)
2017/01/08 02:00:01.427    39    20 GX1   CTcpProcessConnector::CloseConnection(): PID=9829
2017/01/08 02:00:01.427    39    20 GX1!  InterProcessBase::EventFunctionInternal(): IPC-Connection Closed
2017/01/08 02:00:01.427    39    20 GX1   CTcpProcessConnector::CloseConnection(): PID=9829
2017/01/08 02:00:01.427    39    20 GX1   CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 10058: Unknown error
2017/01/08 02:00:01.428    39    20 GX1!! CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 10009: Unknown error, Errorcode=317

 

$ ./teamviewer

Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process started (18848)
Launching TeamViewer GUI ...
terminate called without an active exception
fixme:nls:GetGeoInfoW -1 4 0x1bedd74 3 0
QMetaObject::invokeMethod: No such method QSystemTrayIcon::isVisible()
QMetaObject::invokeMethod: No such method QSystemTrayIcon::isVisible()
fixme:nls:GetGeoInfoW -1 4 0x1cee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1cee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1cee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1cee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1dee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1dee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1dee2ec 3 0
fixme:nls:GetGeoInfoW -1 4 0x1dee2ec 3 0
fixme:nls:GetGeoInfoW -1 8 (nil) 0 0
TeamViewer: Fatal IO error: client killed
terminate called without an active exception
fixme:console:CONSOLE_DefaultHandler Terminating process 27 on event 0

 

Is it something that you are familiar with? How can I help you more to troubleshoot the issue?

 

--
Best regards,

flies