Posted by hintegerha
Digon

teamviewer 13 linux builds with recent QT version

Will there be a new TV version for linux soon linked against recent QT versions (5.9 is recent), 13.1.3026 is linked with QT5.6 and cannot be executed on a recent distro :-(

Error is: Cannot mix incompatible Qt library (version 0x50600) with this library (version 0x50904)

Option 2 would be to add a (qt only) static build.

regards Gerhard

1 Reply
1 Reply
Posted by TeamViewer Staff
TeamViewer Staff

Re: teamviewer 13 linux builds with recent QT version

Actually, TeamViewer is linked against Qt 5.2 currently.
But of course it can still be run on recent distros.

It rather seems that you have an inconsistent set of Qt libraries floating around your system. You can use 5.6, 5.9 or even 5.2 but you shouldn't mix. It might also be a problem in the repositories you're using.

A package which includes Qt may become available, but not in the near future.

Cheers,
Daniel

Linux Developer