Posted by rolandg
Henagon

yum/rpm repo outdated ?

Hi,

to me it looks like the yum repo ( configured by a teamviewer 14.1 rpm installation) is outdated.
I had to install 14.2 again manully ( downloading from website).

my environment: openSuse Leap 15.1

installed rpm:

$ rpm -qa | grep teamviewer
teamviewer-suse-14.2.8352-0.x86_64

repo configuration:

$ zypper lr -u  | grep teamviewer
17 | teamviewer                          | TeamViewer - x86_64                | Yes     | (r ) Yes  | No      | http://linux.teamviewer.com/yum/stable/main/binary-x86_64/

manually refreshing:

# zypper -vv ref 17
Verbosity: 3
Non-option program arguments: '17' 
Initializing Target
Specified repositories: teamviewer 
Checking whether to refresh metadata for TeamViewer - x86_64
Retrieving: http://linux.teamviewer.com/yum/stable/main/binary-x86_64/repodata/repomd.xml .................[done]
Retrieving: http://linux.teamviewer.com/yum/stable/main/binary-x86_64/media.1/media .......................[done]
Repository 'TeamViewer - x86_64' is up to date.                                                                  
Specified repositories have been refreshed.

seems to be successful.

searching for teamviewer:

$ zypper se -s  teamviewer
Loading repository data...
Reading installed packages...

S  | Name                 | Type    | Version      | Arch   | Repository         
---+----------------------+---------+--------------+--------+--------------------
   | teamviewer           | package | 14.1.3399-0  | x86_64 | TeamViewer - x86_64
   | teamviewer           | package | 14.0.14470-0 | x86_64 | TeamViewer - x86_64
   | teamviewer           | package | 13.2.26559-0 | x86_64 | TeamViewer - x86_64
   | teamviewer           | package | 13.2.13582-0 | x86_64 | TeamViewer - x86_64
   | teamviewer           | package | 13.1.8286-0  | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 14.1.3399-0  | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 14.0.14470-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 13.2.26559-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 13.2.13582-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 12.1.83885-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host-suse | package | 14.1.3399-0  | x86_64 | TeamViewer - x86_64
   | teamviewer-host-suse | package | 14.0.14470-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host-suse | package | 13.2.26559-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host-suse | package | 13.2.13582-0 | x86_64 | TeamViewer - x86_64
i+ | teamviewer-suse      | package | 14.2.8352-0  | x86_64 | (System Packages)  
v  | teamviewer-suse      | package | 14.1.3399-0  | x86_64 | TeamViewer - x86_64
v  | teamviewer-suse      | package | 14.0.14470-0 | x86_64 | TeamViewer - x86_64
v  | teamviewer-suse      | package | 13.2.26559-0 | x86_64 | TeamViewer - x86_64
v  | teamviewer-suse      | package | 13.2.13582-0 | x86_64 | TeamViewer - x86_64
v  | teamviewer-suse      | package | 13.1.8286-0  | x86_64 | TeamViewer - x86_64

does not list version 14.2 rpm available on the remote repo (except the one manually installed) .

Are you not distributing via the Yum repo anymore ?