Posted by rolandg
Trigon

yum/rpm repo outdated ?

Hi,

to me it looks like the yum repo ( configured by a teamviewer 14.1 rpm installation) is outdated.
I had to install 14.2 again manully ( downloading from website).

my environment: openSuse Leap 15.1

installed rpm:

$ rpm -qa | grep teamviewer
teamviewer-suse-14.2.8352-0.x86_64

repo configuration:

$ zypper lr -u  | grep teamviewer
17 | teamviewer                          | TeamViewer - x86_64                | Yes     | (r ) Yes  | No      | http://linux.teamviewer.com/yum/stable/main/binary-x86_64/

manually refreshing:

# zypper -vv ref 17
Verbosity: 3
Non-option program arguments: '17' 
Initializing Target
Specified repositories: teamviewer 
Checking whether to refresh metadata for TeamViewer - x86_64
Retrieving: http://linux.teamviewer.com/yum/stable/main/binary-x86_64/repodata/repomd.xml .................[done]
Retrieving: http://linux.teamviewer.com/yum/stable/main/binary-x86_64/media.1/media .......................[done]
Repository 'TeamViewer - x86_64' is up to date.                                                                  
Specified repositories have been refreshed.

seems to be successful.

searching for teamviewer:

$ zypper se -s  teamviewer
Loading repository data...
Reading installed packages...

S  | Name                 | Type    | Version      | Arch   | Repository         
---+----------------------+---------+--------------+--------+--------------------
   | teamviewer           | package | 14.1.3399-0  | x86_64 | TeamViewer - x86_64
   | teamviewer           | package | 14.0.14470-0 | x86_64 | TeamViewer - x86_64
   | teamviewer           | package | 13.2.26559-0 | x86_64 | TeamViewer - x86_64
   | teamviewer           | package | 13.2.13582-0 | x86_64 | TeamViewer - x86_64
   | teamviewer           | package | 13.1.8286-0  | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 14.1.3399-0  | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 14.0.14470-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 13.2.26559-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 13.2.13582-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host      | package | 12.1.83885-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host-suse | package | 14.1.3399-0  | x86_64 | TeamViewer - x86_64
   | teamviewer-host-suse | package | 14.0.14470-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host-suse | package | 13.2.26559-0 | x86_64 | TeamViewer - x86_64
   | teamviewer-host-suse | package | 13.2.13582-0 | x86_64 | TeamViewer - x86_64
i+ | teamviewer-suse      | package | 14.2.8352-0  | x86_64 | (System Packages)  
v  | teamviewer-suse      | package | 14.1.3399-0  | x86_64 | TeamViewer - x86_64
v  | teamviewer-suse      | package | 14.0.14470-0 | x86_64 | TeamViewer - x86_64
v  | teamviewer-suse      | package | 13.2.26559-0 | x86_64 | TeamViewer - x86_64
v  | teamviewer-suse      | package | 13.2.13582-0 | x86_64 | TeamViewer - x86_64
v  | teamviewer-suse      | package | 13.1.8286-0  | x86_64 | TeamViewer - x86_64

does not list version 14.2 rpm available on the remote repo (except the one manually installed) .

Are you not distributing via the Yum repo anymore ?

1 Accepted Solution

Accepted Solutions
Posted by rolandg
Trigon
Solution

Re: yum/rpm repo outdated ?

hi,

for me the Teamviewer yum repo works again since a few days.

zypper on opensuse leap 15.1 can refresh without issue ( GPG checks are enabled ).

Thank you Teamviewer for fixing this issue. now the SW update causes again less effort.

The sad thing is that it took over 3 months the fix this. there was no reaction from Teamviewer on this issue on this forum. I see room for improvement.

2 Replies
Posted by thommierother
Henagon

Re: yum/rpm repo outdated ?

Hi,

it looks as if someone at Teamviewer has changed the repo contents without signing the repomd.xml correctly, therefore the integrity check fails:

File repomd.xml from repository TeamViewer - x86_64 │
http://linux.teamviewer.com/yum/stable/main/binary-x86_64/
│ is signed with the following GnuPG key, but the integrity check failed: │
│ │
│ ID: C5E224500C1289C0 │
│ Fingerprint: 8CAE 012E BFAC 38B1 7A93 7CD8 C5E2 2450 0C12 89C0 │
│ Name: TeamViewer GmbH (TeamViewer Linux 2017) <support@teamviewer.com> │
│ Created: 03/13/17 │
│ Expires: Never

@TeamViewer: please fix the repo signature

Posted by rolandg
Trigon
Solution

Re: yum/rpm repo outdated ?

hi,

for me the Teamviewer yum repo works again since a few days.

zypper on opensuse leap 15.1 can refresh without issue ( GPG checks are enabled ).

Thank you Teamviewer for fixing this issue. now the SW update causes again less effort.

The sad thing is that it took over 3 months the fix this. there was no reaction from Teamviewer on this issue on this forum. I see room for improvement.