Posted by hellblade
Henagon

please help ... remote keyboard bug

I am using teamviewer to control my Win7 computer (legit copy).

Everytime I type the fullstop "." followed with any key, whatever is before it gets copied, automatically.

e.g. typing asdf.c will automatically generate asdf.casdf.c

e.g. if you further type .d after the above, it will turn into asdf.casdf.c.dasdf.casdf.c.d

This happens whether you're using word, notepad, browsers ... anything.  This bug exists even with a clean win7 install.  I've tried controlling this computer with android phones, iphones, even an ipad ... the bug still exist.

It's driving me crazy ... and impossible to use teamviewer.  Am I the ONLY person suffering from this?

4 Replies
1 Accepted Solution

Accepted Solutions
Posted by hellblade
Henagon
Solution

Re: please help ... remote keyboard bug

I need you to do me a favour.  Could you please copy the "solution" you've helped me find, so I can credit your reply for it?

I found the bug is fixed by turning OFF the "predictive text" in the samsung keyboards.

It still makes me wonder why I am the only person complaining about this bug ... as predictive text is set to ON by default.  Or maybe other people are just much smarter than me and figured it out before posting -_-

In any case, thank you.  You saved me from pulling out my own hair.

4 Replies
Posted by Raven
Trigon

Re: please help ... remote keyboard bug

Sorry, just ... want to make sure I completely understand =]

You're remote-controlling a consistent device so, say, your home PC, from other locations using TeamViewer and other solutions including Android- and iOS-enabled devices, and you are finding that this keyboard behaviour consistently happens ?

That would strongly suggest it's not a problem with your remote-access software, but a keystroke that you're activating on the remote terminal itself which is manifesting the behaviour.

Which operating system did you re-install - Windows 7 on the remote terminal ?  Or Windows 7 on the terminal you were using to remote the remote terminal ?

Is the remote terminal running any keyboard-specific software that might account for macros ?  Or are you using a keyboard on your local side that can handle macro programming - something like a Corsair RGB CG70 Vengeance (which I myself use), for example.  It's possible that somebody has mapped a keystroke on the keyboard either locally at your side, or on the remote terminal, which activates a macro that is kicking off each time you hit that specific keystroke.

If you want to insert a period character > . < into text, you can do this via the Alt+Numeric Keypad route.  To do this (even if you just want to do this to test), assuming you have a keyboard locally that has a numeric keypad, try this :-

     1) Turn on the numeric keypad if it isn't already;
     2) With your left thumb, hold down the left alt key, next to the space bar;
     3) With your right hand, hit 46 on the numeric keypad (not the horizontal keys above your QWERTY keys);
     4) Release the alt key with your left thumb.  This will insert a period, like this >>> . <<< =]

Hope that helps a bit !

 

- Raven
Posted by hellblade
Henagon

Re: please help ... remote keyboard bug

First of all, thank you for replying.

I may have been mistaken before.  Because after carefully reading your reply, I have isolated the problem to one place, the default samsung galaxy keyboard.

I have three samsung galaxy devices in my family.  All different models, released in different years.

It is ONLY when I use the stock samsung english keyboard, that creates this strange behaviour.  The >.< fullstop is buggy whether it is English(us) or english (uk) or english (AU), but ONLY in the qwerty version of the above keyboards.  If I switch to the 4x3 keypad for typing, the bug is gone.  If I switch to a keyboard of another language, the bug is gone.

Which begs the question ... how could nobody have noticed this bug?  There must be thousands of samsung users out there controlling their PCs at home remotely!  This is the default keyboard of all samsung devices!

 

Posted by hellblade
Henagon
Solution

Re: please help ... remote keyboard bug

I need you to do me a favour.  Could you please copy the "solution" you've helped me find, so I can credit your reply for it?

I found the bug is fixed by turning OFF the "predictive text" in the samsung keyboards.

It still makes me wonder why I am the only person complaining about this bug ... as predictive text is set to ON by default.  Or maybe other people are just much smarter than me and figured it out before posting -_-

In any case, thank you.  You saved me from pulling out my own hair.

Posted by Raven
Trigon

Re: please help ... remote keyboard bug

You're very welcome, but really-speaking it was you that produced the solution yourself, so I can't take credit for that =]

Thanks though, and I'm really glad you were able to get it sorted ! =D

- Raven