Announcements

Did you already try the new Windows 10 October 2020 Update?


Share your feedback and experience with TeamViewer on the new Windows build with our developers here.

Highlighted
Posted by
Henagon

Cannot upgrade to access upgraded "partner" client

Am running Windows version 14.2.56674.
When attempting to connect to an up-rev "partner" client I get the message that I MUST upgrade to connect. I select "OK" and then recieve a message that I am running the LATEST version and no further upgrade is available!!

I'm now stuck in a lose-lose situation and can no longer connect to assist my 90 year old mother with her computer. (And she needs help!)

Anyone know of any solution?
This reflects poorly on teamviewer as a company. :(

Thank you!

5 Replies
5 Replies
Highlighted
Posted by Moderator Moderator
Moderator

Re: Cannot upgrade to access upgraded "partner" client

Hello @rhythmrider,

Thank you for your message and welcome in the TeamViewer Community! 🙌

You will find the answer to your question in our post here: Re: Teamviewer can't connect to older version?? 

This applies also to version 14. Sorry...😞

Best,

Jean

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!

Highlighted
Posted by
Henagon

Re: Cannot upgrade to version 15 from version 14

Jean,
Thank you for your reply. 
Unfortunately the link you included did not include any useful information on the issue.
Purhaps I was not clear in my decription.

The issue is that when running the upgrade installer from version 14 to version 15, it fails with the error that the version 14 of teamviewer that I am running is the current version.

Thank you,
regards,

Dana

Highlighted
Posted by Moderator Moderator
Moderator

Re: Cannot upgrade to version 15 from version 14

@rhythmrider thank you for these additional details.

If your computer recognizes TeamViewer 14 as being the latest version possible, it means that your computer is not compatible with TeamViewer 15, therefore not compatible to use the free version of TeamViewer.

The previous versions of TeamViewer are only usable with licensed accounts.

I hope this was more clear for you to understand the situation. If you need any further information, please let me know.

Best,

Jean

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!

Highlighted
Posted by
Henagon

Re: Cannot upgrade to version 15 from version 14


Jean,
So just to clarify, only the latest version of teamviewer is available as "free".
As soon as a new version comes out the "older" version is immediately no longer allowed in "free" mode (so to speak)

Does this sum up what you are saying?

Regards,
Dana

 

Highlighted
Posted by Moderator Moderator
Moderator

Re: Cannot upgrade to version 15 from version 14

Hello @rhythmrider,

This is absolutely correct. 👍

Best,

Jean

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!