Posted by macka001
Henagon

Compatibility with older versions

Hi,

im running TeamViewer14 and trying to connect to a host that is running version 9.

if im logged into my teamviewer accont then i can connect. if im logged out of my teamviewer account, i am unable to connect. any ideas on how to resolve this as a couple of my engineers dont have teamviewer accounts set-up.

thanks

1 Reply
1 Reply
Posted by Moderator Moderator
Moderator

Re: Compatibility with older versions

Hello @macka001

Thank you for your message.

Since version 13.2, we switched to an account-based license system. In other words, if you are not connected to your licensed account, your license will not be recognised by the system and you will be flagged as a free user. If you are doing this from a professional environment, you might get blocked.

This is why it is always important to log into your licensed TeamViewer account.

We recommend to create a company profile and to manage your account through it. It offers many convenient ways to manage your users, license and devices through TeamViewer settings policies.

You will find all the information you need in our Knowledge Base articles here:

I hope this could help. If not, do not hesitate to ask your questions here.

Cheers

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.