Posted by rackattack
Henagon

Copy and Paste does not work

We just bought enterprise, and it's a deal breaker if we can't copy and paste from the Windows 10 host into the TV window. 

I've tried with Sync clipboards checked, and unchecked. I've restarted TV multiple times with both options. 

It does not work. 

Is there a fix for this or do we need to cancel our account to find something which has this feature?

19 Replies
Posted by rackattack
Henagon

Re: Copy and Paste does not work

So it turns out it's just the login screen. We use password managers with long complex passwords. Using TeamViewer means we have to manually type these to log on to any computer. 

If this can't be fixed that's a huge problem for us. 

Posted by Senior Moderator Senior Moderator
Senior Moderator

Re: Copy and Paste does not work

Hi rackattack

Thanks for posting.

Unfortunately, this is because the remote side does not have a clipboard at login.

Copy-Paste works by keeping the clipboard synchronize between the two sides. when at the login screen, there is no clipboard at the remote side so there is no synchronization and copy-paste will not function.

Unfortunately clipboard synchronization is only available when there is a remote clipboard to synchronize to.

-Scotty

Senior Moderator
Did my reply answer your question? Why not accept it as a solution to help others?
Posted by jsmosier
Photon

Re: Copy and Paste does not work

Instead of worrying about syncing the clipboards, how about a command/keyboard shortcut that will "type" the text that is in the clipboard of the remoting computer?

Posted by jsmith4892002
Photon

Re: Copy and Paste does not work

Something is not accurate.  When I went from version 12 to 13 (after using 8,9...), something broke in the copy and paste.  I've not been able to do this since version 13 was installed.  

I've gone back to 12 to avoid spewing venom at every screen, but now I can't connect to my version 13 PC's.  This is very frustrating!!!!!

If the program does not function correctly, at least give us the ability to connect to newer versions from older versions if we are continuous licensed users!!!

Yes, if you'd like to call me, please do.

St** [deleted by moderator]

Posted by TechServicesGuy
Henagon

Re: Copy and Paste does not work

If it helps, I had same issue and configured the remote PC's TeamViewer account to automatically log-on Windows sessions for connections from my TeamViewer account (Extras / Options / Security / Windows logon ... And then whitelist yourself.)... I'd be curious to know if anyone reading this knows of a reason NOT to just take this approach (in a sense, I guess it's delegating local security to your TeamViewer account's level of security?)

Posted by TechServicesGuy
Henagon

Re: Copy and Paste does not work

Please disregard this tip; it is not working as expected.

Posted by jgt1942
Trigon

Re: Copy and Paste does not work

Scotty, how do I activate the clipboard at login? I connect to family members that are all running Win10 x64. On my wife's PC I cannot copy something to the clipboard on my system (local, it is a desktop) and paste it into her PC (remote, it is a laptop) whereas I can do this when I connect to my laptop and it is the remote PC.

On her PC via TV I can copy something on her PC and paste it into something on her PC.

 

Posted by jgt1942
Trigon

Re: Copy and Paste does not work

I just rebooted both systems and like magic, it is now working.

Posted by upatrono
Henagon

Re: Copy and Paste does not work

It is not only duting TV sessions. For example even when TV session is not active and it is running as a startup service, my clients cannor Ctrl+C and Crtl+V, when the service is stopper you need to Crtl+V twice in order for it to work. When you completeli shut down TV on the host then everything works ok. 

Not entirely sure if its related but I've observed this on All-In-One desktop computers so far.

Posted by adisharr
Henagon

Copy and pasting images doesn't work

I frequenly clip images from PDF's and other documents into my main PC's desktop clipboard and paste them into emails on my laptop (in Outlook) connected over Teamviewer 14.

This used to work fine but recently (past few days), image pasting stopped working. I'm able to copy and paste files and text fine but when I try and paste an image it's just pastes the last thing in the clipboard instead.

I know the image is in the clipboard because I can paste it into other spftyware on the main machine. I've tried snipping tool and also a thriud party program (FastStone image capture).

Nothing has changed as far as I know on my end. The clipboard sync is still checked on both machines and I tried rebooting both as well.

Any ideas?

This has happened before and then just started working again.

Posted by kroderick
Henagon

Re: Copy and pasting images doesn't work

I'm having the same issue.

Posted by franatech_tk
Henagon

Re: Copy and pasting images doesn't work

I have also the same issue

Posted by TBH
Photon

Re: Copy and pasting images doesn't work

I also have the same issue

Posted by Wholestory
Photon

Re: Copy and Paste does not work

But how does the remote computer suddenly loose its clipboard?  It was working the day before.  It was working for the whole year and the year before that.  Now it doesn't.  Any idea what could have changed?  It feels like something went wrong with the recent TeamViewer 14 update.

In advanced options, Syncronize Clipboards is checked on both computers.  And I can copy-paste text just fine.  Just not images, neither from Paint.exe, nor from the Snipping Tool.  Can't do it in either direction.

Posted by franatech_tk
Henagon

Re: Copy and Paste does not work

I experienced the same behavior.

Copying text works

but copying images bitmaps (not files!) from host to client doesn't work anymore

since I upgrades the Host Temaviewer Software from V13 to V14 yesterday.

I need this feature for copying screenshots from snipping tool into reports.

Posted by maxnett
Electron

Re: Copy and Paste does not work

+1 on this.

That's how many other remoting systems get around this issue. For example Microsoft Virtual Machine Manager, and RoyalTS both have a "Type Clipboard" button, which will simply send the contents of the clipboard to the remote machine as a stream of characters, one by one.

You would have thought TeamViewer would implement something along these lines, given the scale of their operation and price of licensing? 

RoyalTS:

type-clip1.jpg

Microsoft Hyper-V Manager:

hvm.jpg

Cheers, Matt

Posted by kroderick
Henagon

Re: Copy and pasting images doesn't work

I reverted back to v13 and copy/paste of images is now working again.

Highlighted
Posted by adisharr
Henagon

Re: Copy and pasting images doesn't work

Great, I'll try that as well. I'm glad the community tries to answer these questions as Teamviewer must be busy with their larger clients.

1 Reply
Posted by TeamViewer Staff
TeamViewer Staff

Re: Copy and pasting images doesn't work

Hello community users,

thank you for all your messages and feedback.

We are currently analysing why images can no longer be copied & pasted and we will fix the problem it as soon as possible. I'll keep you up to date on the progress.

Sorry for the inconveniences!

Best,

Kerstin

Product Owner TeamViewer Core