Announcements

********

First Step Guides

********

  1. Are you new to TeamViewer and Home Office and need some help? Check out our FAQ here.
  2. New to the Remote Access Plan? Find our first steps FAQ here.
  3. Are you new to blizz and online meetings or classes and need some help? Check out our FAQ here.

********

Highlighted
Posted by
Henagon

GUI fails on thin client

Hello All,

On last three versions of TV when teamviewer is run on a thin client machine the GUI never shows. teamviewerd is running. If we launch teamviewer at the console of the server TV shows ,,& works correctly. If launched from icon or from a terminal on the thin client connected to the server the terminal always ends with "TeamveiwerGUI..." & no gui shows
This has happened fror versions 10,11,& now ver 12.

Both the .deb distribution and the tar.xz archive versions.
This is on both 32-bit and 64-bit versions of debian Wheezx/7 & debian Jessie/8.
There is nothing at all in the TV log that shows any failing happening.
Ideas?

Thank You,
Barry


2 Replies
2 Replies
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Betreff: GUI fails on thin client

Hi BarryCisna,

thank you for your post.

In this case we need more informations to check the issue. 

Could you please submit a ticket to our Support Department on https://www.teamviewer.com/en/support/contact/submit-a-ticket/ with a brief description of the issue so a Support Engenieer can work on resolving the issue with you. 

Please submit log files with the ticket, you will find them most quickly by using following command line in the terminal on Linux:

"sudo teamviewer ziplog"

Hope that was helpful!!! :smileyhappy:

Did my reply answer your question? Please accept it as a solution to help others, Thanks.
Reyhan
Highlighted
Posted by
Henagon

Betreff: GUI fails on thin client

*SOLVED*

Wanting to post what was a good resolve for running Teamviewer on an thin client machine.

This is Debian Jessie/8 ramd64 unning the ltsp thin client/terminal server addition.

Installed the TV ver 12.deb package  into the chroot,of the ltsp tree that the thin client machines actually boot from on the terminal server edition.

doing an 'systemctl start teamvierd.service' to make sure the teamviewer daemon is running in the ltsp/chroot tree,,,(not the actual server part).

ltsp ships with a small shell script that enables any installed application in the ltsp/chroot to run off of the thin client itself,,rather than an server process.

do an 'ltsp-localapps teamviewer'  from the thin client and teamviewer shows gui and works as expected with no keyboard hiccups or such.

Hope this may help someone else.

 

Barry