Unable to access login screen fields when using Hyper-V client with RemoteFX 3D Video Adapter

Announcements

Shape the future of your TeamViewer product with our Product Team. Click here to join!

Posted by lesdekock
Henagon

Unable to access login screen fields when using Hyper-V client with RemoteFX 3D Video Adapter

Running

  • Windows 10 pro 1803 (OS Build 17134.165),
  • TV13 (13.2.14327)
  • and Hyper-V 

When starting a VM with the Hyper-V's "RemoteFX 3D Video Adapter" activated I am unable to log into the Team Vierwer login screen. The E-mail and password fields are in-accessable. The YOUR ID and PASSWORD fields for remote controll are also then populated by a '-'.

Need to reboot the computer to gain access to the login fields again.

The same symptom persist even if I am logged into TV prior to starting the VM.

Any suggestions?

 

1 Reply
Highlighted
Posted by DSperber
Trigon

Re: Unable to access login screen fields when using Hyper-V client with RemoteFX 3D Video Adapter

Open a ticket with Team Viewer support, if you are a licensed paid subscriber. That is the only way we're going to get this issue fixed if they see that they've affected lots of people with their recent change which has caused this.  And you are not the only one affected by a change made recently that has caused this. If you look down further on this forum you'll see a number of other users having similar issues with VM and Hyper-V.

There is a whole second class of affected users who utilize Remote Desktop Connection, where remote clients connect the the host PC via RDP. When those RDP connections are established the Team Viewer login screen fields disappear and cannot be entered.  As soon as all RDP connections are terminated, the Team Viewer login screen once again becomes usable.

In my own case I use Win7 on my HTPC (which utilizes Windows Media Center), which also is a Team Viewer PC.  Whenever a WMC remote extender connects to the HTPC (accomplished as an RDP connection) the Team Viewer login screen goes blank and becomes unusable, same as with any normal RDP connection to the host PC  As soon as the WMC remote extender disconnects the Team Viewer login screen once again becomes usable.

I'm sure the RDP connection and VM Hyper-V client/adapter architectures must be similar, so that they are both now being negatively affected by whatever has been recently changed in Team Viewer.

If you are a licensed user, please open a ticket with Team Viewer Support and provide them with a link to this thread so that they can see you are not the only one being impacted by their recent software change..