Camera turns on with every remote session when it's not in use

Posted by jmac999
Digon

Camera turns on with every remote session when it's not in use

My webcam shows as active (light comes on) every time I initiate a remote session with any remote PC I connect to.

I have had TeamViewer for many years and have connected to many hundreds of computers with TV Host, TV Full, TV QS installed but only recently has this started to happen. I've made no changes to my local config and no changes to remote configs.

I am running the very latest version (12.0.78313) and have tested with a fully up-to-date TV Host and experience the same issue. I have specifically unticked "Record partners video and VoIP' as I record all my sessions and this causes unecssary prompts to appear on the cleint end point.

I'm unable to tell whether it's the Mic or the Camera that is being utilised on the webcam. I've tried to track it down using Process Explorer but I can find no processes that are using either the camera or mic hardware ID. It's definitely TV causing the light to come on though as when I stop the remote session, the light on the webcam goes out.

This is a recent change to TV and it's frsutrating I can't figure it out.

Anyone got any suggestions?

Thanks in advance!

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by jmac999
Digon
Solution

Re: Camera turns on with every remote session when it's not in use

 

I've cracked it!! Smiley Happy

I record all my remote sessions so it's only while recording that this issue occurs.

It would seem as part of the recording process, the local mic is used to record Audio.

In the TeamViewer App, navigate to [Extras] > [Options] > [Audo conferencing] > [Voice input] > [Microphone]. I had mine set to [Default Communication Device] which happens to be my webcam and changing this to another device resolved the issue. In my case, I changed it to the onboard mic of my notebook.

This still begs the question: How do I disable local audio recording when recording TV sessions? I have no desire to record the local audio and would prefer to disable this as it's unecessary.

1 Reply
Highlighted
Posted by jmac999
Digon
Solution

Re: Camera turns on with every remote session when it's not in use

 

I've cracked it!! Smiley Happy

I record all my remote sessions so it's only while recording that this issue occurs.

It would seem as part of the recording process, the local mic is used to record Audio.

In the TeamViewer App, navigate to [Extras] > [Options] > [Audo conferencing] > [Voice input] > [Microphone]. I had mine set to [Default Communication Device] which happens to be my webcam and changing this to another device resolved the issue. In my case, I changed it to the onboard mic of my notebook.

This still begs the question: How do I disable local audio recording when recording TV sessions? I have no desire to record the local audio and would prefer to disable this as it's unecessary.