Announcements

Would you like to be part of the TeamViewer task force to make our product even better? Start now with participating in our survey and help our product team to build an even better TeamViewer. Click here for more information.

Posted by JohnD
Trigon

TV Host v14 beta crashing

I've updated to TV Host v14 beta on my Mac running 10.14 and it's working fine, but on two different remote hosts so far, one running on 10.11.6 and the other on 10.12.6, TV Host will no longer start:  it crashes immediately on both of them.  Reverting to the latest v13 lets them work again, but I'd like to get to v14 to hopefully fix the black-screen/Lock bug.  

I have crashlogs from the remote boxes, if that would be useful.

15 Replies
Posted by Daz89
Photon

Re: TV Host v14 beta crashing

With me it isnt even connecting, complaining about proxy settings. I've checked everything and everything is fine including firewall rules but it won't have it.

 

Roll it back to 13 and it works fine again. Think i'll be avoiding this update,

Posted by LarryD
Digon

Re: TV Host v14 beta crashing

TeamViewerHost v14.0.8346 Beta is crashing when it starts on my Mac El Capitan (OS X 10.11.6) machine as well. v13 was starting without problem. I also have crash reports if needed.

Posted by GodzFire
Henagon

Re: TV Host v14 beta crashing

Same here, v14 crashes immediately upon start on 10.11.16.

Crashlog pastebin (The URL has been removed by a moderator)

Posted by Community Manager
Community Manager

Re: TV Host v14 beta crashing

Hi all,

Thanks for the reports.

Just a quick question: Did you already send the logs via a ticket to our support? If so: Could you send me the Ticket ID in a private message?

If not: May I ask those of you with a license to send the logs and link back to this thread so that we can analyse it?

Thanks a lot,

Esther

Community Manager


Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button.


 


Additional information can be found here: Knowledge Base | Community Blog | How to get started 

Japanese Community (日本語コミュニティ) |  Chinese Community (中文社区)

Posted by LarryD
Digon

Re: TV Host v14 beta crashing

I'm not a license owner, but would be glad to help the development team if I can. They can email me and I can send them the crash logs since I can't submit a ticket.

Posted by JohnD
Trigon

Re: TV Host v14 beta crashing

Esther, I created the ticket with the TV v14 Host Beta crashlogs from macOS 10.11.6 and 10.12.6 and PM'd you the Ticket ID.

Posted by Community Manager
Community Manager

Re: TV Host v14 beta crashing

Thanks John. We´ll have a look into it and get back to you as soon as possible. Best, Esther

Community Manager


Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button.


 


Additional information can be found here: Knowledge Base | Community Blog | How to get started 

Japanese Community (日本語コミュニティ) |  Chinese Community (中文社区)

Posted by GodzFire
Henagon

Re: TV Host v14 beta crashing

Soooo, 2 weeks later, still no update and unuseable. Can we can an update please or at least a build to try?

Posted by JohnD
Trigon

Re: TV Host v14 beta crashing

It's unfortunate, but between the issues with v13 with its longstanding black-screen-lock-bug not being fixed and this new v14 beta that sits around with major crashing issues on the Host side (that obviously should have been detected and fixed in alpha....it's a widespread issue), my suspicion is that there's either a tiny (one person?) TV Mac development team, or development of the Mac client is outsourced.  In my 30+ years of experience, those kinds of development situations are usually the scenarios where things move this interminably slowly, and huge bugs sit around for many weeks or months without getting resolved.

Posted by GodzFire
Henagon

Re: TV Host v14 beta crashing

Its funny you say that, because I've had my suspicions as well. I've used Teamviewer for years on OSX, and it always felt like it was the neglected afterthought compared to the Windows client, including features.

One big thing was the update check: Windows had it for ages before the Mac version finally did. But here's the thing, the way that they have the update install process laid out, you can't even use it because it disconnects you from the remote machine before you're done going through all the needed prompts! It completely negates the purpose of a remote autoupdate if you have to go there locally to finish it! I've submitted feedback and brought this up to them multiple times, but it still hasn't changed. 

That is a basic example of something a Mac dedicated team would not have happen.

Posted by JohnD
Trigon

Re: TV Host v14 beta crashing

Just to close the loop on this, TV 14.0.11436 resolved this issue, and it seems ok in the final version too.

Posted by GodzFire
Henagon

Re: TV Host v14 beta crashing

Unfortunately I have to reopen it. Tried the "release" version of 14, and it's still crashing immediately on open. To make matters worse, Teamviewer has removed all download links for v13, so I'm basically stuck completely down.

Pastebin of console log: [the URL link has been removed by a moderator]

Highlighted
Posted by Community Manager
Community Manager

Re: TV Host v14 beta crashing

Hi @GodzFire

Thanks for your post.

The download links are still available: Where can I download older TeamViewer versions?

Best, Esther

Community Manager


Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button.


 


Additional information can be found here: Knowledge Base | Community Blog | How to get started 

Japanese Community (日本語コミュニティ) |  Chinese Community (中文社区)

2 Replies
Posted by GodzFire
Henagon

Re: TV Host v14 beta crashing

Thanks Esther. I'm hoping this crashing issue can still be investigated and fixed so I can start using v14.

Posted by GodzFire
Henagon

Re: TV Host v14 beta crashing

@Esther, any updates on my unresolved crash at launch issue with 14, all betas and final?

Take your pick of crash logs:
[logfiles removed by moderator]