Highlighted
Posted by TACOBell
Photon

BUG?: Administrator settings not carried forward to non-administrative account

TLDR: I feel its a design error in teamviewer 14, let me know if I'm wrong

Goal: Restrict Windows non-administrator (it shall be known as 'guest' for this entry) from performing outbound connections, and preventing guest from changing configured settings. 

Attempting to directly reach Goal is UNSUCCESSFUL

On the windows administrator account (to avoid confusion, it shall be known as 'root' for this entry), I have set on Teamviewer to only allow changes to be made by root *1, and set a password to protect the settings. After testing that it can be remote in, I halt the remote session and log out.

Logging in to guest (guest is created and initialized, before installation of teamviewer), and running teamviewer, I tested that it can be remoted in. Now, I also realized that I can remote out on a guest account and that the guest account cannot change the settings as set before (see *1 above).

Thus, logging out and logging into root, I made changes to disable outgoing connections, root is no longer able to perform outgoing connections, and restarted the computer.

When it loads, guest user is able to perform outbounding connection. However, if in the guest user account and Teamviewer is made to run as administrator, Teamviewer can not perform outbounding connection.

Screenshot (6).pngI do realize that I hid the username of the windows user account found after "non-commercial use only)-" by accident, but trust me left is guest, right is guest 'run as administrator' on teamviewer.

I conclude that this is potentially a design error as the setting to disable outbound connection is not synced over to the guest user, although password locking the settings is.

TEMPORARY WORKAROUND:

On root: Teamviewer > Extras > Advanced > Teamviewer options > uncheck require administrator rights
On guest user account, restart teamviewer and then disable outgoing (or change what ever settings)
On guest account check Extras > Advanced > Teamviewer options > Check require administrator rights
Now outbound is enforced on guest account running normally and not as administrator

Teamviewer: Version 14.0.13880
Windows 10 version 1803 build 17134.407