Announcements

Would you like to co-innovate with us? If so, we’d like to invite you to become product development partners with us. Read more about it in our announcement Launch of the TeamViewer User Focus Program

Posted by Graeme1
Digon

SSH Headless install on LINUX - Needs proxy setup

Is anyone able to assist with instructions on how to complete setup of Teamviewer via SSH on a Linux server.?

TV is installed and running ready for setup. Our environment requires a proxy and port to be configured in the software like in TV Host to continue - how is this achieved in TV server in headless mode?

Thanks.

 

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by Graeme1
Digon
Solution

Re: SSH Headless install on LINUX - Needs proxy setup

Thanks to the Support team we got this working, here are the steps provided. I did have to setup the password, vis teamviewer passwd <my password> at one point but it worked.

The fix was to edit proxy settings - documented but not obviously so to me. ;-)  

Also check this link which helped with the final steps : https://community.teamviewer.com/t5/Linux/TeamViewer-13-for-Ubuntu-16-04-4-LTS-connectivity-problems...

In order to use proxy for LINUX device would you would need to edit your TeamViewer config file.
config file at: /opt/teamviewer/config/global.conf

Please add below settings for manual proxy.
[int32] Proxy_Type = 2
[strng] Proxy_IP = "proxy1:portNum" 


(*proxy1:portNum will be your settings)

1 Reply
Highlighted
Posted by Graeme1
Digon
Solution

Re: SSH Headless install on LINUX - Needs proxy setup

Thanks to the Support team we got this working, here are the steps provided. I did have to setup the password, vis teamviewer passwd <my password> at one point but it worked.

The fix was to edit proxy settings - documented but not obviously so to me. ;-)  

Also check this link which helped with the final steps : https://community.teamviewer.com/t5/Linux/TeamViewer-13-for-Ubuntu-16-04-4-LTS-connectivity-problems...

In order to use proxy for LINUX device would you would need to edit your TeamViewer config file.
config file at: /opt/teamviewer/config/global.conf

Please add below settings for manual proxy.
[int32] Proxy_Type = 2
[strng] Proxy_IP = "proxy1:portNum" 


(*proxy1:portNum will be your settings)