TeamViewer IoT is hiring! Check out the open positions here!

Posted by LanmanOne

TeamViewer won't connect

My TeamVIewer 14 client is stuck saying not ready/not connected.

I am unable to remotely connect to my computer from other devices, nor am I able to connect outbound to other known working TeamViewer clients on other devices.

I have uninstalled and fully reinstalled several times.  I have also checked in netstat, and see that there is in fact a connection established to TeamViewer servers (port 5938).

I'm at a loss as to where to go next to troubleshoot.  Does anyone have a fix for this issue with TeamViewer 14?



Problem is solved if I create a Network Bridge, which includes the Wireless Device that I'm using to connect to the internet.  As soon as I go back to connecting to the internet with no network bridge using my wireless device directly, TeamViewer will not connect.

My network adaptor is an Intel Wireless-AC 9560

1 Reply
1 Reply

Re: TeamViewer won't connect

Had same issue. I updated the 9560 driver to revision 20.120.1 today and problem solved. BTW windows kept saying old driver was latest so I got latest from Intel and manually installed.