Announcements

TeamViewer 14.5 has been released. See the Change Logs here.

Posted by Zahar
Henagon

Teamviewer 14.2.2558 service starts slow

Hello!

After upgrade to Teamviewer 14.2.2558 I've noticed that TeamViewer_Service.exe starts slower, about 10-20 seconds. And local network connection of my computer hangs out in this time. Will it be resolved in the very near future?

Thank you in advance.

My system is Windows 7 Ultimate SP1.

5 Replies
Posted by Plus
Henagon

Re: Teamviewer 14.2.2558 service starts slow

Same here, I firgured out latest version causes LAN and Wifi take long time to load

Posted by klebom
Photon

Re: Teamviewer 14.2.2558 service starts slow

Same here. Teamviwer causes it to take about 2 minutes of delay after boot and login until network is available. I made the Teamviewer service start delayed as a workaround.

Teamviewer 14.2.8352 on Windows 7 Ultimate SP1

Posted by Zahar
Henagon

Re: Teamviewer 14.2.2558 service starts slow

Hello! How did you do that?

But I use function Wake-On-Lan, when my computer turned off. So, I think, I don't need delayed starts of TeamViewer service.

What do you think about that?

Posted by zstoja
Photon

Re: Teamviewer 14.2.2558 service starts slow

The worst remote desktop software. They finally succeeded to destroy TeamViewer. WOL is only useful feature for me.

Stubborn and stupid development team.

Highlighted
Posted by PadaKwaak
Henagon

Re: Teamviewer 14.2.2558 service starts slow

I have the same issue with TeamViewer 14.4.2669 on Windows 7 Home Premium SP1, where I can already see my desktop upon startup, but the network connection and Windows antivirus takes another minute or two to start, and during this time it also prevents (delays) elevated Windows credentials popup.

If I tried doing a shutdown before my network connection startup up correctly,  the shutdown process was also slow due to this issue.

Changing TeamViewer 14 service startup type from "Automatic" to "Automatic (Delayed Start)" also fixed the issue for me.