Posted by KampfKraut
Digon

Teamviewer contacts appear as Unknown.

Hello,
I'm German so sorry for the Google English ;-)

I have the problem that in my contact list my cell phone contacts on which TeamViewer and Teamviewer Quicksuport is installed shows that these contacts are "unknown".

Although these blue when I turn on the QuickSUport on the phone and you can also connect to them but on my other phones on which I have installed the whole earlier it was always so the contacts not as "unknown" but as "Offline" are displayed. Or not be displayed. Usually these are logged out when they are offline in the contact list.

Why is not that the case with the new phones anymore?

2 Replies
Posted by KampfKraut
Digon

Re: Teamviewer contacts appear as Unknown.

Does not anyone have an idea?

Highlighted
Posted by Dom
Digon

Re: Teamviewer contacts appear as Unknown.

Date: 20190228 / 28-Feb-2019

So it seems the rot with TeamViewer continues! I launch TeamViewer 14 tonight to find all by client contacts on TeamViewer 14 are now listed as black with the following after all of them (unknown). Worse I have arranged to work on a clients laptop tonight and 90% of the time when I add the clients TeamViewer ID they do not come up as an available and online system to connect to but they are classified as "(unknown)" and I am unable to connect to my client. When my clients remote laptop (Windows-10) has been online I have been able to connect until the remote connection fails and when attempting to reconnect I am presented with "waitforconnectfailed" and all the rot there.

At the end of the day you take our money and when your product is incomplete or fails it is not you who is on the ground who looks bad because of your failures it is us. I have spend over a year having to downgrade back to TeamViewer 12 for stable remote support services and a service I have paid for now for 2 years running that is incomplete or makes me look bad. I deserve better from a business who charges me so much per year for their product and a Premium licence.

I have in the past deleted a number of contacts (my clients) from which I earn a living and provide remote support services and tonight I can not enter a clients TeamViewer ID and provide an Alias for them as for the majority of the time they are classified as "unknown" and I am unable to connect.
I do not know what is going on at TeamViewer but this rot of developing a product around your paying clients and providing incomplete products masquerading as complete when key features are missing (ability to automatically reconnect to a remote windows OS after a remote reboot) and worse removing TeamViewer 12 and adding a set of custom repositories to ensure and force users to use TeamViewer 14 even though key features are still missing is plain outright disrespectful.

You do not care that the remaining business and private clients I had saved in my list of contacts is now classified as “unknown” and that I have let another client down with your failing and faulty service tonight because you have already been paid for another year. If you did care then why is this the state of TeamViewer in 2019 on 28-Feb? I am the one who will have to explain to my client why I was unable to complete the work I promised them I would do which, makes me look bad when you should own this sh*t and not leave it on our shoulders!!!

After the disaster of tonight I guess there is no point in saving clients information and TeamViewer Contact Details. TeamViewer use to have respect, honour, commitment and passion for their software and us as their clients but for over a year now I have seen none of it, replaced with pure greed at the cost of us, your paying Linux Users & Clients! I could not be more disappointed and let down by TeamViewer as a Premium and paying client and worse it carries on directly to my clients!