Posted by mikee
Digon

Temporarily save connection passwords not working?

The passwords are not being remebered, at least not the way the used to be.

Before I could connect to a machine for a while and if the connection drops or I disconnect I can connect right back with the saved password. Now when I have to enver the password almost every time.

I have noticed that it does keep the password, but for a very short time. Maybe 5 minutes. So if I am having immediate connection issues it works fine, but mostly it fails.

Is there a way to control the temorrary time, or at least only have the timer start when it is disconnected so in the case of a disconnection I can quickly connect back?

7 Replies
Posted by Zimond
Electron

Re: Temporarily save connection passwords not working?

Hi, I have the same problem. TW 14.0.13880 keeps asking for password every time when reconnecting. It worked fine on TW 12, which I've been using until next week. Tried to uncheck/check the option in settings but no luck. I hope this feature hasn't become something just for commercial use only.
Posted by Community Manager
Community Manager

Re: Temporarily save connection passwords not working?

Hi there,

Thanks for your posts.

Due to security reasons we changed the logic in July 2018 and added an automated clearance of the cached password from memory after 5 minutes.

If you need access at any time, we recommend to set up a password for unattended access or Easy Access.

Thanks and best,

Esther

Community Manager


Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button. Find more information here: Knowledge Base | Community Blog | How to get started


English Community |  German Community (Deutschsprachig) | Japanese Community (日本語コミュニティ) |  Chinese Community (中文社区) | French Community (Communauté française) |

Posted by mikee
Digon

Re: Temporarily save connection passwords not working?

Thank you. This is a perfect example of something that should be user configurable. At the very least there should be an option to only start the timer after I disconnect from a computer.

As a topic of another post, I found that a connection always times out after an hour even though I set it to never timeout. That together with the password requirement makes it quite anoying, especially if I am using a temporary password given to me over the phone.

And yes I do know I can add a password to the account, but that is a real security risk. Remembering passwords, at least for the time I am connected to a remote machine is more secure than having to having to re-type my password multiple times. Making it easeier for somone to spy on my password if desired.

Is there any way to turn off or bypass this feature or do I need to go back to 12?

Highlighted
Posted by Community Manager
Community Manager

Re: Temporarily save connection passwords not working?

Hi @mikee

Thanks for your reply and your feedback.

I will forward this to our Product Management.

Regarding the timed-out connections: Do all connections consequently time-out after 60 minutes or only when the connection has been inactive (=no mounse interaction) for 60 minutes?

Best, Esther

Community Manager


Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button. Find more information here: Knowledge Base | Community Blog | How to get started


English Community |  German Community (Deutschsprachig) | Japanese Community (日本語コミュニティ) |  Chinese Community (中文社区) | French Community (Communauté française) |

3 Replies
Posted by Zimond
Electron

Re: Temporarily save connection passwords not working?

Hi, the thing is that I am using the password for unattended access. I've been using this since version 7 or so and never needed to re-enter the password when reconnecting (durring a boot session). Now I have to re-enter the password even if I disconnect for a few minutes which annoys me. I don't understand why having this "Temporarily save connection passwords" feature only for five minutes. It doesn't make much sense to me. Five minutes doesn't make it more secure than keeping it longer. Why not let users decide?
Posted by mikee
Digon

Re: Temporarily save connection passwords not working?

The timeout occurs in an hour even if I am actively using the connection.

I am doing something and it disconnects, I re-connect right away, re-entering the password and I am good to go for another hour.

I belive the disconnects are too consistent to be caused by network outages. However I am not sure if 1 hour is exact, but my approximation just like my 5 minute gues for remebering passwords.

Posted by Zimond
Electron

Re: Temporarily save connection passwords not working?


@mikee wrote:

The timeout occurs in an hour even if I am actively using the connection.

I am doing something and it disconnects, I re-connect right away, re-entering the password and I am good to go for another hour.

I belive the disconnects are too consistent to be caused by network outages. However I am not sure if 1 hour is exact, but my approximation just like my 5 minute gues for remebering passwords.


Hi mikee, I noticed this behavior as well but I'm not sure if it is an hour or so. I think this happens upon some sort of iddle algorithm. If not used for certain amount of minutes, the session ends. It cannot be a network issue since in this case it gives a message saying something like "the remote session has ended". If the session ends due to network/connection failure, it gives a message saying something like "session interupted, trying to reconnect". But you mentioned "I am doing something and it disconnects". Does this mean you were doing something on that remote session or the session was open in the background and were not using it? This is just to support my guess that it ends the session if it's not used/fucused.