TeamViewer Host for Raspberry Pi

Highlighted
Verfasst von
Photon

TeamViewer Host for Raspberry Pi

Hallo,

ich möchte TeamViewer Host for Raspberry Pi auf eimem RASPBERRY PI 4B/4GB mit der 64-Bit-Version von Raspberry Pi OS. Beim Installationsversuch erhalte ich jedoch die Meldung das Abhängigkeiten nicht erfüllt sind. Was kann ich tun um TeamViewer Host for Raspberry Pi zu nutzen ?

Gruß

Michael Feske

5 Antworten
5 Antworten
Highlighted
Verfasst von
Digon

error message

i try this

sudo wget https://download.teamviewer.com/download/linux/teamviewer-host_armhf.deb

2020-07-20 16:05:07 (3,42 MB/s) - »teamviewer-host_armhf.deb« gespeichert [10832314/10832314]

sudo dpkg -i teamviewer-host_armhf.deb

(Lese Datenbank ... 92352 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von teamviewer-host_armhf.deb ...
Entpacken von teamviewer-host:armhf (15.7.6) über (15.7.6) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von teamviewer-host:armhf:
teamviewer-host:armhf hängt ab von libdbus-1-3.
teamviewer-host:armhf hängt ab von libqt5gui5 (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von libqt5widgets5 (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von libqt5qml5 (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von libqt5quick5 (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von libqt5dbus5 (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von libqt5webkit5 (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von libqt5x11extras5 (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von qml-module-qtquick2 (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von qml-module-qtquick-controls (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von qml-module-qtquick-dialogs (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von qml-module-qtquick-window2 (>= 5.5) | qt56-teamviewer.
teamviewer-host:armhf hängt ab von qml-module-qtquick-layouts (>= 5.5) | qt56-teamviewer.

dpkg: Fehler beim Bearbeiten des Paketes teamviewer-host:armhf (--install):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für gnome-menus (3.31.4-3) werden verarbeitet ...
Trigger für desktop-file-utils (0.23-4) werden verarbeitet ...
Trigger für mime-support (3.62) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.17-2) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
teamviewer-host:armhf

sudo apt --fix-broken install 

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... fehlgeschlagen.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
teamviewer-host:armhf : Hängt ab von: libdbus-1-3:armhf ist aber nicht installiert
Hängt ab von: libqt5gui5:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: libqt5widgets5:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: libqt5qml5:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: libqt5quick5:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: libqt5dbus5:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: libqt5webkit5:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: libqt5x11extras5:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: qml-module-qtquick2:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: qml-module-qtquick-controls:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: qml-module-qtquick-dialogs:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: qml-module-qtquick-window2:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
Hängt ab von: qml-module-qtquick-layouts:armhf (>= 5.5) ist aber nicht installiert oder
qt56-teamviewer:armhf ist aber nicht installierbar
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
E: Abhängigkeiten konnten nicht korrigiert werden.

 

Was muss ich tun um den Host zum laufen zu bringen ?

Gruß

Micha Feske

Highlighted
Verfasst von
Tetragon

Re: error message

Hi,

warum versuchts du nicht die Installation mit Hilfe von apt. apt sollte dabei automatisch die Anhängigkeiten auflösen.

z.B.:    sudo apt install ./teamviewer-host-armhf.deb

 mfg
Roland

Highlighted
Verfasst von
Digon

Re: error message

Hallo Roland,

danke für den Tipp. Aber:

sudo apt install teamviewer-host-armhf.deb
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Paket teamviewer-host-armhf.deb kann nicht gefunden werden.
E: Mittels des Musters »teamviewer-host-armhf.deb« konnte kein Paket gefunden werden.
E: Mittels regulärem Ausdruck »teamviewer-host-armhf.deb« konnte kein Paket gefunden werden
Highlighted
Verfasst von
Tetragon

Re: error message

sudo apt install ./teamviewer-host-armhf.deb

 

Highlighted
Verfasst von
Digon

Re: error message

Hallo Roland,

das macht es leider nicht besser.

pi@raspberrypi:~ $ sudo apt install ./teamviewer-host-armhf.deb
Paketlisten werden gelesen... Fertig
E: Nicht unterstützte Datei ./teamviewer-host-armhf.deb auf Befehlszeile angegeben

Gruß

Micha