反馈Linux版本TeamViewer QuickSupport无法运行的问题

公告

~~~~~~~~

TeamViewer 服务站正式上线

~~~~~~~~

购买了远程访问许可计划 ,欢迎浏览/查询/获取相关协助 

Highlighted
发布自
两角形

反馈Linux版本TeamViewer QuickSupport无法运行的问题

您好,

我下载了Linux版本TeamViewer QuickSupport,在系统无法运行,详细信息如下:

Linux版本TeamViewer QuickSupport下载网址:

操作系统版本信息如下:

  • tributor ID: Debian
  • Description: Debian GNU/Linux 10 (buster)
  • Release: 10
  • Codename: buster

使用Linux的file命令查看程序信息如下:

file teamviewer :
teamviewer: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), statically linked, BuildID[sha1]=1a4cade3fa80aeb857e1dbe1bdcddfbf1f015c2e, stripped

运行出错信息如下:

Downloads/teamviewerqs# ./teamviewer

Init...
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
wine: loadlocale.c:130: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_TIME) / sizeof (_nl_value_type_LC_TIME[0]))' failed.
/home/jeff/Downloads/teamviewerqs/tv_bin/script/tvw_profile:行 142: 7715 已放弃 wine regedit "$tweakfile"

请问怎么解决这个错误问题?如何正常运行呢?希望技术人员给予解答。

@Ying_Q 

page.ForumTopicPage.accepted-solutions.text

已接受的解答
Highlighted
发布自 调解员 调解员
调解员
解决方案

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Jeff_Li 您好,

感谢您的耐心等候。

在进一步与工程师确认后,请您查看以下信息:

  1. Linux 现阶段只有 TeamViewer 11 QuickSupport 可供使用。可惜的是,该版本只提供给授权用户下载使用;
  2. 如果您希望使用 Linux版本 TeamViewer 11 QuickSupport, 请您考虑购买TeamViewer 订阅许可
  3. 或者,在免费使用的环境下,请您考虑使用 tar 版本 TeamViewer ;此版本的 TeamViewer 为 TeamViewer 完整版本,也可发起远程连接,却不是安装版本,可以当 TeamViewer QuickSupport 使用。
    linux tar download.png

希望以上信息能帮到您。

如有更多问题,欢迎与我们联系。

Ying_Q

 

在原帖中查看解决方案

发布自 调解员 调解员
调解员
解决方案

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Jeff_Li 您好,

感谢您的回复。

Linux 版本的 TeamViewer 11 QuickSuppport 均可从中文,英文和其他语言的 TeamViewer 下载页面下载。 但是因为该版本主要提供给许可用户使用,且版本较旧,英文下载页面将 QuickSupport 的下载选项收藏至早期版本里。

但是您的第二种理解方法也是对的。多谢您的指正。

Ying_Q

在原帖中查看解决方案

9 回复
Highlighted
发布自 调解员 调解员
调解员

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Jeff_Li 您好,

感谢您的提问和耐心等候。

请您尝试在 TeamViewer QuickSupport 的终端设备上先运行以下命令行:

LC_ALL=C ./teamviewer

希望以上信息能有所帮助。

Ying_Q

Highlighted
发布自
两角形

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Ying_Q @您好

感谢您的帮助和一直关心着这个问题,您提供的命令行能够成功运行,但是出现了新的问题。成功运行的回显和截图如下所示:

 

root@debian:/home/user/Downloads/teamviewerqs# LC_ALL=C ./teamviewer
Init... XRandRWait: No value set. Using default. XRandRWait: Started by user. Checking setup... Launching TeamViewer ... Starting network process (no daemon) Network process started (7467) Launching TeamViewer GUI ...

PIC__17.jpg

 

 

 

 

 

 

 

 

但是当我使用最新14版本的Teamviewer去连接这个快速支持客户端的时候,出现如下版本过低无法连接的错误:PIC__16.jpg

 

 

 

 

 

 

我是用命令行查看了Debian Linux上运行的客户端版本,如下所示,显示版本为11.x:

root@debian:/home/user/Downloads/teamviewerqs# LC_ALL=C ./teamviewer info

 TeamViewer                           11.0.95210  (TAR_QS) 

 teamviewerd status                   * teamviewerd.service - TeamViewer remote control daemon
   Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2019-11-12 18:42:36 CST; 6 days ago
  Process: 1196 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
 Main PID: 1456 (teamviewerd)
    Tasks: 12 (limit: 4915)
   Memory: 11.6M
   CGroup: /system.slice/teamviewerd.service
           `-1456 /opt/teamviewer/tv_bin/teamviewerd -d

Nov 12 18:42:28 debian systemd[1]: Starting TeamViewer remote control daemon...
Nov 12 18:42:36 debian systemd[1]: teamviewerd.service: Can't open PID file /run/teamviewerd.pid (yet?) after start: No such file or directory
Nov 12 18:42:36 debian systemd[1]: Started TeamViewer remote control daemon. 

 TeamViewer ID:  

我在英文网站https://www.teamviewer.com/en/download/linux/ 也找不到最新版本(大于11.x)的版本可供下载,而正如我主贴所述,我安装的是中文官网能下载到的最新版的Linux版Quick Support了,请问能否提供最新版的可以被别人连接的版本下载呢?

 

Highlighted
发布自
两角形

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Ying_Q 您好,

我回复了一个详细的帖子给您,不知为什么被论坛自动删除了,我只能重新简短回复了。使用您提供的命令能运行了,但是之后使用Teamviewer 14.x版本的客户端去连接,显示对方版本过低无法连接,如下图所示:

PIC__16.jpg

我也找了英文网站,也无法下载到更高版本的Linux下的Qucik Support客户端了,现在中文官网的Linux下的Qucik Support客户端版本是11.x的。

 
Highlighted
发布自 调解员 调解员
调解员

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Jeff_Li 您好,

感谢您的回复。

Linux 现阶段只有 v11版本的 QuickSupport 可供下载和使用。请您确保主控方所使用的 TeamViewer 的完整版本为最新版本,这样可以确保完整版本连接到 QuickSupport 正常进行。

多谢您的理解和支持。如果仍遇到其他使用问题,欢迎随时给我们留言。

Ying_Q

Highlighted
发布自
两角形

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Ying_Q 您好,

如下面两个图片所示:

  1. 我使用的主控端是在官网下载的最新版15.0.8397,但是远程连接Linux的Quick Support版本还是显示远端的TeamViewer版本太旧导致无法连接。我认为原因是Linux的Quick Support版本过低导致的。
  2. 我上传的图片不含TeamViewer的ID等隐私信息,请不要删除图片。

PIC__21.jpgPIC__22.jpg

期待您的答复,非常感谢。

Highlighted
发布自 调解员 调解员
调解员

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Jeff_Li  您好,

感谢您的反馈。

我已将您这边的问题转交给TeamViewer 工程师作更多查看和确认。如有进一步的进展,我将尽快告知您。

多谢您的理解和耐心等候。

Ying_Q

Highlighted
发布自 调解员 调解员
调解员
解决方案

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Jeff_Li 您好,

感谢您的耐心等候。

在进一步与工程师确认后,请您查看以下信息:

  1. Linux 现阶段只有 TeamViewer 11 QuickSupport 可供使用。可惜的是,该版本只提供给授权用户下载使用;
  2. 如果您希望使用 Linux版本 TeamViewer 11 QuickSupport, 请您考虑购买TeamViewer 订阅许可
  3. 或者,在免费使用的环境下,请您考虑使用 tar 版本 TeamViewer ;此版本的 TeamViewer 为 TeamViewer 完整版本,也可发起远程连接,却不是安装版本,可以当 TeamViewer QuickSupport 使用。
    linux tar download.png

希望以上信息能帮到您。

如有更多问题,欢迎与我们联系。

Ying_Q

 

在原帖中查看解决方案

Highlighted
发布自
两角形

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Ying_Q 您好,

Linux 现阶段只有 TeamViewer 11 QuickSupport 可供使用。可惜的是,该版本只提供给授权用户下载使用;

您说的上面 TeamViewer 11 QuickSupport我能够在TeamViewer中国官网正常下载的(不过英文官网无下载链接),那么您说的“只提供给授权用户下载使用”里的“下载”二字我无法理解了。

如果说:没有购买授权的人即使能从TeamViewer中国官网正常下载 TeamViewer 11 QuickSupport,也无法连接到服务器正常使用。这个说法我倒是理解。您说的是这个意思吗?

发布自 调解员 调解员
调解员
解决方案

回复: 反馈Linux版本TeamViewer QuickSupport无法运行的问题

@Jeff_Li 您好,

感谢您的回复。

Linux 版本的 TeamViewer 11 QuickSuppport 均可从中文,英文和其他语言的 TeamViewer 下载页面下载。 但是因为该版本主要提供给许可用户使用,且版本较旧,英文下载页面将 QuickSupport 的下载选项收藏至早期版本里。

但是您的第二种理解方法也是对的。多谢您的指正。

Ying_Q

在原帖中查看解决方案