Posted by Martin_RB
Electron

Automatic Rollout SCCM with API & Easy Acces / Group

Good Morning,

i have some trouble with my settings in terms of mass deployment.

TV 14 SCCM Rollout with following command:

msiexec.exe /i "TeamViewer_Host.msi" /qn CUSTOMCONFIGID=******* DESKTOPSHORTCUTS=1 APITOKEN=********** ASSIGNMENTOPTIONS="--alias %COMPUTERNAME% --group REN_Computer --grant-easy-access"

Some machines where automatically added to my group Ren_Computer, some not.

All clients have the correct personalized look & internet connection.

Where i have to check what kind of settings are missing, to make sure, 100% of all client will be added correctly?

Best regards Martin

 

2 Replies
2 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: Automatic Rollout SCCM with API & Easy Acces / Group

Hi Martin,

Thank you for your post. Can you please try it with the group-ID instead of the group name? You can find the group ID if you sign in in the management console, click on the group at the left side and look at the browser URL. It should look like this:

https://login.teamviewer.com/nav/home/buddies/g/12345678

Now take the number and the g (you don't need the slash) and put it in your parameter.

Your parameter should look like this:

msiexec.exe /i "TeamViewer_Host.msi" /qn CUSTOMCONFIGID=******* DESKTOPSHORTCUTS=1 APITOKEN=********** ASSIGNMENTOPTIONS="--alias %COMPUTERNAME% --group-ID g******** --grant-easy-access"

Does the assignment work if you are trying it this way?

Cheers,

Julia
Senior Support Engineer - 2nd level Support
Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button.
Posted by Martin_RB
Electron

Re: Automatic Rollout SCCM with API & Easy Acces / Group

Hey Julia,

thank's for fast response. Same Problem. I tried two computers, one fails, one success.

Do i have to clean up something before i try to install TV a second time? Check any Logs?

Greetings