Posted by Vorrin
Electron

Can't connect to a MacOS computer from a Windows one.

Hello, I've just downloaded the latest version of teamviewer from your site, on a Windows machine, and on a MacOS machine. I can connect from the MacOS to the Windows computer fine, but the other way around I get a 'The remote TeamViewer is running an old version which is out of date' error, so no connection at all. I have enabled TeamViewer to control the Mac PC in Security&Privacy, but that attained nothing. Did anyone encounter a similar issue?
5 Replies
Posted by Moderator Moderator
Moderator

Re: Can't connect to a MacOS computer from a Windows one.

Hi @Vorrin 

Thank you for your post. 

Can you please provide the version number of TeamViewer that you installed on the Mac?

Have a great day and all the best,
Natascha

Posted by Vorrin
Electron

Re: Can't connect to a MacOS computer from a Windows one.

Hi Natascha! 

It's 14.2.8352. I've tried the help-check for updates route, but that's also convinced this is the latest version! 

Regards!

Highlighted
Posted by Moderator Moderator
Moderator

Re: Can't connect to a MacOS computer from a Windows one.

Ok, should be fine so far. Thank you!

Would you mind to uninstall TeamViewer in the advanced options of the app? Please, in addition, clear all p lists in your library to make sure there is no remaining stuff from TeamViewer. 

Then reinstall TeamViewer directly from our official download page.

Hope this could help. Please let me know :) 
All the best,
Natascha

 

2 Replies
Posted by Vorrin
Electron

Re: Can't connect to a MacOS computer from a Windows one.

ok, will do, but for what it's worth, I had just installed teamviewer, from the same source you linked, with no previous installations on this machine! 

Posted by Vorrin
Electron

Re: Can't connect to a MacOS computer from a Windows one.

Urgh, doing the whole process again, did point me to the solution, I'm afraid this was a total PEBKAC (I had typed the partner id by hand, two digits were mismatched -_-).

I'd imagine the somewhat confusing error message might have been due to the resulting ID actually existing, and really running an older version of teamviewer! 

Thanks for your help, sorry for wasting your time!