Announcements

TeamViewer IoT is hiring! Check out the open positions here!

Highlighted
Posted by blithe
Photon

Harassment "Your partner uses a newer version of TeamViewer"

I was angry customer. Please end the harassment "Your partner uses a newer version of TeamViewer. Would you like to update TeamViewer now it etablish and connection". Is it really wrong that you are not able to make a program that will at least partially compatible between versions. We can work with customers who have legally purchased and other versions do not currently have any interest in the update.

1 Accepted Solution

Accepted Solutions
Posted by Former Staff Jonathan
Former Staff
Solution

Re: Harassment "Your partner uses a newer version of TeamViewer"

Hi blithe and bitflipper,

Thank you guys for your posts and welcome to the community!

Please check out the following thread for helpful answers from fellow TeamViewer users regarding being prompted to update to V12.

https://community.teamviewer.com/t5/TeamViewer-12/Why-am-I-forced-to-update-to-version-12/m-p/1203#U...

Hope this helps!

All the best,

Jonathan

Did my reply answer your question? Accept it as a solution to help others, Thanks.
5 Replies
Posted by bitflipper
Henagon

Re: Harassment "Your partner uses a newer version of TeamViewer"

Agreed. I just had a customer who'd just downloaded Teamviewer 12. I am on ver. 11.

I got a dialog telling me the other end was using a newer version, and would I like to upgrade. If I say no, I do not want to upgrade, it just gets into an endless loop and I cannot connect to the user.

If I say yes, it tells me I'll have to re-purchase Teamviewer.

Rock <-> hard place!

Are they telling me I have to pay again to keep using TeamViewer? **bleep**?

Posted by Former Staff Jonathan
Former Staff
Solution

Re: Harassment "Your partner uses a newer version of TeamViewer"

Hi blithe and bitflipper,

Thank you guys for your posts and welcome to the community!

Please check out the following thread for helpful answers from fellow TeamViewer users regarding being prompted to update to V12.

https://community.teamviewer.com/t5/TeamViewer-12/Why-am-I-forced-to-update-to-version-12/m-p/1203#U...

Hope this helps!

All the best,

Jonathan

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by bitflipper
Henagon

Re: Harassment "Your partner uses a newer version of TeamViewer"

Thanks for replying, Jonathan.

I have settled on a solution. I will provide my customers with a link to version 11 and ignore the annoying advertisements that pop up. Problem solved for now.

 

Posted by Tracy
Photon

Re: Harassment "Your partner uses a newer version of TeamViewer"

Can you not just get them to end the service for TV12 and then rerun your TV11 link?

Posted by Bob357
Digon

Re: Harassment "Your partner uses a newer version of TeamViewer"

I have Teamviewer 12.0.82953 on my mac.

When I try to connect I get this "Your partner uses a newer version of TeamViewer" message.

When I hit the 'update' button it tells me there is no newer version available!