Posted by Canneh
Digon

My mic is always auto adjusting itself even though all the options are turned off.

The problem I have when using TeamViewer is always, that my mic is adjusting its volume on its own. It's a huge problem since I am using custom settings so my colleagues don't always hear anything I do (such as typing itself).

I turned off and unticked all the settings that could be taking control of my mic/audio ports but the issue consists ONLY when using TeamViewer. I also turned the automatic function off and don't even use the mic on TeamViewer since we talk over another platform already. I really would like to know what causes this issue or how to stop TeamViewer from adjust my mic volume all the time. 

Huge thanks still to the software! Made uni collaborating much easier.

29 Replies
Posted by DomLan
Heptagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

Hi @Canneh,

I assume that you have correctly configured the MUTE system in TeamViewer.

You could check if your PC is equipped with an automatic sound mixing system. Find information by accessing the playback devices from the appropriate volume icon in the tray bar.

From here, with the right mouse button, make sure to view all devices (even hidden).

Do you find some automatic mixing device like this?

2017-04-30_19-49-29.png

Let me know.

Regards

Domenico Langone
MCSD: App Builder
Posted by Canneh
Digon

Re: My mic is always auto adjusting itself even though all the options are turned off.

Unfortunately not. 

 

 

Posted by DomLan
Heptagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

Hi @Canneh,

What are your settings in the Extras -> Options -> Remote Control?

Regards.

Domenico Langone
MCSD: App Builder
Posted by Canneh
Digon

Re: My mic is always auto adjusting itself even though all the options are turned off.

The first one translates into "Automatic".

Thanks for looking into my issue :).

 

Posted by DomLan
Heptagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

???

2017-04-30_21-18-34.png

Remove?

Regards

Domenico Langone
MCSD: App Builder
Posted by Canneh
Digon

Re: My mic is always auto adjusting itself even though all the options are turned off.

It's just the pre-set, that I can hear the other sides PC. Even when I turn it off when we start the transmission, it still auto-adjusts my microphone volume.

Posted by huminit
Electron

Re: My mic is always auto adjusting itself even though all the options are turned off.

i agree with you

Posted by Ryudo_Kaze
Henagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

I am having the same issue as described here.

I'm runing TeamViewer 12 on Windows 10 and I've already disabled exclusve application control over audio devices. But as soon as I run TeamViewer and start a session, my volume levels always slide to max gradually. I've already tested different settings in TeamViewer and disabled automatic noise threshold settings but that didn't change anything except the voice level being lowerd as soon as I talk.

It would be nice to have an option to turn this adjustment off, that is easy to access. I can't seem to find anything.

Posted by AtroposOrbis
Henagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

Okay, where is support on this???

This is incredibly frustrating! 3 weeks and no reply??

Posted by Canneh
Digon

Re: My mic is always auto adjusting itself even though all the options are turned off.

Since I got the time now and support has seen that 3 other individuals have the same problem, it is time to revive this issue (kind of).

As seen above, by the accompanied people above, the microphone volume keeps adjustin itself to really high levels as to where some microphones, like mine, are really hard to bear with. This volume setting doesn't just set itself in the Teamviewer communication, but actually in the SYSTEM. So the change is audible on every platform. If a video is really demanded for a precise reproduction, I will deliver. I think the description should be enough though.

Just a heads up: I tried everything suggested, I don't even use the microphone in Teamviewer, it is muted there. The issue is, if I want to COMPLETETLY disable it in the settings tab, it will disable it by the system, which disables it everywhere. Teamspeak and other voice communication platforms made sure this is handled seperately, in case you are thinking of a solution (I code quite a bit myself).

Thanks in advance to the support and everyone replying and have a nice day! (Your software is awesome nevertheless :) )

Posted by Flitskikker
Henagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

Same issue here. Recording volume (in my case Stereo mix) is automatically being adjusted and I can't find an option to disable that.

I use Stereo mix to reroute my pc audio to my tv and to record sound, so I have to re-adjust the settings after every TeamViewer use, which is almost daily.

Don't touch my settings please, TeamViewer!

Posted by bazli
Electron

Re: My mic is always auto adjusting itself even though all the options are turned off.

same here..

Posted by Matreciman
Henagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

I am having this issue also. It is very frustrating. Can we at least get a response if this will ever be fixed, or if I should find alternate remote software? I've been using Teamviewer for years, but this issue is a dealbreaker.

Posted by chicken-
Henagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

Well I'll post and hope they decide to respond because this is really annoying. Even if you turn the volume slider all the way down it doesn't change when you look at the audio device in windows Recording Devices. The only change that ever happens is it does mute if you choose to mute it in teamviewer but the volume slider is ignored. If I fix my volume in windows all I have to do is enter the audio options section of teamviewer options and it raises my mic volume to max immediately.

This is very annoying, it's been months and nobody has bothered responding to this officially.

Posted by signeduptopost
Photon

Re: My mic is always auto adjusting itself even though all the options are turned off.

This is a massive pain. I'm not worried about my volume sliders, I don't want Teamviewer activating my microphone/webcam when in use. I have all the relevant settings turned off / muted. My webcam light comes on when it's in use. I feel as if I'm being spied on! If I'm not sharing my microphone or webcam with anybody, why does my webcam light turn on every time I use Teamviewer?

It took me forever to find out what program was using the webcam because who on earth would suspect Teamviewer. Usually such a refined program, somebody has allowed this bug (or NSA surveillance 'feature'?) to drive away customers. I hope it's rolled-back soon!

Posted by NAM1025
Electron

Re: My mic is always auto adjusting itself even though all the options are turned off.

Just wanted to chime in and express my current hatred for TeamViewer because of this.

I'll probably end up moving to something else if this doesn't get resolved. Absolutely ridiculous.

Posted by Matreciman
Henagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

After many years of using Teamviewer this issue caused me to switch to VNC today.

Posted by Lmar
Electron

Re: My mic is always auto adjusting itself even though all the options are turned off.

Still no solution for this issue?

Posted by Canneh
Digon

Re: My mic is always auto adjusting itself even though all the options are turned off.

Yeah, apparently not reply and nothing in my inbox either... really sad.

I've already switched to alternatives but we will see what the future holds.

Posted by fredised
Henagon

Re: My mic is always auto adjusting itself even though all the options are turned off.

I do not have any solution to the issue with teamviewer volume control (or Slack, Skype for Desktop...).

But the application VolumeLock resolved the problem for me, allowing me to lock the mic volume to 50%.

https://www.actualsolution.com/

Also, not affiliated with Actual Solution, just a user of this application to resolve this problem.

Posted by Simonmicro
Electron

Fixed - dirty workaround

Okay, my friend found a dirty workaround:

1. enable Stereomix / CD in or other "useless" input device.

2. restore the default device seletion.

3. set [Stereomix / CD in or other "useless" input device] in Teamviewer

4. voilá

best regards,

Simonmicro

Posted by hwfanatic
Electron

Re: Fixed - dirty workaround

Is this never going to be fixed? Am I going to have to cancel my subsription and switch to another solution? **bleep**? It's 2019...

Posted by CliffordOost
Digon

Re: Fixed - dirty workaround

This doesn't work when you using the SIP phones.
Posted by CliffordOost
Digon

Re: Fixed - dirty workaround

One can only hope with enough people commenting that the developers will take note of this.
Highlighted
Posted by Moderator Moderator
Moderator

Re: Fixed - dirty workaround

Hi there, 

Thank you for your posts. 

Maybe the following workaround helps to fix your issue: 

Please right click on the speakers item in the tray menu --> Open "Sounds" --> Go to "Communication" and set the value to "Do nothing". Confirm the settings and try it again. 

For further questions, please do not hesitate to contact us again. 

All the best, 
Natascha

4 Replies
Posted by Canneh
Digon

Re: Fixed - dirty workaround

Hey there, inital thread creator here.

Didn't check this thread in a long time but "nice" to see that other people also had this issue and I'm not going crazy.

Sadly I already tried this solution way back then and it didn't work. I don't know though if you had considerable changes but 2 months ago was the last time I tried it. I even tried taking the permissions for audio from the TeamViewer.exe in a way - still did not work.

Posted by Moderator Moderator
Moderator

Re: Fixed - dirty workaround

Maybe you can change the audio settings in "Extras" --> "Options" --> "Audio conferencing" and set different "Default Communication Devices" for Voice playback and Voice input than you use for VoIP calls. 

Please let me know, if this helps. 

Best,
Natascha 

Posted by CliffordOost
Digon

Re: Fixed - dirty workaround

We have tried every option available and as soon as you run teamviewer it takes your microphone volume down in windows thus causing clints not to hear us over our voip phones.

We have tried every suggestion on the internet including this one so sorry we need the Team Viewer developers to actually look at this.

Posted by Moderator Moderator
Moderator

Re: Fixed - dirty workaround

Thanks for your reply.

If you are a customer, I recommend contacting our support team.

They can have a deeper look at what happens in your case or open a ticket for our colleagues in the 2nd level. 

Thank you very much and have a great day. 

Best, 
Natascha