Posted by Stewert
Henagon

No Connection To Partner

Ever since upgrading to v12 I keep getting the following error

No connection to partner!

Partner did not connect to router.

Erroer Code: WaitforConnectFailed

I have tried to connect with multiple devices to multiple machines. I even get the error from machine to machine.

If I keep trying sometimes it will connect or I will get another error stating that I have to wait for a bit before trying again.

Please Help.

47 Replies
Posted by kayla
Henagon

Re: No Connection To Partner

did you find a solution for this error? I am having the same problem!

Posted by Stewert
Henagon

Re: No Connection To Partner

I have not yet found a solution for this issue. I still get connections intermittently. Meaning that sometimes it connects, sometimes it doesn't connect.
Posted by Former Staff Jonathan
Former Staff

Re: No Connection To Partner

Hi Stewert and Kayla,

Thanks for your posts!

Sorry you are having trouble making connections. Basic trouble shooting steps include but are not limited to:

  1. Restart TeamViewer on both sides of the connection
  2. Uninstall the current application and install a fresh copy on both sides of connection
  3. Make sure internet connection on both sides is active

If you can try these steps usually it will correct the issue. If not please let me know.

All the best,

Jonathan

 

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by kayla
Henagon

Re: No Connection To Partner

Jonathan, 
 Thank you for your reply.
 the restart and uninstall steps have been done mulitiple times on each computer and it still has this error come up " No connection to Partner, Partner did not connect to Router, errorcode:WaitForConnectFailed" 

I am connecting with  a PC to a MAC computer if that has anything to do with it.
and ther is at times when I can connect but its more often that I can't connect then I can...

Posted by keyxmakerx
Henagon

Re: No Connection To Partner

I'm also having this problem, these are fresh installs as well. I have reinstalled to be sure. It is from an android phone > my linux pc. I've not had this issue till upgrading to v12. 

Posted by madbilly84
Henagon

Re: No Connection To Partner

the problem is when  we using the same ISP. If you get on internet via 4g (hotspot) from your phone. The program is working fine but with ADSL no..... i had the same problem and i found this solution for instant

Posted by keyxmakerx
Henagon

Re: No Connection To Partner

I've tried two different carriers, Google Fi and Earthlink, neither is working. I have ATT at the other location. 

Posted by madbilly84
Henagon

Re: No Connection To Partner

Try over 4G and don't​ bother for the other side.
With mobile app all things running ok to me
Posted by keyxmakerx
Henagon

Re: No Connection To Partner

Already tried, still not getting it to work. 

Posted by maksmms
Electron

Re: No Connection To Partner

Hi, i had similar problem. Then i open the log and see some special symbol before partner number.

It appears when i copy/paste number from any place, i entered number by my keyboard and connect was successfull. Hope it helps to someone.

Highlighted
Posted by chris_tv
Electron

Re: No Connection To Partner

If running on Linux, try restarting the TeamViewer daemon, e.g. 'service teamviewerd restart'. I can't remember where I saw this suggestion, but this works for me. The explanation was that it's caused by a race condition. Hope it helps someone.
13 Replies
Posted by teopas11
Electron

Re: No Connection To Partner

I hane the same problem. Impossible to connect with my partner. I have already tried all the proposed solutions but nothing happened. I don't know what else to do!

Posted by OaklandMike
Henagon

Re: No Connection To Partner

I downgraded to version 11 and it's working fine for me now.

Here's the previous versions link: https://www.teamviewer.com/en/download/previous-versions/

Posted by MBS
Digon

Re: No Connection To Partner

 Restarting the service worked for me too.  Problem is, I can't do that from home, so I still cannot remote in. Any further ideas?

 

 

 

 

 

 

 

 

Posted by lordoftears
Digon

Re: No Connection To Partner

I have the same identical problem and I am unable to restart the machine as it is in a site without people. I solved (just now, I have to verify it again) by logging in putting the ID number instead than clicking in the remote PC icon on my contacts account.

Posted by lordoftears
Digon

Re: No Connection To Partner

I was wrong, it was a coincidence. I have not found a way to connect to a non responding remote computer.

Posted by jimbaum
Photon

Re: No Connection To Partner

I have same issue on ver 12. It all happened when my Win10 computer was having some sort of internet connectivity problems. At that time, I uninstalled ver 11, and installed ver 12.  Worked for about 3 weeks until this problem.

Apparently the computer again, is having connectivity problems. It cannot open web pages, etc.  Perhaps this is some sort of Windows problem after an update?  I have win 10 that was upgraded from Win 7 about a year ago.

Posted by bartlanz
Heptagon

Re: No Connection To Partner

If the computer does not have internet access, TeamViewer will not work either.

I did have one laptop that got an update to Windows 10 that broke its internet access, I don't know how or why though. I rolled back the windows update and it came back.

If my post was helpful, Please throw me a Kudos.
If my post fixed your issue, please mark it as the solution to help the next person find a solution quickly.
Bart Lanzillotti
We Do IT USA
www.wedoitusa.com
Posted by lordoftears
Digon

Re: No Connection To Partner

My remote computer has no connectivity problems when this issue happens.

I also tried to use a VPN but it did not solve the issue.

Posted by ColinK
Henagon

Re: No Connection To Partner

Just started happening to me. Win10 desktop (12.0.78313) to Win10 Tablet. (11.0.76421

Same error message as others but chat works OK. 

Update to 12 failed, removed and installed 12 (not easy on a tiny tablet with out remote access).

Same erorr on 3 attempts. Then suddenly it worked.

Now there is no popup of chat notification, but chat still works. Show notifications enabled on Desktop and Tablet.

Disconnected, tried to reconnect, same error, then seemed to conect without me doing anything (I may be wrong about doing nothing).

Second tablet on V11 still working OK

 

Posted by wrswaim
Trigon

Re: No Connection To Partner

Interesting this has been an ongoing issue since March of this year and yet no solution has been found.

Both of the pc's I access remotely show up as ready to be accessed (they have been running on unattended access always) and yet every time I connect it says "No conection to partner" - once in ever so many attempts on both pc's one will say "ready to connect" but it just stays there, the screen of the other pc never comes up.

I need a fix on this STAT!  Thank you.

 

 

 

Posted by Cyuena
Henagon

Re: No Connection To Partner

This past week, I started having this problem suddenly, trying to connect to one of my PCs (it is running Win10). There has been no major changes to that machine/router/internet that I know of, it is sitting idle (not torrenting) at the moment, and where Teamviewer had been working fine before.

During testing this morning, it actually connected 2 times and I was able to use that remote PC as usual. So it does work! But as soon as I disconnect, I have to try many times to reconnect again and I keep getting the same error message "No connection to partner! Partner did not connect to router. Error Code: WaitforConnectFailed".

I have several devices on TeamViewer:
- Desktop at home (the problem PC) running Win10.
- Wife's laptop at home, on the same router, running Win7.
- Desktop at my in-laws running Win 8.1.
- Laptop at my in-laws running Win7.
- 2 Android smartphones.
- Parent's laptop running Win10 and 6,900km away over the Pacific Ocean.

All the PCs and laptops are on wired networks (not wifi) and currently using TeamViewer 12.0.81460, whereas the smartphones are on 12.3.7343CL. They all have had no problems connecting to each other for many years, except just recently for that one PC.

Any updates from the TeamViewer team on this issue? Or anyone else have a suggestion? Much appreciated for all your support. Cheers~

Posted by Cyuena
Henagon

Re: No Connection To Partner

Update: I was able to connect the two desktops 3 times in a row! Pushing my luck, I tried using my smartphone, but then got the same error as before. And now I have lost all connectivity to that problem PC again with any device. It almost seems like that PC is sporadically busy, but it should be just sitting idle. Is there a way to check the internet traffic for a PC?

Posted by lordoftears
Digon

Re: No Connection To Partner

Dear Cyuena,
Unfortunately I do not have any good answer yet. Recently I had less error episodes but it persists. I run:
- Win 10 desktop in my institute (the computer with issues)
- WinXP desktop in my institute
- Win10 Desktop at home
- Win7 laptop st home
- Win10 work laptop

Only on 1 computer I experienced this problem.

Emanuele
Posted by jliggero
Henagon

Re: No Connection To Partner

That's good advise, reboot and reinstall? How about why it happened in the first place. I have the same problem and the remote computer is a thousand miles away. How about a better solution. the purpose of teamviewer is REMOTE connection. 

Posted by MBS
Digon

Re: No Connection To Partner

I went back through the remote manual and found one setting (the WOL button) that was not correct. When fixed, it worked and has been working ever since. I would have sworn that it was set correctly...but it wasn't. So my best advice is check every setting again. It is much more likely a setting than a corrupted program.

Posted by MBS
Digon

Re: No Connection To Partner

One more thing - don't forget the Windows settings. I have to leave my computer running, not sleeping, for it to work. I know it isn't supposed to work that way, but that is what it does.

Posted by goodevoice
Electron

Re: No Connection To Partner

Hey Guys! Just solved the same problem... if your devices are on the same network, you have to change the LAN setting from deactivated to "Accept" That solved it for me!

Hope that helps you too. I think when it updated it changed some default settings..so I'd start there.

Posted by lordoftears
Digon

Re: No Connection To Partner

Thank you for the information goodevoice.

Unfortunately I am not on the same network but i have to control the target computer from a remote position. Anyway, it seems that in the last period it is working well, I haven't experienced any troubles for many days until now.

Posted by jradwan
Digon

Re: No Connection To Partner

I'm running into this problem a lot as well!

Posted by dn1
Henagon

Re: No Connection To Partner

My solution involves getting someone to manually run teamviewer on the remote computer, get past the UAC screen if it pops up, then it works fine while teamviewer is active. I tried removing UAC The only real working solution seems to be to downgrade back to version 11.
Posted by meevo_tv
Photon

Re: No Connection To Partner

I just force quit TV and started it back up and all is well.  Maybe something in memory was hanging up.

Posted by Edgerman
Photon

Re: No Connection To Partner

Disable ipv6 con client and server computers.

Posted by Edgerman
Photon

Re: No Connection To Partner

Posted by kyoq
Henagon

Re: No Connection To Partner

I have tested TV v12 on:
-Ubuntu 17.10
-elementary OS
- Fedora

It all gives the same result (translated from Polish)
Partner is not connected to router
Error Code: WaitforConnectFailed

It is a pity that TV is not that much supported under Linux.

It works on win7 & 10 on the same hardware.

EDIT: Under mint with kernel 4.10.0-38 it worked once and now it is the same. Like something was updated and it stopped working.

Posted by CaptGadget
Henagon

Re: No Connection To Partner

I finally found the fix for my particular problem by logging in with XOrg vice Wayland.

https://askubuntu.com/questions/961304/how-do-you-switch-from-wayland-back-to-xorg-in-ubuntu-17-10

I had to log off the session, select my username, then the gear shows up. Select Ubuntu XOrg, put in password and log back in. Re-attempted to connect to PC from my phone, and bam, it worked. There is some explination about why on askubuntu, but I just know it worked for me. 

Posted by CaroS
Electron

Re: No Connection To Partner

Yes, this worked perfectly for me. Thanks!

Posted by kyoq
Henagon

Re: No Connection To Partner

Hi,

This also worked for me. But isn't it a workaround rather than a fix?
When could we expect an updated working version?

BR

Adam

Posted by Rekcin
Neutron

Re: No Connection To Partner

Getting the older version worked for me. Thanks so much. :)


@OaklandMike wrote:

I downgraded to version 11 and it's working fine for me now.

Here's the previous versions link: https://www.teamviewer.com/en/download/previous-versions/


 

Posted by CardinalChaos
Electron

Re: No Connection To Partner

My only work around is to connect to my router (flashed w/ddwrt and internet facing via ssh) remotely and reboot it. Then I can make a connection inbound again to the devices (specifically in this case a win10 desktop) in that network. Don't seem to remember this error before teamviewer v12.

Posted by Abestr
Digon

Re: No Connection To Partner

I have this issue since last week, connecting to my TV 13, I did restart and it worked a few times, and now again I can't connect, it shows online but I'm getting the error of no connection to router, I also have another desktop on same network same router with separate TV account and it does work, so it's not a router issue.
Posted by JimWh
Henagon

Re: No Connection To Partner

This sometimes occurs for me when I use Windows to direct the remote PC to Restart via the Windows Start button.  The PC hangs up before completing the shutdown.  When the problem occurs I can expect to see "Connecting to Partner" briefly before the "Ready to Connect" status message returns.  Eventually the PC reaches the point that it reports the WaitforConnect Failed message.  I have to get someone at the remote location 1.  to shut the PC down -- if necessary by pressing the power off switch and waiting a few seconds before pressing the switch again to power the PC on, and 2. sometimes I have to also ask that the router be rebooted.  One or both of these actions (taken seqentially) has so far been sufficient for my needs.  Perhaps a Net User command script (to run remotely on another PC on the network) would direct the PC to restart. Then, if that isn't sufficient, using remote administration of the router at the remote location (again through another PC on the same network) would allow the router to be rebooted without anyone helping at the remote location.

Posted by DFWKen
Trigon

Re: No Connection To Partner

STill happening for me trying to connect to either of two computers at a client's site over a thousand miles away.   We've tried booting the remote computers.  We've tried updating their QuickSupport to TV14.  I've tried TV 11 and TV 14 on my end (I have a paid subscription).  Nothing is helping and my client is losing confidence in me because of it.  It's out of my control!

Need help.  

Posted by melvin4u
Electron

Re: No Connection To Partner

I had the same issue too. I started noticing this after I installed xrdp. Uninstalling it and restarting the machine fixed it 

sudo apt remove xrdp

Posted by harold3212
Digon

Re: No Connection To Partner

There are many reasons that become the cause of Partner did not connect to router error. The can probably be Network connection is triggering the problem, The newest TeamViewer version is not supported by one (or both) computer, Microsoft Store Teamviewer application is buggy and many other reasons. Here for the sake of users’ convenience, we have some solutions to resolve this issue.

1) Downgrading to an old version:
i). To do it tap Windows key + R to open up a Run dialog box, write “appwiz.cpl”, tap Enter to start the Programs and Features menu. You will find many more solutions by tapping https://appuals.com/fix-partner-did-not-connect-to-router-in-teamviewer/
ii). AS second step Inside the option of Programs and Features, find the TeamViewer installation, right-click and press on the option named Uninstall.
iii). Then go for the commands that are on the screen and reboot your system.
iv). Now in the next startup go for the page of previous versions, tap on the Version labeled 11.X tab, tap on TeamViewer to download the installation executable.
v). As second last step go for the install commands to install the previous version on both systems.
vi). At the end reboot both systems and re-create the connection. This would probably fix the error.

2) Utilizing the Teamviewer desktop application on both computers:
i). In the start download TeamViewer button to begin the download of the installation executable.
ii). After the downloading process completes open the installation executable (TeamViewer_Setup.exe) and go for the commands that pop up on the screen to finish the installation.
iii). As third step tap Yes to grant administrative privileges when stressed by the UAC. iv). At the end when the desktop version of TeamViewer is installed on both systems, restart both and check if the issue has been resolved.

Posted by SGI-
Electron

Re: No Connection To Partner

Same issue here.  Both PC's on TV.14.  Uninstalled, reinstalled several times.  Attempted both plugging in ID and password and using the Session Code - Invite option.  Turned off Windows Firewall for all networks.  This user is several hours away so I cannot get physical access to his PC.  **Third Party Product** works, which is how I can work on his PC, but I need to get TV working.  Any ideas for fixing would be greatly appreciated.

Posted by mayank5
Electron

Re: No Connection To Partner

I logged out of and logged back in to all my devices and it got fixed