Announcements

Would you like to co-innovate with us? If so, we’d like to invite you to become product development partners with us. Read more about it in our announcement Launch of the TeamViewer User Focus Program

Posted by pedro_unity
Photon

TeamViewer 13.1 won't start on my Mac

Hi Jeremy, 

In my specific case, running MacOS 10.13.3 (17D47), Teamviewer (v13.1.2991) is not even allowing me to start. I double click after installation,  follow and accept any prompts for action on my part. Once installed, I cmd+spacebar (to pop spotlight bar and search) to start Teamviewer.app. The software will briefly flash in my dock and will appear in my toolbar as an active software very briefly and will disappear before I manage to see any UI of any kind. 

Thoughts? Ideas? Tips? 

10 Replies
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Re: TeamViewer 13.1 won't start on my Mac

Hi @pedro_unity, did you have a previous version of TeamViewer on this Mac before you installed 13.1.2991? Or is this the first version you've installed on it?

Can you try manually removing TeamViewer using the steps described here, making sure to carefully delete the .plist files as described?

Afterwards, try installing it again. Does it work now?

Regards,
Jeremy
TeamViewer Quality Assurance Engineer
5 Replies
Posted by Snakedog116
Henagon

Re: TeamViewer 13.1 won't start on my Mac

Hi, I tried completely removing Teamviewer (I have an app called AppCleaner which finds all preference and library files and cleans them all out). I also followed the instructions on Teamviewer's website to delete the couple of library files they recommend deleting.

 

I then rebooted, and reinstalled Teamviewer. I'm still having issues. If I setup unattended access during the install process then Teamviewer will bounce in the dock, show up in the taskbar, and then quit. If I don't setup unattended access it just bounces once or twice in the dock and quits. (And gives me an apple error report).

 

Any help would be appreciated.

Posted by JavierEslava
Photon

Re: TeamViewer 13.1 won't start on my Mac

I have the same problem. I have not been able to resolve it, either.

We need professional help
Posted by 6Zayn
Henagon

Re: TeamViewer 13.1 won't start on my Mac

Having the same problem. I hope to ge a quick solution in this forum.

Regards,

Zayn.

Posted by Snakedog116
Henagon

Re: TeamViewer 13.1 won't start on my Mac

I ended up doing a reinstall of my Mac OS. It's non-destructive (all the apps and files stay) and that fixed teamviewer.

Posted by danrademacher
Henagon

Re: TeamViewer 13.1 won't start on my Mac

I have a similar pattern, though now it has gotten worse.

TV was consistently starting up when I first started my Mac, but if I quit, it would never start again, until I restart.

I tried the full manual TV uninstall/reinstall a couple times, including deleting the Plist items. No difference. Also reinstalled MacOS, no difference It does bounce a couple of times, then disappears.  

So then I restarted, opened TV and tried using the Preferences method of uninstalling. Then reinstalled, and now TV won't start even the first time, so not at all.

Consistent errors like this: 

default 21:35:01.829210 -0700 launchservicesd CHECKIN:0x0-0x53053 964 com.teamviewer.TeamViewer
default 21:35:01.931374 -0700 TeamViewer -[TVProcessLock initWithScope:name:lockImmediately:]: You don’t have permission to save the file “Cleanup At Startup” in the folder “Caches”.
default 21:35:01.934082 -0700 TeamViewer A TeamViewer instance is already running.
error 21:35:02.013702 -0700 TeamViewer AEGetDescData of non-desc type 'reco' not a good idea
default 21:35:02.020049 -0700 TeamViewer OSErr AERemoveEventHandler(AEEventClass, AEEventID, AEEventHandlerUPP, Boolean)(aevt,quit handler=0x7fff52baf52c isSys=NO) err=0/noErr
default 21:35:02.020289 -0700 TeamViewer OSErr AERemoveEventHandler(AEEventClass, AEEventID, AEEventHandlerUPP, Boolean)(GURL,GURL handler=0x7fff52baf52c isSys=NO) err=0/noErr

Looking at Activity Monitor, I see this process: /Applications/TeamViewer.app/Contents/MacOS/TeamViewer_Service

Which is impossible to quit. Maybe I need to disable that somehow to get this app to work again?

Also tried downgrading to TV 12 installer. Same results

Posted by danrademacher
Henagon

Re: TeamViewer 13.1 won't start on my Mac

Hmm. I have a similar pattern. ONly now it is worse. TV was consistently starting up when I first start my Mac, but if I quit, it would never start again, until I restart.

I tried the full manual TV reinstall a couple times, including deleting the Plist items. No difference. Also reinstalled MacOS, no difference.

It does bounce a couple of times, then disappears. Looking in Console, I see errors like this:

default	21:35:01.829210 -0700	launchservicesd	CHECKIN:0x0-0x53053 964 com.teamviewer.TeamViewer
default	21:35:01.931374 -0700	TeamViewer	-[TVProcessLock initWithScope:name:lockImmediately:]: You don’t have permission to save the file “Cleanup At Startup” in the folder “Caches”.
default	21:35:01.934082 -0700	TeamViewer	A TeamViewer instance is already running.
error	21:35:02.013702 -0700	TeamViewer	        AEGetDescData of non-desc type 'reco' not a good idea
default	21:35:02.020049 -0700	TeamViewer	        OSErr AERemoveEventHandler(AEEventClass, AEEventID, AEEventHandlerUPP, Boolean)(aevt,quit handler=0x7fff52baf52c isSys=NO) err=0/noErr
default	21:35:02.020289 -0700	TeamViewer	        OSErr AERemoveEventHandler(AEEventClass, AEEventID, AEEventHandlerUPP, Boolean)(GURL,GURL handler=0x7fff52baf52c isSys=NO) err=0/noErr

I then restarted, started TV and tried the Uninstall via preferences, then reinstalled. Now it won't start even after I restart the machine, same sort of console errors.

Lookng at "A TeamViewer instance is already running" in Console messages above, I checked Activity Monitor and found a TeamViewer_Service, whose parent is launchd. So a daemon, but I can't see how to disable that, if it is even the problem.

I even tried downgrading to TV 12 and got the same results.

Not sure what else to try here.

Posted by moore
Photon

Re: TeamViewer 13.1 won't start on my Mac

I am having the same issue. Is this going to get resolved soon??

Posted by danrademacher
Henagon

Re: TeamViewer 13.1 won't start on my Mac

I got a brief reprieve by downgrading to TV12 -- after a couple more restarts, I was able to remote in. But then today TV decided that since I have 13 on my PC, I could no longer use 12 on my Mac. So I had to try the upgrade again, still doesn't work.

We're paying for TV as part of our adoption of NinjaRRM and we planned to drop our premium **Third Party Product** as a result, but after lots of successful testing of TV and finding it better than **Third Party Product**, suddenly I can't use TV at all. Very discouraging

Posted by danrademacher
Henagon

Re: TeamViewer 13.1 won't start on my Mac

Latest I used `launchctl remove` to try to prevent that daemon from starting up, then tried  to kill it with GUI Activity Monitor and commandlin:

1638 ??         0:00.54 /Applications/TeamViewer.app/Contents/MacOS/TeamViewer_Service -Module Full

Eventually tried a sudo kill, but still it wouldn't die. Not even sure what that would do, but seems like I ought to be able to completely turn this service off if I want to