Read this article in ChineseFrenchGerman | Japanese | Spanish


This article applies to all TeamViewer IoT users.

The TeamViewer IoT solution has been verified to be compatible with the following platforms/operating systems:

TeamViewer IoT Agent

Platform

As Tested on:

Operating System / Kernel

Example Devices

TeamViewer IoT Agent Version

ARMv7 HF

Raspbian Jessie 4.9

Raspbian Stretch 4.9

Raspbian Stretch 4.14

Raspberry PI II,III

Samsung Artik 530S

1.0.46 - Latest

ARMv7 el

Raspbian Jessie 4.9

Raspbian Stretch 4.9

Raspbian Stretch 4.14

   1.1.102- Latest

ARMv5 HF

Raspbian Jessie 4.9

Raspbian Stretch 4.9

Raspbian Stretch 4.14

Raspberry PI

1.0.46 - Latest

ARMv5 el

Raspbian Jessie 4.9

Raspbian Stretch 4.9

Raspbian Stretch 4.14

 

1.1.102- Latest

Intel x86-64 (AMD64)

 

Ubuntu 16.04 LTS

Ubuntu 17.10.1

CentOS 7.5.1804

Intel 64 Bit PCs

*Windows Subsystem for Linux (WSL) 

1.1.102- Latest

Intel x86-32 (i386)

 

Ubuntu 16.04 LTS

Ubuntu 17.10.1

CentOS 7.5.1804

Intel 32 Bit PCs

*Windows Subsystem for Linux (WSL) 

1.1.102- Latest

 * Via TeamViewer IoT Labs 
 

Note: To identify the version of your agent, execute the following command on your IoT Device (an error, or no result, indicates an older version of the agent is installed): 

sudo teamviewer-iot-agent info

 

TeamViewer IoT Cloud

  • Browser Compatibility
    • Chrome (versions released within last 6 months)
    • Firefox (versions released within last 6 months)
    • Edge (versions released within last 6 months)
    • Internet Explorer 11(or higher)
    • Safari (versions released within last 6 months)

TeamViewer IoT Client for Remote Access

  • TeamViewer IoT Remote Access is currently available via TeamViewer Client v13.1(or higher) for Windows.
    • Note: Internet Explorer 11 is required.

Version history
Revision #:
28 of 28
Last update:
‎19 Jun 2019, 4:27 PM
Updated by:
 
Labels (1)