Announcements

TeamViewer IoT is hiring! Check out the open positions here!

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

Hi @mcoates 

Could you tell your Synology model?

Posted by mcoates
Henagon

Re: I dont even get an ID or password ?

Thank you its a 218J model   The cheap entry level home unit

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

@mcoates 

It should run perfectly on DS218j. Is the package in running state in package center? Which package have you taken? And could you reinstall it and check again.

Posted by avogadro23
Photon

Re: IoT Remote AppControl solution and Synology NAS boxes

Wow, I wasted 2 hours trying to get this to work, only to realize that buried in the fine print was the statement that this would not work with the Mac TeamViewer client.  Way to bury the lead!  Please call more attention to this, as it is not a minor detail!

Posted by KCtheDJ
Photon

Re: IoT Remote AppControl solution and Synology NAS boxes

I am able to use Teamviewer in Parallels on my Mac to access all of our Synology's with Teamviewer. Minor inconveince but doable.

Do you have Parallels that you can try?

Posted by ar0na
Henagon

Re: I dont even get an ID or password ?

hi,
i have the same problem as mcoates.
My DS116 also doesn't get an ID or password. I use the the 1.1.1227 armv7 package. In the Package Centre is Teamviewer always shown as ready to start so the service isn't running. When i try to start Teamviewer, the status doesn't change.
any ideas?

Posted by mcoates
Henagon

Re: I dont even get an ID or password ?

I eventually got it to work, you just keep closing it down and restarting and after about three times it will come up with a username and password for you.

Be aware however as soon as you add it to your list of trusted devices it then goes off and demands you upgrade to a mobile licence !   I already have two business licenses and its wanting me to buy something else which I don't want and probably don't need. It refuses to connect unless you purchase a mobile licence which is probably something stupid like $40 a month. As soon as I saw this I just deleted it from my NAS

Posted by ar0na
Henagon

Re: I dont even get an ID or password ?

i already tried that (also reinstall), but no luck ...

Today i check the Log Files and i could only find 1 entry:

2019-05-20T10:11:02+02:00 backup synoscgi_SYNO.Core.Package.Installation_1_install[8336]: pkgtool.cpp:3033 Package TeamViewer stops but service pkgctl-TeamViewer start

any ideas?

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?


@mcoates wrote:

Be aware however as soon as you add it to your list of trusted devices it then goes off and demands you upgrade to a mobile licence !   I already have two business licenses and its wanting me to buy something else which I don't want and probably don't need. It refuses to connect unless you purchase a mobile licence which is probably something stupid like $40 a month. As soon as I saw this I just deleted it from my NAS


That has been a bug and we hoped we fixed it some time ago. No mobile license should be required for connecting to NAS systems. Is this still happening to you? If yes, please contact support so we can fix it for you.

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

Hello@ar0na 

I don't understand why its not working on your device. Do you have access to Synology Terminal (from Linux or Windows machine)?

Posted by ar0na
Henagon

Re: I dont even get an ID or password ?

hello arpitjindal,

sure i have a ssh connection. what do you need?

Posted by mcoates
Henagon

Re: I dont even get an ID or password ?

Hello, yes I have reinstalled the program on two separate devices and it is still demanding I have a mobile license even though I have two separate business licenses. The bug is still there and I have put a claim through the support system of your website. Thank you Michael

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

Hello @mcoates 

Please contact to our support system. It should never ask for any kind of additional license.

Could you also please tell me your Windows TeamViewer version?

Posted by jnjsdad
Photon

Re: IoT Remote AppControl solution and Synology NAS boxes

Thanks for the work.  Be sure to let us know when you have this working on platforms other than Windows. 

Posted by TeamViewer Staff
TeamViewer Staff

Re: IoT Remote AppControl solution and Synology NAS boxes

Hi @jnjsdad 

Yes, it will be announced when we support connections from other platforms.

Posted by F1nchy
Digon

Re: IoT Remote AppControl solution and Synology NAS boxes

I use Teamviewer for personal use only, just at home and for occasionally accessing a couple of family members' PCs to help them with problems. I have a Synology NAS so thought I'd try the TM app for it, but after trying to run it tells me I need a license, and I also now have messages flashing up on my PC saying I am using it for commercial use!

Firstly, should I need a license to use it on a Synology NAS? 

And secondly, how do I make sure my TV account IS set to personal use only? 

Thanks

Posted by carstenpohlmann
Henagon

Re: IoT Remote AppControl solution and Synology NAS boxes

When will Teamviewer 14 be available ? 

Posted by TeamViewer Staff
TeamViewer Staff

Re: IoT Remote AppControl solution and Synology NAS boxes

Hi F1nchy!

You should be able to access your Synology with your free license just fine. If you are incorrectly recognised as a commercial user, please contact our support so they can fix that for you. If you are asked for a license while connecting, please also open a support ticket with your log files (from the Synology and from your client system) attached.

Posted by F1nchy
Digon

Re: IoT Remote AppControl solution and Synology NAS boxes

Thanks for the reply. I've reinstalled TV on the Synology but when I  try to access it tells me I'm using it commercially still.

What's the easiest way to contact support? I can't contact via the website as I am a private user and it won't let me submit a ticket without a license!

Posted by Aktarus
Henagon

Re: I dont even get an ID or password ?

Hello Group,

I just installed the beta version on my DS412+ ...

 

I have an ID but no password and I can't define one by myself ...

If i click "download support information" I got an error

The "remote Terminal" switch is OFF and gray ..unable to avtivate it ...

What's wrong with my team viewer ??

MERCI :)

Posted by mickwish
Digon

Re: I dont even get an ID or password ?

Is there a plan to update the TV in Synology devices to version 14? Seems I have upr-graded all of my computrs and can't connect to the DS218j. Should the Synology package (beta) work, or should I manually install the TV package?

 

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

Hi@Aktarus 

Are you still facing this problem?

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

@mickwish 

It should work with the current package. What is the error you are getting?

Posted by Aktarus
Henagon

Re: I dont even get an ID or password ?

YES, it's still the same this morning .. :(

I got only the ID .. no password .. and If i try to connect tho this ID from another computer, I got an error ...

Posted by mickwish
Digon

Re: I dont even get an ID or password ?

I can add to my computers ok but then it fails to connect. It pops up a box to say upgrade it.
Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

@mickwish 

Could you post the screenshot?

And also, have you assigned the device to your account? For more information about the assignment process, read the first page of this forum

Posted by ThreadRipper86
Henagon

Re: I dont even get an ID or password ?

I second that issue - TV@Windows is simply unable to accept the password provided by TV@Synology, see:

image (5).png

@_Andreas_/ @arpitjindal please, once and for all, fix this mess!

Posted by bazingaa
Electron

Re: I dont even get an ID or password ?

I didnt properly understandyour probem

Highlighted
Posted by ThreadRipper86
Henagon

Re: I dont even get an ID or password ?

How come?

The darn password, when entered into the "Assign to account" box, is declared wrong, hence no assignment possible, hence no connection possible.

I'm just fed up with how bad this is developed. Calling it beta, not issuing any update on weeks or even months and simply letting users on their own.

Oh and those g-o-d-d-a-m-n captchas, always requiring about 5 or more rounds - as if 2FA wouldn't be enough to secure - and proof! - that I'm a) a human and b) valid user.
Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

Hi @Aktarus 

At the moment I don't have any clue why password is not showing up. I don't see any reason in which this would happen. The only thing I could ask you to check from your side, at the moment, is that in your settings "protection against cross-site" is activated which you could find in "Control Panel"->Security ->"Improve protection against cross-site request forgery attacks" .

I would be needing more time for this. Meanwhile, you could directly take the serial number of your synology device("control Panel" -> "info center") for the password and assign the device to your account.

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

Hi @mickwish 

If you are still facing the problem then could you please post the screenshot of the error?

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

Hi @ThreadRipper86 

Could you please send me the logfile. To download the logfile, click on the "Download Support Information". Also, are you using the actual Synology device or the virtual DSM? If it is virtual DSM, then it is not supported by us.

Please download the logfiles twice, one before the making the assignment and one after the error happens due to the assignment failure.

Posted by TeamViewer Staff
TeamViewer Staff

IoT Remote AppControl solution and Synology NAS boxes

Hello All TeamViewer Users,

Final TeamViewer package has been released for Synology, available directly from Synology package center. This package includes:

  1. Improvement in Remote Terminal
  2. Increase in performance.
  3. Minor bug fixes

Please download/update your Synology's TeamViewer package.

Enjoy :)

Posted by mickwish
Digon

Re: IoT Remote AppControl solution and Synology NAS boxes

Thank you! Now TV works as expected with my DS218j.  :)

 

Cheers

Mickwish

Posted by ThreadRipper86
Henagon

Re: I dont even get an ID or password ?

@arpitjindal
> If it is virtual DSM, then it is not supported by us.

I guess that makes downloading log files unnecessary. While it's technically nearly equal, you opted for not supporting Virtual DSM. Great, really.. not!
May I at least ask what's the ETA for such support?

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

Hi@ThreadRipper86 

At the moment, We don't plan to support virtual DSM.

Posted by Sniper8952
Henagon

Synology 1512+

Is the Synology 1512+ supported? Which version i have to download it?

Posted by TeamViewer Staff
TeamViewer Staff

Re: Synology 1512+

Hi @Sniper8952 

The new version is now being added in Synology package center. You could directly install it from there.

Posted by Sniper8952
Henagon

Re: Synology 1512+

Hi arpitjindal

If i install it, i can't connect with my PC Teamviewer to the Synology Teamviewer Server. My Computer can't find the Server.

 

Posted by TeamViewer Staff
TeamViewer Staff

Re: Synology 1512+

Hi @Sniper8952 

Could you tell me what error are you getting? And also how are you connecting to it? Did you assign the device to your account first?

Posted by Sniper8952
Henagon

Re: Synology 1512+

A connection could not be established

Eine Verbindung konnte nicht hergestellt werden.

I connect in the same network.

Posted by TeamViewer Staff
TeamViewer Staff

Re: Synology 1512+

Hi @Sniper8952 

Are you facing this problem always? So, not even once you are able to connect to your device? If that is the case, then please download the logfiles by clicking "Download Support Information" and directly send it to me.

Posted by Patoune
Electron

Synology 1019+

Same problem, no ID and no password on 1019+.
Restart, reinstall app, same problem


Capture d’écran 2019-07-24 à 16.26.34.png

Posted by xv34d
Electron

Re: Synology 1019+

same here

Posted by ThreadRipper86
Henagon

Re: I dont even get an ID or password ?

@arpitjindal,

couldn't reply sooner, sorry about that.

Yes, it's a virtual DSM, hence any logfile is probably obsolete.

Nonetheless, that VM, together with a couple more VMs, runs on a 716+II DSM to comply with SOC (separation of concerns, i. e. 1 VM per concern, e. g. DBs, website files, webserver, etc.) which helps minimize both, security vulnerabilities and admin tasks like updates.

I therefore request immediate support for virtual DSM as it's almost identical to any "real" DSM.

Posted by kc6108
Henagon

Operating System Health Monitoring

Is Health Monitoring supported on Synology devices? If so, how does one go about activating Operating System Health Monitoring on a Synology DS1812+ for example?

FYI, we are running version 2.3.7 of TeamViewer on the NAS.

Posted by AndrewRH
Electron

Re: IoT Remote AppControl solution and Synology NAS boxes

Is there a verssion that supports Synology NAS DS413 (Freescale chipset)?

Thanks in advance,

~Andrew~

Posted by Tender
Henagon

Re: IoT Remote AppControl solution and Synology NAS boxes

I asked 1 year ago by when will come support for macOS and Android. I has been said it is on the roadmap. 

Any news on that ?

Posted by TeamViewer Staff
TeamViewer Staff

Re: I dont even get an ID or password ?

Hi @ThreadRipper86 

Thanks for the use case. We will look into it and try to find the solution as-soon-as-possible.

Posted by TeamViewer Staff
TeamViewer Staff

Re: Operating System Health Monitoring

Hi @kc6108 

Operating System Health Monitoring is not supported on Synology Device.