Posted by JCTech
Electron

Version out-of-date: Update the remote Teamviewer - Running verison 14

I am getting an error that the remote Team Viewer is running an old version which is out of date.  Therefore you cannot connect to this Version anymore.  I have installed the updated version 14.3.4730 on both the main computer and remote computer.  Both running version 14.3.4730.

So I can NOT connect to remote computer via the "Remote Control - Prompt for confirmation" method. This method gives me the out of date error.   Instead, I can only remote control via the "Windows Authentication" method.

Who Me Too'd this topic