teamviewer.com link icon
or
Ask The Community

Install Script Fails to Assign To Account w/ CustomConfigID

I've been working on creating an installation script so that I can automate the installation as much as possible. I seem to be running into an issue where if I try to include CUSTOMCONFID, that the installation will not join my account. 

I've tried putting CUSTOMCONFIGID in front of & behind the APITOKEN value and that does not seem to matter. If I remove CUSTOMCONFIGID, the installation & account assignment works, but the GUI is not branded the way we want. Am I missing something?

msiexec.exe /i "D:\Software\TeamViewer_Host.msi" /qn /norestart /log output.log CUSTOMCONFIGID=1234567  APITOKEN=TOKEN DESKTOPSHORTCUTS=0 assignmentoptions="--alias %Computername% --grant-easy-access true"

Comments

  • I'm glad it's not just me. I've been struggling, working with this off and on for the past month since we purchased the corporate license. I've been trying to use the APITOKEN and the CustomConfigID together and the customizations will come through, but not auto-assign and once I manually add our account, it will put the computer in an "unknown" group instead of the groupID specified. 

    Once I tried your method of not including the CustomConfigID, it works and adds our account and moves to the right group! But then no custom logos or how we want it to look.

    This definitely seems like an issue or a bug they need to address. Any help from TeamViewer would be appreciated!

    *Not sure if related, but I get a lot of popups "Sorry, an error occurred while processing your request. Unknown Error. mWhtex5nHvW-3-1-32-tx (the code will vary)" while on my dashboard.

Sign In or Register to comment.