teamviewer.com link icon
or
Ask The Community

Auto account assign doesn't work on TV12 Host MSI

Hello

I can't figure out how to configure TV MSI to assign automatically account and to show PC in the TV as a connected device.. 

When i tried TV11 Host it at least assigned to the account. I had problem with password and There was screen that asked to allow to assign to account. At least worked 

TV12  i can't make to work at all No matter hat i try. 
I looked at the documentation but it did't helped me at all. Especially in case of that new file for assignment. 

«13

Comments

  • dwyeredwyere Posts: 16

    At least in v11 we had to export registry keys and re-import them (via script) after making the changes on one machine. Possibly that procedure would work here as well?

    --
    I am not associated with TeamViewer in any way, and all comments are strictly my personal views and opinions.
  • I've tried that and it didn't helped.

    Accout still doesn't assign to th Host :(

    on the V11 it works 

  • I'm unable to get it to work either.  Here are the steps I've followed:

    1) Created our customized MSI via the Desirng & Deploy section of our Management Console.

    2) Generated the API token to allow account assignment.

    3) Installed the customized MSI (it was renamed properly to TeamViewer_Host-idcxxxxxxx.msi, where xxxxxxx is our Configuration ID from the Management Console)

    4) Ran the TeamViewer_Assignment.exe with the commandline options -apitoken <our token from step 2 above> -datafile "C:\Program Files (x86)\TeamViewer\AssignmentData.json" 

    The commandline fails with the message: => Assignment failed with:
    Reading datafile 'C:\Program Files (x86)\TeamViewer\AssignmentData.json' failed
    with: File not found

    I have confirmed that the AssignmentData.json file does NOT exist, even after running TeamViewer on the machine.

    The instructions - both the PDF included in the MSI, and the single page found at https://community.teamviewer.com/t5/Knowledge-Base/Deploy-TeamViewer-Host-MSI-Package-with-Assignment-Tool/ta-p/310 are vague or refer to the steps needed for TV11.

    It's funny that this deployment feature is touted in the new version, but so poorly supported.

  • I've found that the AssignmentData.json file is sometimes present when the .exe version of the TeamViewer deployment package is used to install the host.  

    The AssignmentData.json file is specific to the host upon which it is created.  I tried copying the file to another host, in hopes that the TeamViewer_Assignment.exe tool might modify it for the new host, but this is not the case.

    I've been unable to far to find any switches to make the .exe version of the deployment package run silently for use with GPO-based installs, or use with tools like PDQ Deploy.

  • Hi @Sybreeder,

    Have you mirated to v12 in the web console? I have noticed since doing that, there is a new account assignment option and tool in the customised host.

    Not sure if this link will work or not but in my web console this link downloads the assignment tool.

    Hopefully this is helpful to you.

  • @designworks Yes i did migrated console to v12. I've also tried setup that json file. It shows on the tv host installation. But i cant put that token anyway. There is no manual for v12 really at all. when i download latest msi manual is fr v11. I'm really dissapointed in this product. 

    And for assignment tool. there is no manual how to use it really. 

     

  • Yeah the documentation for v12 is pretty terrible to be honest. I haven't figured it out myself yet either. At least their support is pretty good and v12 is a big improvement over the previous version.
  • There's no manual for TeamViewer_Assignment, but there is a help entry that you can access by running "TeamViewer_Assignment.exe -help" from the command line.

    The syntax that I've been using is:

    TeamViewer_Assignment -apitoken <the token generated by the Management Console> -datafile "C:\Program Files (x86)\TeamViewer\AssignmentData.json"

    The problem is that there is no AssignmentData.json file in the directory when the install is done with the MSI.  If you use the EXE version of the TeamViewer_Host installer, there will be an AssignmentData.json file, but it is specific to the host on which the installation has been performed.  If you do a silent install using the /S switch on the TeamViewer_Host.exe file, the AssignmentData.json file is not created.  In this case, the host ID assigned to the machine will appear in the "Unamed devices" group in the Management Console. 

    Without the AssignmentData.json file the TeamViewer_Assignment command fails, making the MSI based install pretty much worthless.  

    For what TeamViewer charges I would expect better support than what's been given.  

  • EstherEsther Posts: 2,991 Community Manager

    Hi,

    Thank you all for your feedback.

    Of course, we want to provide you with very good and helpful documentation and therefore have we just updated the article in the Knowledge Base and I hope, that this version is better.

    Can you give it a try and give me a short feedback (if it was helpful or not)?

    Thank you in advance!

    Best,

     

    Community Manager
  • Thanks Ester,

    That is much better! Thank you for that. I still have some questions however.

    I don't have an 'assignmentdata.json' file in my TeamViewer v12 install folder to direct the assignment tool to. Am I missing a step that is required to create that file?

    Cheers.

  • @dwadmin 

    I was missing this file as well, but once I created a completely new MSI file via the Design and Deploy tool it started appearing during the install and have been able to use the TeamViewer_Assignment tool.


  • @donrin wrote:

    @dwadmin 

    I was missing this file as well, but once I created a completely new MSI file via the Design and Deploy tool it started appearing during the install and have been able to use the TeamViewer_Assignment tool.


    yep, thanks. That worked for me too.

  • I tried rebuilding the MSI package, but I still cannot get AssignmentData.json to show up.  Any ideas?  I have tried EVERYTHING.

  • EstherEsther Posts: 2,991 Community Manager

    Hi @aferguson56

    Can you provide us with a description of the process, so that we can find out, why you do not see this file?

    Thank you in advance!

    Best,

    Community Manager
  • Hi Esther,

    I recreated a custom module, downloaded the .msi package, followed the deployment manual.  When installing the custom host application, I can see the customizations I set have deployed, but i'm stuck at auto assigning TeamViewer.  

    When running TeamViewer_Assignment.exe, it gives me an error that it can't find C:\Program Files (x86)\TeamViewer\AssignmentData.json.  I looked in that location and confirmed it's not there.  I did a system wide search to try and find it with no luck.

  • Hi Esther,

    I recreated a custom module, downloaded the .msi package, followed the deployment manual.  When installing the custom host application, I can see the customizations I set have deployed, but i'm stuck at auto assigning TeamViewer.  

    When running TeamViewer_Assignment.exe, it gives me an error that it can't find C:\Program Files (x86)\TeamViewer\AssignmentData.json.  I looked in that location and confirmed it's not there.  I did a system wide search to try and find it with no luck.

  • Hi @Esther,

    Thanks for the update to the KB. 

    I can confirm that I have successfully deployed a version 12 host file and used the assignment tool to assign it to our account with your help.

    One suggestion that perhaps others might also find helpful is to have examples that show the correct usage of the environment variables when used in a whole command? After all, you have mentioned the usage of environment variables in isolation so it would be thorough to include them in an example command.

    I'm sure giving clear examples of commands with and without environment variables would also your reduce support requests.

    Cheers.

  • @Esther

    After having successfully installed hosts using the autoassignment tool, I am trying to automate deployment of TeamViewer 'clients' using the assignment tool and I think I may be running into the same issue as @aferguson56.

    When I installed the non-host .MSI file, there is no assignmentdata.json in the TeamViewer folder. Is it meant to be possible to assign TeamViewer clients using the tool?

    Cheers!

  • EstherEsther Posts: 2,991 Community Manager

    Hi,

    Wow, I really like what is happening in this thread :-)

    Together we are really making things better! Thank you all for your help and your feedback!!

    In addition, I would like to give you an update on this: We are working together in the Team to update the documentation. We are reading all of your feedback and I hope, we can publish the updated version soon.

    If you have any further feedback, please let us know :-)

    Best,

     

    Community Manager
  • I still belive that it was easier before..

    on TV10 when i installed MSI by GPO it installed by itself and it just worked...

    Now it's a mess. That new app is another work for us. 

    It should be easier to do. I shouldn't  write post that it doesn't work. Especially for that expensive software. 

    The best way would be to embed configuration and assigment to MSI itself that would automatically configure. 
    With each version it look that it harder to setup. And i still don't belive that that assigment tool i right way to do it..

    Isn't there a way to jus have a reg file or configurable msi that would do it? 

  • it's seems like the assignement json is not appearing everytime, i did some testing :

    if the computer is already assigned to my account, no assignement.json appears

    If i update a computer with a host v10  already present it wont appear if in my account

    if i delete the id from my account and then update a computer with host v10, the file appear

    Heres a powershell script that works :

     

    msiexec /quiet /i TeamViewer_Host-idcXXXXXXX.msi
    ./tv_assignement.exe -apitoken 0000000-XXXXXXXXXXXXXXXXXXXX -devicealias "$env:computername - $env:username" -wait "30" -datafile “C:\Program Files (x86)\TeamViewer\AssignmentData.json"

    Waiting 30 seconds before trying to assign, Teamviewer_Settings.reg in the same folder exported from a sample installation

    What i would like, i would like to be able to mass update my hosts, and there aliases with the logged user, anytime i want.

    It seems like, the only way i could do that, is to delete all the host i have in my account, then force a reinstall of teamviewer on all computers. I'm a bit reluctant, is there another way?

     

     

  • Yeah I agree with 's suggestion about embedding assignment and configuration into the standard MSI installers. No extra downloads required.

    Hopefully with our feedback we can make this work better than it does currently. ?

    @Esther With that said though, I haven't tested the old deployment method yet so I can't comment, but I assume from the v11 documentation that comes bundle with the v12 MSI, the old method it still works?
  • I was also receiving the same file not found error but I noticed odd characters before the file path. I removed the quotes that were in TeamViewer's example and used the appropriate variable:

    *For 32bit: ${ProgramFiles}

    *For 64bit: ${ProgramFiles(x86)}

    Error: Assignment failed with:
    Reading datafile '“C:\Program Files (x86)\TeamViewer\AssignmentData.json' failed with: File not found

    Solution: -datafile ${ProgramFiles(x86)}\TeamViewer\AssignmentData.json

  • RahulRahul Posts: 4

    Hi everyone,

     

    product management here.

    First, let me thank you for your great participation here. Your feedback is more than welcome and much appreciated.

     

    I will try to untangle some uncertainty and answer questions about the Silent Host Roll Out as good as I can.

     

    While I was reading through the thread I recognized some possible issues for confusion which I would like to start with.

     

    To use the new Silent Host Roll Out feature, a few requirements exist:

    • TeamViewer 12 Corporate license activated on your account
    • Custom TeamViewer 12 Host with “Allow account assignment without confirmation” activated
    • Custom Host is deployed with the Configuration ID in the file name
    • Device is not already assigned to an existing account when the new Host is deployed
    • Only works for Host, not for TeamViewer full version

     

    Please make sure that these requirements are met.

    If you still have trouble using the new feature, e.g. the AssignmentData.json file is not created, please describe your scenario as accurately as possible.

     

    The deployment of TeamViewer Host MSI via GPO and the account assignment via Active Directory serviceConnectionPoint still works, of course. Both features are not mutually exclusive.

    We are also working on an update of the knowledge base article that makes things a bit clearer and considers your feedback.

     

    Best regards

  • Hi guys,

    I have been able to create and deploy a customised host file successfully and tried to create another customised host recently and ran into the same issue that others were having here but I was able to resolve it and thought I would post my findings here to help narrow down the issues for everyone.

    Prior to v12 I was able to download the MSI package and rename the TeamViewer_host.exe  that came in the ZIP file with the deployment ID. e.g. TeamViewer_Host-idcXXXXXXX.msi.

    It would appear that this workflow doesn't work if you need the "assignmentdata.json" file.You have to use the link in the bottom left corner instead of the MSI package. (See below for screenshot. )

     

    @Rahul can you confirm if my findings are consistent with yours?

    @jlevesque have you been following the same workflow I described above? Have you tried using the file generated from the link in the bottom left corner rather than renaming the host installer from the MSI ZIP file?

    EDIT: I also just noticed that the file that downloads from the link in bottom left is an EXE which CANT be silently installed, rather than an MSI. It's also named differently as well as having the unique deployment ID already appended to the file name when downloading. e.g. TeamViewer_Host_Setup-idcXXXXXX.exe. AND the other successfull customised host that I deployed was using a renamed Host MSI file but now I cant get the new customised host to generate the .json file for autoassignment, even after redownloading the MSI package after the auto assisgnment option was selected.

    So now I'm stuck and REALLY confused! >_<

     

     

  • RahulRahul Posts: 4

    Hi @designworks,

    I'm sorry to read that you are still having trouble to do the auto assignment.

    The new Silent Host Roll Out feature is designed to work with the MSI package as well as EXE. It is required to always add the Configuration ID to the Host filename, no matter if the MSI package or the EXE is used. E.g.:
    TeamViewer_Host-idcXXXXXXXX.msi
    TeamViewer_Host_Setup-idcXXXXXXXX.exe

    Another requirement is, that the device you want to do the auto assignment on is not already assigned to an account. If the devices is already assigned to an account, the datafile is not generated.
    If you have TeamViewer already installed and assigned, the assignment must be removed prior to using the Silent Host Roll Out.
    There would be several ways to do this:
    - Remove the account assignment in TeamViewer settings
    - Delete the TeamViewer registry settings
    - Uninstall TeamViewer with "Delete settings" option checked (EXE only)
    - Uninstall TeamViewer and delete the TeamViewer registry settings afterwards

    The issue that a device is already assigned and hence the datafile is not generated might occur while testing the new feature but should actually not be an issue when deploying TeamViewer using the Silent Host Roll Out.

    Please let me know if this helps you. If not, I would be happy to set up a TeamViewer meeting to go through the issue together with you.

    Best regards

  • bayloxbaylox Posts: 2

    Hi!

    I'm also having trouble getting the json-file to appear, which leads to the file not found-error. I install the MSI file the following way:

    msiexec.exe /i \\server\share\Teamviewer\Version12\TeamViewer_Host-xxxxxxx.msi /qb-

    I just tested this on a new (virtual) machine with a computer name that (as far as I know) hasn't been used with TeamViewer before and we do have a Corporate account.

    Thanks in advance for any help,

    /Peter

  • bayloxbaylox Posts: 2

    Nevermind - when fiddling with the packages, I had forgotten to add "idc" to the beginning of the ConfigurationId. Still have trouble conncting to webapi.teamviewer.com, but that is probably a firewall-issue at my end.

  • Thanks @Rahul for that clarification.

    I have been correctly appending -idcXXXXXXX to the end of the MSI file name. Thats particularly puzzling about all this is that the .EXE works but the MSI file doesn't.

    Ultimatley what I am trying to achieve is trying to update all our exiting hosts without them pulling the update from the internet.

    How do you propose we upgrade our existing install of Teamviewer 10 & 11 hosts and have them silently assigned to our account?

    Manually deleting the computer assignment from my account is a non-solution. This is a very labour intensive exercise. This step really shouldn't be necessary or is a process that really should be able to be automated (or invisible and done automatically during the install process).

    If leave the computer account assigned to my Teamviewer account and uninstall Teamviewer and check the option to delete all settings and try to install v12 it doesn't create the JSON file. Is this expected behaviour?

    For the sake or clarity, can you please provide more detail about the registry settings that need deleting?

    I think I will contact Support to resolve this. I was trying to solve this here where everyone could benefit but its taking too long to resolve.

    For everyone else playing at home, I will be sure to report back. :smileyhappy:

  • EstherEsther Posts: 2,991 Community Manager

    Hi @designworks

    Thank you for your post and thank you for sharing the solution with us when you are getting the reply from support!

    Best,

    Community Manager
Sign In or Register to comment.