teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

TeamViewer MSI via deploy fails in Windows 10, works under windows 7

skydiverscott
skydiverscott Posts: 1
edited September 9 in API and scripting

I have a script msiexec command to install a deployment msi from our corporate TV poortal.

I have tested and confirm this command works under Win7

msiexec.exe /i ".\D-TeamViewerDeploy\HostOnlyTeamViewerDeployPackage.msi" /qn CUSTOMCONFIGID=<Deployconfig code> APITOKEN=<Deploye API token> ASSIGNMENTOPTIONS="--grant-easy-access --reassign"

When I run this in WIn7 x86 it works as expected

When I run this under Win10x64 it fails to run

When I change the /qn to /qb I get this error:

"This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package."

TeamViewer can be installed via the msi file interactively, to the file is not corrupted.

Answers

  • flospi
    flospi Posts: 26 ✭✭

    Try activate more verbose logging for the MSI installation. In the resulting logfile you should get more information on the error.