teamviewer.com link icon
or
Ask The Community

Issue assigning teamviewer.exe to account after installation

ThinkIt
ThinkIt Posts: 5 ✭✭

Hi, I followed the mass deployment guide (https://community.teamviewer.com/English/kb/articles/39639-mass-deployment-on-windows), I don't have an msi as my licence is for the Business product but having installed TV Host I ran:

"C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assign --api-token xxxxxxxxxxxxxxxxxxxxxx --grant-easy-access

Nothing happens, I checked the logs and see:

8436 1900 C2!! AssignmentData-File "C:\Program Files (x86)\TeamViewer\AssignmentData.json" didn't appear within 30 seconds, Errorcode=2

8436 1900 C2!! DeviceAssignmentStarter::RunInternalAssignment: Could not read assignment file., Errorcode=2

Is this because it is not possible to assign in this way on my licence? I generated the api token with the permissions in the guide. I found others with similar issues on old threads but no resolution.

Thanks in advance

Answers

  • JM73
    JM73 Posts: 1 Newbie
    edited June 10

    Hello, I've the similar issue :

    The command work when I launch it with administrator account, but with an user account I have this error :

    8016 2084 C1!! AssignmentTrigger::Set: can't open event (lastError=5), Errorcode=5

    8016 2084 C1  DeviceAssignment::TriggerAssignmentAction - Try triggering the assignment event for the next 30 secs.

    8016 2084 C1!! DeviceAssignmentStarter::Run: can't access action-trigger, Errorcode=5

    the command work when


    Thanks for help.

    JM

  • DLiberty
    DLiberty Posts: 2 ✭✭

    I am with you here. I have tried using the assignment in the GPO MST file. It seems to get the custom configuration, but the apikey and assignment options don't do anything. When trying this manually, which will eventually going to be a script across all workstations I get this. The json file doesn't work.

    Looks like I wasted a morning on this so far. Hope you have some success. I am going to send this off to TV support as well.

    Doesn't seem to matter whether is an admin or normal user either.


    Command line:

    TeamViewer.exe assign --api-token 1234-abcd --grant-easy-access --group 'Computers'

    Command does not have any response, so have to check the log file.


    Log File:

    2022/06/28 13:59:06.258 9024 4016 C1  Logger started.

    2022/06/28 13:59:06.258 9024 4016 C1  CommandLineTasks: initializing...

    2022/06/28 13:59:06.524 9024 4016 C1+ GetSimpleDisplayCertNameFromFile: Found cert name: 'TeamViewer Germany GmbH'.

    2022/06/28 13:59:06.524 9024 4016 C1+ VerifyTeamViewerCertificate: File for loading certificate is C:\Program Files (x86)\TeamViewer\TeamViewer.exe

    2022/06/28 13:59:06.524 9024 4016 C1+ VerifyTeamViewerCertificate: SHA256 code path.

    2022/06/28 13:59:06.524 9024 4016 C1+ SHA256 certificate check.

    2022/06/28 13:59:06.524 9024 4016 C1+ VerifyCertHash(): Certificate check succeded.

    2022/06/28 13:59:06.524 9024 4016 C1  CommandLineTasks::Execute: executing task 'assign'

    2022/06/28 13:59:06.524 9024 4016 C1  AssignmentTrigger::Set: set AssignmentTriggerAction to 1

    2022/06/28 13:59:06.524 9024 4016 C1  AssignmentTrigger::Set: triggered event

    2022/06/28 13:59:06.524 9024 4016 C1  DeviceAssignment::TriggerAssignmentAction - Try triggering the assignment event for the next 30 secs.

    2022/06/28 13:59:06.524 9024 4016 C1  DeviceAssignment::TryReadAssignmentDataFile, Wait until service creates "C:\Program Files (x86)\TeamViewer\AssignmentData.json"

    2022/06/28 13:59:37.420 9024 4016 C1!! AssignmentData-File "C:\Program Files (x86)\TeamViewer\AssignmentData.json" didn't appear within 30 seconds, Errorcode=2

    2022/06/28 13:59:37.421 9024 4016 C1!! DeviceAssignmentStarter::RunInternalAssignment: Could not read assignment file., Errorcode=2

    2022/06/28 13:59:37.446 9024 4016 C1  CommandLineTasks: finished

  • donrin
    donrin Posts: 6 ✭✭

    I've run into this issue as well and it seems that the account assignment broke with one of the recent 15.x version updates. We've long used a scripted install of TeamViewer and used the command line options to our account and place the machine into the desired group. Here's the command line with our specific info redacted:

    start /b /wait msiexec.exe /i "Z:\TeamViewer\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=###### DESKTOPSHORTCUTS=0 APITOKEN=XXXXXXXXXXXXXXXXX ASSIGNMENTOPTIONS="--grant-easy-access --group-id gYYYYYYYY" SETTINGSFILE="Z:\TeamViewer\TVOpts.tvopt"

    Notes: This should all be on a single line. The "#######" should be your specific Config ID, the "XXX" your API Token, and the "YYYY" the number of your group.

    All of this worked with the 14.7 version of the TeamViewer_Host.msi. However, when I upgraded to the latest 15.x version of the TeamViewer_Host.msi, the script would complete the install, including assigning the TVOpts file, but would NOT join the machine to our account, nor "Grant Easy Access".

    I'd tried rebuilding my script using the info here: https://community.teamviewer.com/English/kb/articles/109279-recommended-scripts-3-6 and none of it worked.

    Once I rolled the TeanViewer_Host.msi back to the 14.7 version, the install completes and the machine is added to our account in the correct group. You can get older versions of TeamViewer here: https://support.teamviewer.com/en/support/solutions/articles/75000016428-download-msi-for-previous-teamviewer-versions

    Sadly, as seems to be par for the course with TeamViewer, they've apparently broken something, or changed something and not communicated it.

    If someone from TeamViewer sees this - The actual product of TeamViewer is wonderful. However, the management interfaces, via the UI or the web are lacking, particularly for something other than a small business, and either your quality control (to make sure that bugs such the one apparently preventing account assignment don't make it into the product stream) or your communication on changes incorporated into new versions needs some serious work.

  • SMP_IT
    SMP_IT Posts: 4 ✭✭

    Looks like we're all in the same boat. All my attempts to overcome the failing account assignment have been futile, so far... The only option I currently see is the manual registration process, but this would be quite a hassle for +200 devices...

  • JeanK
    JeanK Posts: 6,210 Community Manager 🌍

    Hello all,

    Thank you for all your messages.

    I've been asking our engineers about the error messages you are reporting.

    It seems that the modules you are using might be broken. Therefore, the best option would be to create a new module and to redeploy with the new module's values (Api token and customconfigid)

    Furthermore, we do have a complete deployment user guide that you can follow here:

    📄 Mass deployment on Windows - Overview

    Let me know if deploying with a new module fixed the issue.

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • SMP_IT
    SMP_IT Posts: 4 ✭✭

    That definitely worked out!

  • JeanK
    JeanK Posts: 6,210 Community Manager 🌍

    I'm happy to hear this! Thanks a lot for updating the thread, @SMP_IT.

    Did creating a new module fix the issue?

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • DLiberty
    DLiberty Posts: 2 ✭✭

    Hello @JeanK Can you please explain how our modules get 'damaged'. There really isn't anything we can do to 'damage' them as the customizations are quite simple.

  • JeanK
    JeanK Posts: 6,210 Community Manager 🌍

    Hello @DLiberty,

    Sorry, my message was maybe confusing on this point.

    There is nothing you have damaged. It can, in some rare cases, that something in our back-end breaks the module and causes issues like this. It's like a bug that occurred. You didn't do anything wrong here.

    All the best,

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • ThinkIt
    ThinkIt Posts: 5 ✭✭

    I created a fresh custom Host module, installed it on a system and then ran CMD as admin. I tried two commands:

    "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assign --api-token <APItoken> --grant-easy-access --reassign

    "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assign --api-token <APItoken> --alias %COMPUTERNAME% --group <GroupName> --reassign --grant-easy-access

    Neither command did anything and the installed Host remained unassigned to any account. My app has the following permissions:

    Group management - Create groups, read groups, edit groups, share and unshare groups, delete groups

    Computers & Contacts - View entries, add entries, edit entries, remove entries

    Has anyone got this working?

    Thanks

  • ThinkIt
    ThinkIt Posts: 5 ✭✭

    I just tried running the same command on my full Teamviewer install (not a customised module) and I noticed "AssignmentData.json" appeared in the Teamviewer program files directory but still my TV says there is no account assignment even after restarting.

  • JeanK
    JeanK Posts: 6,210 Community Manager 🌍

    Hi @ThinkIt,

    Thank you for coming back.

    I am missing the CUSTOMCONFIGID in your script.

    I would recommend using one of the two script templates we provided in this article:

    📄 Recommended scripts - 3/6

    Let me know if it worked better.

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • ThinkIt
    ThinkIt Posts: 5 ✭✭

    Hi @JeanK, I note that the guides specify a corporate licence is needed for MSI deployment, is there a restriction that would prevent a business licence from running these scripts after installation has completed using the exe? I mentioned this in my original post but haven't had any clarification. Thanks

  • JeanK
    JeanK Posts: 6,210 Community Manager 🌍

    Sorry that I missed this part, @ThinkIt.

    Yes, there are technical restrictions allowing only Corporate (and Tensor) license holders to deploy TeamViewer via MSI.

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer