TeamViewer enters “Remote Terminal “

mrolton
mrolton Posts: 2 ✭✭
edited April 2023 in IoT Forum

Please can anybody help me . I have setup TeamViewer on my Synology but when I login it goes to “Remote Terminal ” how do I make it go to my Synology login page instead . Thanks

Answers

  • JeanK
    JeanK Posts: 6,963 Community Manager 🌍

    Hello @mrolton,

    Welcome to the TeamViewer Community! 🚀

    When connecting to your device, make sure that you select the Remote control mode in the Remote Control menu.

    You can switch from Remote terminal mode to Remote control mode as below:

    Let me know if this has worked for you!

    /JeanK

    Community Manager

  • mrolton
    mrolton Posts: 2 ✭✭
    edited November 2022

    Hi thanks I already had these settings and it goes straight to Remote Terminal

  • JeanK
    JeanK Posts: 6,963 Community Manager 🌍

    Hi @mrolton,

    I eventually learned the reason why this is happening.

    Currently, remote controlling Synology devices is only possible from Windows devices.

    I can see from the screenshot that you are connecting from a Mac. This is currently not supported and, therefore, redirects you to the remote terminal as default.

    I hope this could at least answer your question. 🙂

    /JeanK

    Community Manager

  • ManelGT
    ManelGT Posts: 2 ✭✭

    Hello... Sorry, but in fact it seems a problem affecting not only Macs...

    I too, have Teamviewer set on a Synology (DS918+) and trying to Remote Control from a Windows Laptop. And, beginning some months ago, as far as i can remember, that has been happening to me too, lost the ability to do remote control, just only really working is access to the remote terminal.

    Recently (these last days, as i occasionally kept trying it again, i.e. as this early morning...) it leads me just to a Web Station page (as it is running but not set and configured) just stating this, that it still needed to get Web services and webpage set, configured and sucessfully running to let me access the NAS (through a web homepage...) from my Teamviewer application, or else just only still allowing access to the terminal.

    Hope this gets somehow clarified and solved, i miss a bit that old remote access as we assume it should continue to be done.

    Anyway...

    Thanks for your efforts... 🙂