link icon
Ask The Community

Install teamviewer host on headless raspberry pi via ssh for 24/7 unattended access

I am unsuccessful in installing teamviewer host (only) on a Pi 2 (Linux PI2 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux). The instructions I've found by searching this give an example such as "apt" to install the .deb, however after it gave bad results I googled and I'm supposed to use "dpkg -i   <debfile>". I tried another method, which seemed to work, and when doing a apt-get update && apt-get upgrade to resolve dependencies, it says it's uninstalling teamviewer. I don't get it. Now I don't know what state my Pi's teamviewer-host package is in. 

This Pi is headless (it hosts a weather station at a remote unmanned building) and only accessed via ssh. If someone would please clarify the exact steps. 

Thank you very much.



  • Hi @MPotamia,

    Thanks for posting.

    Please  update to the latest Raspbian version. It would also help to see the output of apt what exact packages are missing.

  • Thank you I updated from Wheezy to Jessie, followed
    and it is working now. 

  • I updated my Pi2 from Wheezy to Jessie and it installed okay, after "sudo apt-get update -f". I did "teamviewer setup" and it worked as I've seen it work once before on a Pi3. However when I went to connect via TV to the Pi2 it did not automatically log me in, i.e. it made me sign in as user pi with password (the previous install did not); and just as bad is I have no control over the screen size (see attached pic).  When I installed tv-h on the Pi3 it allowed me to size the screen to the max character width of my local screen, whereas with this install I'm stuck with the screen size you see in the attached and I really need to resize the screen because of the work I need to do remotely. Could someone tell me what went wrong with this install? 


    screen unsizeable.pngI upgraded the Jessie using sudo apt-get upgrade also after the successful install in case something else was causing this shortcoming. 

  • Thank you I updated from Wheezy to Jessie, followed

  • rikimaru
    rikimaru Posts: 1

    Thank you I updated from Wheezy to Jessie, followed 
    [link removed]
    and it is working now.

  • Thanks, tech Viral it's working now. check it 

    Game Guardian No Root Tutorial

  • Thank you .You have give nice information.

    <a href=>card activation</a>

  • I think you should check the source file in your system and than uninstall it....

  • i think you should check the source file where its located and than delete it...

  • Have you got the solution.

  • Thanks for acknowledging my path by telling the site from where i can download it .

  • Download new version.

  • Fix 403 Forbidden Error Caused by Corrupt .htaccess File. Often the 403 error iscaused by a corrupt .htaccess file in your WordPress site. ... Try accessing your website. If 403 forbidden error is resolved, then this means that your .htaccess file was corrupt.

  • You can download songs from using something like this soundcloud to mp3 converter Just paste in the URL of the soundcloud song. And you get a mp3 download.