teamviewer.com link icon
or
Ask The Community

IoT Remote AppControl solution and Synology NAS boxes

12345679»

Answers

  • Hi everyone, Hi @_Andreas_ ,

    Does anyone know if the Teamviewer client now works on Mac ?

    Everything is installed correctly on mine but the client does'nt launch.

    Thanks.
    Patrick

  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    Hi @PatrickMignon 

    For now, is not working to connect from a MacOS to a Synology device.

    Regards,

    Mircea

     

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • When will macOS be supported?

  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    Hi @raptile

    Unfortunately, for the moment, we do not have an ETA for the MacOS support.

    Regards,

    Mircea

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • MrNew666
    MrNew666 Posts: 1

    hi @PatrickG 

    I have the following problem when connecting thru Teamviewer to my NAS DS220+.

    I have installed TEamviewer on NAS and successfully established the connection thru Teamviewer client to the NAS. But there is a security issue poping up when connection (see pic below), that says that the name on the certificate in invalid or does not match the name of the site. I assume this means that the connection is not secure when connecting thru teamviewer because of the issue with certificate. My certificate installed on NAS is valid and issued by Lets Encrypt. I can actually connect, by its not secure. Would appreciate if you could help me make the connecton secure.

    Can u pls furnish me with the solution what to do in order to pass this certificate issue successfully? thx

    Regards

    Simon

    certificate problem 

    certificate problem backup image 

  • On my Synology DS215+ dith DSM version DSM 6.2.3-25426 Update 2, TeamViewer doesn't work.
    It has never worked.

    When I run it, it shows a blank little window wi no links or button except for the "Third party licenses" and "www.teamviewer.com" links on the bottom.


     

  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    Hi @OnSite 

    I forwarded your issue to my colleagues from support.

    They will get in contact with your for further checkups

    Regards,

    Mircea

     

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    Hi  @MrNew666 

    I forwarded your issue to my colleagues.

    They will get in touch with you for more details.

    Regards,

    Mircea

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • mahisri
    mahisri Posts: 2 Newbie

    Any ideas on how to fix this? It used to work but presents blank screen after update:


  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    Hi @mahisri

    The device is assigned to your account or because the interface is not loading you were not able to do it? I am asking this because if is not assigned you can try like a quick fix if it is possible via the “Nearby contacts and devices” function for adding the device.

    On some devices it seems that the Agent interface is not loading, we are aware and trying to fix it.

    Regards,

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • wschlich
    wschlich Posts: 7 ✭✭
    edited March 2021


    After almost a year, still no news with TeamViewer 15.15.5 on Linux! :-(

    Connecting to TeamViewer IoT on a Synology NAS results in "Authentication rejected".

  • Guig67
    Guig67 Posts: 1 Newbie
    edited April 2021

    Hello everyone,

    I'm facing problem with Teamviewer package on a Synology DS220+.

    When attempting to "Assign" my NAS to my Teamviewer account, i have this message :

    Even with the correct password for assignement, i get this error.

    For information, i have already added 2 other NAS, DS220+ and DS118 without any problem !

    I'm thinking that it comes from the package ...

    Any idea, please ?

    Thanks in advance !

  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    Hi @Guig67

    If you already have 2 NAS added, the issue could be that you do not have any Synology Endpoints left for assignment.

    To support you more, the first two devices are free of charge. For adding more devices or to get more information please visit here

    Regards,

    Mircea

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • DoubleM
    DoubleM Posts: 1 Newbie

    I could add my NAS by using Teamvier from my PC and use the “Nearby contacts and devices” function 😀

  • Spaldo
    Spaldo Posts: 2 ✭✭
    edited May 2021

    I am also getting the same issue with the blank box. I have never installed the app on the Synology. The local search method on my windows machine finds the server, but, I cannot login as I do not know the password nor have been able to link it to my Synology account :(

    Anyone have any ideas to make it display? I have tried checking & unchecking the security box - cross site protection.

    I am running: Synology DS214 (MARVELL Armada XP MV78230) running DSM 6.2.4-25556. TeamViewer 2.8.17 version on Synology

  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    @Spaldo

    On some Synology devices seems that the TeamViewer Agent is showing a blank page.

    If you are in the same LAN network with the device, open on the PC TeamViewer and try to add the device via “Nearby contacts and devices” function.

    The device will get assigned to your account without the need of password. If the device is already added please try again to add.

    Regards,

    Mircea

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • chriszh
    chriszh Posts: 1 Newbie

    How the teamviewer app on synology could be reseted?

    Whats the path of the Settings File?

    Because only delete and reinstall the app is not solving my problem.

  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    Hi @chriszh

    Could you please give more details with you problem?

    Regards,

    Mircea

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • Amsterdamer
    Amsterdamer Posts: 6 ✭✭
    edited October 2021
    Hi!
    There is a Synology NAS with TeamViewer 2.8.17 installed and there are also problems with its operation. More precisely, it does not work at all. I launch the application, White screen and nothing else. It stops. I also attach a log file.
    I reinstalled and did a full reset, the HDD faded, with no result.
    The rest of the functionality works fine.
    And how can you then want to buy a license :(
    
    DSM 6.0.2-8451
    
    The previous version 2.3.7 starts and works fine, but you cannot connect to it - it requires updating the application to synilogy NAS.
    
    
    2021/10/27 20:00:25.844 15727 1074823168     Logger started.
    2021/10/27 20:00:25.873 15727 1074823168     Found 4 stack dump files ...
    2021/10/27 20:00:25.873 15727 1074823168     Found 4 Minidump files ...
    2021/10/27 20:00:25.933 15727 1074823168  !  AsioSettings::FindExternalIP: found 0 external IPs instead of 1!
    2021/10/27 20:00:25.979 15727 1074823168  !  AsioSettings::FindExternalIP: found 0 external IPs instead of 1!
    2021/10/27 20:00:30.801 15727 1074823168     IdentityManagement: Load ManagerIDs from local Storage:
    2021/10/27 20:00:30.803 15727 1074823168     [Beehive] Initializing Beehive device
    2021/10/27 20:00:30.806 15727 1074823168  !! DeviceBaseLin: Initialization of the device failed, Errorcode=2
    2021/10/27 20:00:30.806 15727 1074823168  !! BeehiveDeviceFactory: Synology Device initialisation failed, Errorcode=2
    2021/10/27 20:00:30.807 15727 1074823168  !! [Beehive] No device information available!, Errorcode=2
    2021/10/27 20:00:30.807 15727 1114630560     NetworkControl shutdown started
    2021/10/27 20:00:30.808 15727 1074823168     NetworkControl shutdown done
    2021/10/27 20:00:35.814 15727 1074823168  !!!Crash: stack dump has been written at '/volume1/@appstore/TeamViewer/logfiles/teamviewer-iot-agent_BV_15.3.17_2021-10-27-200035.armv7.stack', Errorcode=2
    2021/10/27 20:00:35.864 15727 1074823168  !!!Crash: Minidump has been written at '/volume1/@appstore/TeamViewer/logfiles/teamviewer-iot-agent_BV_15.3.17_2021-10-27-200035.armv7.dmp', Errorcode=22
    2021/10/27 20:00:35.864 15727 1074823168     Process received fatal SIGABRT
    


  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    Hi @Amsterdamer

    Could you please try to assign the device via the "Nearby contacts and devices" function from your pc's TeamViewer application and see if is working? The steps are here

    Regards,

    Mircea

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • Amsterdamer
    Amsterdamer Posts: 6 ✭✭
    Of course, I tried it beforehand.
    I just attach a log file.
    How will it be detected if it crashes when the application is launched?
    and yes, the proposed solution does not work, as did my predecessors in this thread.
    Are you sure you read my post completely? No offense :)
    


  • mircea_c
    mircea_c Posts: 131 Staff member 🤠

    Hi @Amsterdamer


    It is possible to sent the model name of your device and the entire logs from the agent?

    Or the above lines are the only ones?

    Regards,

    Mircea

    Tech Support IoT

    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.

  • Amsterdamer
    Amsterdamer Posts: 6 ✭✭
    edited October 2021


    Yes, the only ones, he just can't write anything to the log.
    
    DS214se
    


  • Amsterdamer
    Amsterdamer Posts: 6 ✭✭
    These are all logs, they are repeated with each attempt to start the application.
    I don't remember the model, 2 is wild on the Marvell Armada 370, like DS213j
    


  • Amsterdamer
    Amsterdamer Posts: 6 ✭✭

    2021/10/27 20:22:29.245 6694 1074126848    Process received fatal SIGABRT

    2021/10/27 20:45:31.529 10539 1077088256    Logger started.

    2021/10/27 20:45:31.579 10539 1077088256    Found 6 stack dump files ...

    2021/10/27 20:45:31.583 10539 1077088256    Found 6 Minidump files ...

    2021/10/27 20:45:31.636 10539 1077088256 ! AsioSettings::FindExternalIP: found 0 external IPs instead of 1!

    2021/10/27 20:45:31.690 10539 1077088256 ! AsioSettings::FindExternalIP: found 0 external IPs instead of 1!

    2021/10/27 20:45:37.278 10539 1077088256    IdentityManagement: Load ManagerIDs from local Storage:

    2021/10/27 20:45:37.279 10539 1077088256    [Beehive] Initializing Beehive device

    2021/10/27 20:45:37.280 10539 1077088256 !! DeviceBaseLin: Initialization of the device failed, Errorcode=2

    2021/10/27 20:45:37.280 10539 1077088256 !! BeehiveDeviceFactory: Synology Device initialisation failed, Errorcode=2

    2021/10/27 20:45:37.280 10539 1077088256 !! [Beehive] No device information available!, Errorcode=2

    2021/10/27 20:45:37.307 10539 1123518880    NetworkControl shutdown started

    2021/10/27 20:45:37.307 10539 1077088256    NetworkControl shutdown done

    2021/10/27 20:45:42.334 10539 1077088256 !!!Crash: stack dump has been written at '/volume1/@appstore/TeamViewer/logfiles/teamviewer-iot-agent_BV_15.3.17_2021-10-27-204542.armv7.stack', Errorcode=2

    2021/10/27 20:45:42.470 10539 1077088256 !!!Crash: Minidump has been written at '/volume1/@appstore/TeamViewer/logfiles/teamviewer-iot-agent_BV_15.3.17_2021-10-27-204542.armv7.dmp', Errorcode=22

    2021/10/27 20:45:42.470 10539 1077088256    Process received fatal SIGABRT