teamviewer.com link icon
or
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳


Please find more information here.

Remote control Issue throgh URL

Hi,

i have tried with URL which is provide in API Documentation, that is not working as expected, or suggest me how to connect throgh URL from my browser.

i have tried below URLs.

start.teamviewer.com/ remotecontrol_id
start.teamviewer.com/device/remotecontrol_id/authorization/password/mode/control .

Best Answer

Answers

  • Argh
    Argh Posts: 1

    I have tried making a get request to both  https://start.teamviewer.com/<some remote control id> and https://start.teamviewer.com/device/<some remote control id> /authorization/password/mode/control, but despite the fact that the machine making the request already has the TeamViewer client installed, rather than opening the client and initiating the connection, the client exe is returned in the response and begins to download. This behavior is not consistent, that is, sometimes the client is opened and the connection is initiated and other times the exe gets downloaded, so I am not sure what triggers the download. Any suggestions?  

  • Flupp
    Flupp Posts: 1

    Same problem here. Additionally I observed, that passing the correct Remote Control ID is never pasted in for the user on iOS devices.

    1) User opens link:  https://start.teamviewer.com/<some-remote-control-id>

    2) Safari asks if TeamViewer should be opened? Answer: Yes

    3) TeamViewer App opens up, but Remote Control ID is not being set.

    4) User has to type in the ID manually.

    Is there any solution for this behaviour? The ID should be passed in the app when clicking the URL containing the ID.

  • MHM
    MHM Posts: 1

    Please Delete this Message

  • Claudio72
    Claudio72 Posts: 1

    Dear all i have the problem since my IT admin has blocke the APP Teamviewer and i cannot anymore use the APP itself.

    I thought that via web was possible anyway but when i click on URL protocol nothing occurs.

    Could It be possible that IT admin has blocke also the lauching of the APP?

    Thanks for You kind reply.

    Claudio

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @Claudio72,

    Yes of course. If your company policy requires that no address of the teamviewer.com domain is contactable.

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • I'm trying to do something similar, but use VPN instead of remote.   Is there not a way to launch a VPN through the API without providing the password?

  • resq
    resq Posts: 1

    Same thing happens to me.  It was working for a couple of years. Then after a software update it stopped working. Now it downloads the teamviewer executable or .dmg (on Mac) instead of launching the session.