teamviewer.com link icon
or
Ask The Community

API-error during assignment

I'm getting an error when using the assignment tool for my host. The following is what I'm running...

C:\Windows\system32>D:\TeamViewer_Assignment.exe -apitoken MY TOKEN -datafile "C:\Program Files (x86)\TeamViewer\AssignmentData.json"

TeamViewer_Assignment (r350)

=> Assignment failed with:
POST-Request 'groups' failed with 500 (API-Error: 'internal_error' (Code 3), Description: 'A group with the same name already exists for this account. Please choose another name.')

 

Is the code I'm using correct? What does it mean when it same "A group with the same name already exsits for this account"? There is only one group with this name but that's where I want the users to be assigned. 

Best Answer

Answers

  • We are receiving the same error.
  • Same error here! Both Mac and PC assignement fails with the same error code. Group already exists, just adding the computers to the existing group.

    Scripts worked fine up to a few days ago.

  • I did call them yesterday and they acknowledged that this is a global issue and they would have it fixed "within a couple of days".

  • Yes. Adding the g followed by the group number from the management console worked for me.

Sign In or Register to comment.