link icon
Ask The Community

Installation error when trying to deploy TeamViewer via Microsoft Intune


I tried to deploy the TeamViewer host via intune following the official guide. At first everything seemed fine, installs were pending and now some are still pending but some have gotten an installation error 0x80070667. I researched that error and Microsoft says it maps to ERROR_INVALID_COMMAND_LINE so it looks like there is something wrong with the command line parameters? This got me stumped because I carefully followed the guide and still got this error.

My command line for the host installation msi in Intune is like this:


And I of course replaced the %YOURAPITOKEN% and %YOURCUSTOMCONFIGID% with the correct strings from the TeamViewer management console.

What might be the problem? I've tried researching and googling and I've found some indications that others have had the same kind of errors that ended up being caused by the "ASSIGNMENTOPTIONS" parameter. I've not yet tried the deployment without that parameter, because I really need to have the easy access enabled on deployment.

I have also sent a ticket to TeamViewer support about the problem but I have not gotten any answers to it yet.

Kind Regards,

Best Answer


Sign In or Register to comment.