teamviewer.com link icon
or
Ask The Community

Are you working with Insider Builds❓


Participate in our survey and get to know the new UI 👉 here 👈.

TeamViewer assigment

I just want upgrade from v 12. to 14. I wondering if is automatic assigment PC to contact list by script is same

I use :

TeamViewer_Assignment.exe -apitoken xxx -datafile "${ProgramFiles}\TeamViewer\AssignmentData.json" -allowEasyAccess=true -devicealias="${COMPUTERNAME}" -wait=10 -verbose

Will be working also in version 14? batch file I run by GPO. Thanks

Best Answers

Answers

  • Sven_F
    Sven_F Posts: 22 Staff member 🤠

    Hi @Oto

    I assume that you want to upgrade several devices from v12 to v14 because you are using a batch file executed by GPO. In this case, I would recommend uninstalling the existing v12 installations and performing a reinstallation including assignment via MSI. This article should help you with this process.

    The command you are using no longer works with v14 when installing with msi.

    I hope this helps you. Regards,
    Sven

  • Oto
    Oto Posts: 8

    Thanks,,

    I have v12 on 200PC and all are in contact list

    What is best process to migrate to v14:

    1 Uninstall v12 by GPO script
    msiexec.exe /uninstall "Path\To\TeamViewer_Host.msi"

    2 Install v 14 by GPO script
    msiexec.exe /i "Path\To\TeamViewer_Host.msi" /qn APITOKEN=<YOUR_APITOKEN> ASSIGNMENTOPTIONS="--alias %COMPUTERNAME%"
    Ho to combine with IMPORTREGFILE=1 and  CUSTOMCONFIGID=<YOUR_CUSTOMCONFIG_ID>

    Thanks for recomendation. Oto

     

  • Sven_F
    Sven_F Posts: 22 Staff member 🤠

    Hi @Oto

    the process could be as follows:

    1. Export a TeamViewer options reg file with your preferred options (from an existing installation)
    2. Uninstall your v12 via a GPO script including this command: 
      msiexec.exe /uninstall "Path\To\TeamViewer_Host.msi" /qn
      (/qn forces a silent uninstallation)
    3. Copy your CUSTOMCONFIGID and your APITOKEN from the Management Console
    4. Download the v14 TeamViewer_host.msi
    5. Put the options reg file into the same directory as the TeamViewer_host.msi
    6. Execute the installtion of v14 via a GPO script including this command:
      msiexec.exe /i "Path\To\TeamViewer_Host.msi" /qn APITOKEN=<YOUR_APITOKEN> IMPORTREGFILE=1 CUSTOMCONFIGID=<YOUR_CUSTOMCONFIG_ID> ASSIGNMENTOPTIONS="--alias %COMPUTERNAME%" /lvx msi.log
       (/lvx msi.log is just for creating a msi log in case errors occur)

    Regards

    Sven

  • Oto
    Oto Posts: 8
    Sorry I accidently click to Solved
  • Sven_F
    Sven_F Posts: 22 Staff member 🤠

    Hi @Oto,

    when you are doing an update, the Computers should already by in your contact list, or did you remove them before? In this case you should also add a group to your assignment parameters so the device is moved to a specific group.

    Regards

    Sven

  • Oto
    Oto Posts: 8

    Hi Swen,

    It is new computer

    I edit .bat script to

    start msiexec /i "D:\@install\Teamviewer14\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=xxx APITOKEN=xxx IMPORTREGFILE=1 ASSIGNMENTOPTIONS="--reassign --alias ""%COMPUTERNAME%"" --group ""@new"" --grant-easy-access"

    and nothing happen

    Thanks

     

  • Sven_F
    Sven_F Posts: 22 Staff member 🤠

    Hi @Oto,

    you don't need to use the assignment parameter "--reassign" when you rollout to a new computer and make a complete new assignment. "--reassign" is only necessary when your computer is already assigned and you want to move it to another group or changing the alias, etc...

    If that doesn't help I would recommend contacting our technical support, so they can analyze your log files in order to detect possible problems.

    Regards

    Sven

  • jka
    jka Posts: 3

    Hi,

    i currently had the same issue. I created a customized host client, set the options "add to a group" and "allow account assignment..."

    Then i created a script with the same options as yours. It never adds the computer to the group.

    My solution(its also mentioned at the top of the "mass deployment" article):

    Hint: Please beware we currently have an issue with the assignment with the --group; please use the --group-id at this point. Please see below for details.

     

    So u basically have to use the --group-id parameter. With this option it works for me. But it is clearly a bug.

  • have you a problem with your pc????

  • Oto
    Oto Posts: 8

    jka I tried it (--group-id) but with same result. Computer dont assign automaticly ...

  • jka
    jka Posts: 3

    Did you use the correct group ID? It has to be something like g12345678. Also, the computer you want to assign has to be online in the moment of the installation.

  • Oto
    Oto Posts: 8
    No , I use name of group.. where I can see ID od group? Yes Computer was online...
  • jka
    jka Posts: 3

    Log in into Managment Console. On the left you can see your groups. Click on the wanted group. Look at the URL, its something like "https://login.teamviewer.com/nav/home/buddies/g/**Please do not post TeamViewer IDs**4". Now you take the last numbers with the g, that is your group ID.