teamviewer.com link icon
or
Ask The Community

Issues when using Remote Desktop

Hey there,

Whenever I use Teamviewer to remote to my workstation and I from there have to use Remote Desktop (MSTSC) to access a server I have issues with alternate keys not being sent across to the server. Ctrl, alt and Shift keys aren't working on the server, but they are if I access the server directly from my workstation when I'm physically in the office. So I can only type lower case and have issues with any copy pasting etc. whilst on the server. 

Using Teamviewer 15.8.3 and Windows 10 / Windows Server (several versions)

Best Answer

Answers

  • JeanK
    JeanK Posts: 5,589 Community Manager 🌍

    Hello @MichaelPedersen,

    Thank you for your message. ?

    To send special key entries to the remote computer during a session, access the toolbar located at the top of the screen.

    Select the “Actions” tab and under the “Remote Interaction” section, you should be able to check the box for “Send key combinations”.

    By doing so, you will be able to execute commands mentioned in your post on the remote computer.

    Hope this helps.

    Best regards

    Jean

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • Hi Jean,

    Sorry about my belated response, I didn't get a notification about your answer and I forgot, until I stumbled on it it again :)

    However the Send Key Combinations have always been enabled and the issue remains the same. I can't forward any key combiations to remote desktop, I can to my workstation, where it in fact sends the key combinations regardless of whether the box is ticked or not. There it always works and when on remote dekstop it never works :)

  • Hi Jean,

    Thanks for the workaround, it does indeed work when not using the RDP in fullscreen, how oddly it may sound however :) Thanks for letting me know :)

  • JeanK
    JeanK Posts: 5,589 Community Manager 🌍

    Hi @MichaelPedersen

    I am glad to hear this. ?

    Yes... it is indeed strange. We have reported it to our dedicated team and hope there will be a fix for the full-screen mode as well.

    Take care ?

    Jean

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • nathann
    nathann Posts: 2

    Can anyone from TeamViewer report back a status on this?? Why is this taking so long to resolve??


    N.

  • SDP190
    SDP190 Posts: 2 Newbie

    Any update on this one?

  • JordiFresquet
    JordiFresquet Posts: 1

    Hi.

    It's still happening with the last version. The only workaround is not using

    full screen in the rdp session, which in most cases it’s annoying.

    Looks like a Mandalorian but now “This is the way” 😊

    Any idea when this issue will be solved?

    Thanks.