teamviewer.com link icon
or
Ask The Community

Trouble installing Teamviewer on Ubuntu 18.04 computer

I am trying to install Teamviewer on an Ubuntu computer, however, whenever I download the Deb package and try to install it, it keeps saying "Don't know how to handle 'file". I't's my first time to use a Linux computer and I am completely lost as to how to proceed from here. The Ubuntu version is Ubuntu18.04: Linux Kernel 4.15 and it is a 64 bit computer. If anyone can direct me to any helpful direction, so that I can  successfully install teamviewer, it would be very much appreciated. Thank you.

Tagged:

Comments

  • QPG
    QPG Posts: 21 ✭✭

    This article on Linux Hint may help:
    How to Manually Install a Deb Package Using Command Line in Ubuntu 

    Deb files are package archives. If you are coming from Windows, you can think of them as zip files to put it in a familiar context. There is more to them than that, but the short of it is that your Ubuntu desktop environment doesn't know what to do with the file because it has no program associated with the file type. (That seems a bit strange since Deb files are usually associated with the Ubuntu Software Center application on a stock Ubuntu Desktop install.)

    You may run into missing dependencies. How to handle that is also addressed on the page I linked.

  • RY5
    RY5 Posts: 2

    Thank you very much for your kind reply.

    I have tried to manually install the deb package and there appears to be issues with dependencies. I could not install "libqt5webkit5" (an error occurs every time I try) and another error occurs saying Package "qt56-teamviewer" has no installation candidate. 

    I tried running "'apt --fix-broken install' but to no avail.

    Any advise regarding how I could proceed from here would be greatly appreciated. Thank you!

Sign In or Register to comment.