teamviewer.com link icon
or
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳


Please find more information here.

how can prevent to lock computer when connection close

i am license user of 11 version

i manage serveral computer.... and some computers didn't lock and some computers did

lock when connection is closed...(some computers were install by teamviewer host some were teamviewer but i think those are doesnt matter)

i can't find this option

how can prevent to lock computer when end of connection 

Comments

  • Esther
    Esther Posts: 3,880 Community Manager 🌍

    Hi @WS

    You can pre-define which behaviour you would like to have in your TeamViewer Settings under Advanced --> Advanced settings for connections to other computers --> Lock remote computer:

    LockComputer.png

    Here is the meaning of the different possibilities:

    • Automatic:  The remote computer will be locked, if it was also blocked at the start of the connection.
    • Always:  The remote computer will always be locked after a connection. 
    • Never:  The remote computer will never be locked. 

    I think, that your setting is on automatic, right? 

    All the best, Esther

    Community Manager

    Support us on Trustpilot.
  • siys
    siys Posts: 4

    How do you disable 'Lock Computer > Lock on session end' on Mac version 12.0. 75813? Thank you very much.

  • Bean
    Bean Posts: 6 ✭✭

    I have team viewer 11.0.93231 on both computers and both computers have lock computer on disabled but computer still locks after disconnecting. Is there a bug?

  • I have this same issue. I presume it's a bug?

  • All the remote sessions lock when I disconnect regardless of the setting in options set to never. Is this a bug?

  • CyberBob
    CyberBob Posts: 2

    Hi

    I can also confirm - regardless of Lock settings on source and remote PC - the session always locks the remote system.

    Experienced this only after remote system rebooted after windows update. Before the update it was fine.

    Windows 10 with cumulative update patch for March was installled

  • Winnie
    Winnie Posts: 1

    im also having this problem since about a week back when rebooting after windows 10 march updates.

    Have checked all the settings and they are set to never lock on exit.

  • Under the advanced options, I have "Lock Remote Computer" set to never.

    While connected, at the top under Actions -> Lock, I have "Lock on Session End" UNchecked.

    Yet, everytime I close out of a connection, the target computer is locked.  This has been going on since the update to Teamviewer 13.  How can I stop this?

  • higopr
    higopr Posts: 2

    I'm using Windows 7 X64 Ultimate
    And i have the same problem..  Teamviewer locks my target computer.
    TeamViewer 13.1
    (This problem started today, But i updated my pc on the saturday 07/04/18

  • siys
    siys Posts: 4

    I wish to state I ugraded my Teamviewer program quite some time ago and the issue was resolved on the new version 13.0.6447 for Mac.

  • CyberBob
    CyberBob Posts: 2

    Just an update from my incident - it appears that after connecting to the remote computer about 5 times (and unlocking it) - Teamviewer remembers the setting for do not lock.

    This only happens after rebooting the remote computer

  • MWCU
    MWCU Posts: 1
  • PCLANVAD
    PCLANVAD Posts: 1

    Folks,

    Your problem has nothing to do with TEAMVIEWER version or Windows update.  After changing "Lock remote computer" to "Never" as instructed by the first POST above.  You simply has to sign out of TEAMVIEWER and then sign on again for the settings to take effect.

  • Sign out doesn't help in my case. I had to rollback from 13.1 to 13.0 (on the controlled PC) to be able to disconnect from it without locking. This is just a total mess.

  • M_Arafat
    M_Arafat Posts: 1

    You can prevent the user from locking his PC through the PC group Policy so when you close the TeamViewer connection the PC will stay where you left it.

    You can do that by going to:

    1. on the keyboard press (Win + R).
    2. Write (gpedit.msc).
    3. on the left sidebar navigate to: User Configuration--> Administrative Templates --> System --> Ctrl+Alt+Del Options
    4. Enable the "Remove Loc Computer" Option
    5. Save Changes and give it a go.
  • nattan
    nattan Posts: 3
    Well, ok, it works, however it's not the best solution. Sometimes I need to lock my computer but not necessarily when connecting with via TeamViewer. It seems that TeamViewer 'forgets' that locking remote computer is set to Never after every Windows Update.
  • This setting applies to all hosts I connect to. Shouldn't this be configurable PER HOST?? Some of my clients want me to lock their computer when I close the connection and some don't want that.

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @M_Arafat: From a security perspective, it sounds like a bad idea to prevent users from locking their system.

    @SijeDeHaan: In that case, keep the "auto" setting. It should leave the computer in the state it was found: If locked when connecting, lock on disconnect.
    The "End session" button in the toolbar will always indicate whether the computer will be locked when you disconnect. You can always override the default behavior via the Actions menu: Have a look at the End-session submenu and the Lock submenu.

    Cheers,
    Daniel

    Linux Developer
  • whippie
    whippie Posts: 2

    This locking option is not available on the Mac version. Is there some other way to set this up? For me, sometimes the computer locks sometimes it doesn't. I want it to ALWAYS lock.

  • fabiotnt
    fabiotnt Posts: 1

    On Actions menu, select Lock Computer and then unmark Lock on session end option.

  • Hooli
    Hooli Posts: 1
    OMG thats it... remotely rebooting is ignoring this setting completely ... thanks... it was getting quite frustrating!
  • And what can I do if I want some computer lock and others still unlock? Any idea?

  • Faslane
    Faslane Posts: 1

    Thank you!! This is turned on by default in Teamviewer 14 I THINK. I'd never had it do this before, not a big issue but kinda annoying for multiple logins when applying updates and having to reboot host a lot. Yay!!

    TY!

    Faslane

    ~ Never underestimate the power of being powerless.
  • We are using the latest version of TeamViewer 11.

    This option does not appear in the host's "TeamViewer options" menu:

     

    20190422-co-pss1-teamviewer-auto-lock-on-disconnect.PNG