link icon
Ask The Community

Teamviewer hangs with "Pasting from ..." Message on host

I'm using Teamviewer 12.0.78517 on two OS X 10.12.5 machines. Periodically my host machine will have a notification "Pasting from " followed by the client computer name. This brings up the dreaded OS X "beachball" and both systems hang for a minute or two. What is this? How do I fix it? Thanks


  • It's been 2 months since this problem was reported and 5 others have the same problem, including myself.

    Any updates or suggestions???

  • DHK1
    DHK1 Posts: 15

    I've not found out anything new. I'm on a Mac, so I've switched to an Apple solution of "Back to My Mac" which covers 99% of my needs.

  • mbohu
    mbohu Posts: 5

    I have the same problem. Where do you see the "clipboard synchronization" setting? There is nothing like this under the advanced tab. (Version 13)

  • Haim
    Haim Posts: 4

    Thanks Man! 

    It solved the problem for me.

  • Haim
    Haim Posts: 4

    - Right click the team viewer icon on the top bar and click on "Preferences"

    - Go to the "Advanced" Tab (next to the "invitation" tab)

    - Search for the "Clipboard Synchronization" in the box with the title "Advanced settings for connections to other computers". In this box you should also find  "Access Control", "Timing out inactive session", "start remote control automatically... ", "Temporarily save connection passwords", and right after that the "Clipboard synchronization" option.

  • DHK1
    DHK1 Posts: 15

    @Haim What version do you have? I'm running macOS and Teamversion version 13.0.6447 and there is no Clipboard reference in the advanced preference pane.

  • Haim
    Haim Posts: 4

    I'm using:

    Controling Computer:  TeamViewer:12.0.90924, MacOS 10.13.3

    Controlled Computer: TeamViewer 12.0.92876, MacOS 10.13.3

  • DHK1
    DHK1 Posts: 15

    @Haim You're on version 12, I've upgraded to 13... that must be the difference.

  • Haim
    Haim Posts: 4

    Probably so @DHK1 

    But since we have the same problem there's a good chance that they just moved the location of the "clipboard synchronization" option, I recommand you would go over all the advanced tabs and search for it (or maybe the description of this option was changed?).

    Would be very helpful to get some help from @support on this.

  • ShadowVA
    ShadowVA Posts: 1

    You just need to scroll down on the Advanced window.  It is easy to miss, but there is a scroll bar on the right, and more options further down the page.  Took me a few seconds also to figure that out.

  • macaid
    macaid Posts: 6
    Still happens in version 13
  • Bug is still there. Matto's fix still works. Thanks, Matto.

  • Stoked, worked for me TY!

  • mtimm
    mtimm Posts: 1

    Worked for me. Thanks


  • schnebs1
    schnebs1 Posts: 2

    Solved it for me - thanks!

  • schnebs1
    schnebs1 Posts: 2

    TeamViewer > Prefrences > Advanced, then you need to scroll way down until you find Clipboard synchronization under Access Control section.

  • Thank you!!!

  • SimonITS
    SimonITS Posts: 2

    still getting this issue on the latest version in April 2020.... would be nice to see this fixed so I can use the clipboard sharing feature!

    For now I've had to disable it as the lesser of two evils, as the crashing and lagging (beachball) it causes are far worse

Sign In or Register to comment.