teamviewer.com link icon
or
Ask The Community

Teamviewer Host no longer allows 24/7 access on Android 10 / Samsung Galaxy Tab


We're using TeamViewer Host to allow access to devices that are attached to cameras and the remote control operations have been working flawlessly.  Until some of our devices were upgraded to Android 10.  Now we see this and the "Start Now" button has to be pressed, which is not possible when there's nobody around.

message-13800478-10682951908962334162.png

Has anyone else experienced this?  Does anyone have a solution?

These are Samsung Galaxy Tab SM-T290s from 2019.



Comments

  • smpl
    smpl Posts: 6 ✭✭

    I have the same proble on Huawei T10s. I have no idea how to solve it.

    Screenshot_20201027_221958_com.android.systemui.jpg

    I described it in this thread:

    https://community.teamviewer.com/t5/Mobile-EN/Android-Host-on-Huawei-T10s-Privacy-notice/td-p/105352

    Someone else reported a similar problem here::

    https://community.teamviewer.com/t5/Mobile-EN/Have-to-allow-each-time-with-host-app/td-p/105147

    Does anyone have any idea how to solve this?

  • smpl
    smpl Posts: 6 ✭✭

    Ok, I found the solution:

    https://support.google.com/android/thread/13791498?hl=en&msgid=62539685

    1. install ADB on your computer
    2. install Shizuku on your phone, open Shizuku, "view command," copy command, close Shizuku
    3. Install (and purchase) App Ops on phone
    4. Enable Developer options on your phone
    5. Allow USB debugging on your phone (in Developer options)
    6. Connect phone to computer via USB cable
    7. Open terminal window on computer in ABD folder, and type in the command that you copied from Shizuku
    8. Open App Ops, look for application you want to allow PROJECT_MEDIA for, and allow PROJECT_MEDIA
    9. Close App Ops. You're done.

    2020-10-29_22-20-47.jpg

    You don't have to purchase App Ops. Free version is enough.
    It works perfectly for me.

    Sławek

  • Howard57
    Howard57 Posts: 2 Newbie

    Hi

    I have upgraded my 85 year old mothers tablet from an Lenovo Tab E10 to the latest Samsung A7 (2020) running Android 10. We use this tablet purely for Zoom and because my mother is unable to operate the tablet I do this remotely via Teamviewer Host. This worked perfectly on the Lenovo but on the new Samsung I can install the Host app but it will not let me assign the device to my account it comes up with "Unexpected error please try again later"


    I tried researching the subject and found some reporting that Android 10 does not work with Teamviewer Host.


    Is this correct? if it is is there a work around.




    Regards

  • AdobeFelix
    AdobeFelix Posts: 10 ✭✭

    Encountering the same issue with Sony devices. Android 10 seems to block 24x7 support.

    Seeking a similar solution for Xperia XZ premium devices.

  • AdobeFelix
    AdobeFelix Posts: 10 ✭✭


    We're supporting 4k display Android devices in a worldwide deployment.

    At this point we're hitting a blocker - as our devices are upgraded to Android 10 they no longer allow us to provide remote support via teamviwer support.

    These are the ones that were getting hit first.


    Seeking a supported solution from Teamviewer. Please PLEASE assist, our customers really need us to be able to provide 24x7 support and are only in the office during business hours.

Sign In or Register to comment.