Installation files cannot be extracted

ESMIT Posts: 1
edited May 2023 in General questions

Hi, I need help with my computer.

I tried to update my computers Teamviewer as it wouldnt connect with my husbands computer. THe update didnt want to work. 

So I uninstalled Teamviewer, and tried to install it again. But now I get an error message saying: Installation files could not be extracted. Installation aborted!

I have disabled my Firewall and Antivirus. I have tried the download in Firefox, Chrome and Internet Explorer.

I am wasting so much time to get Teamviewer onto my computer and I need to work. Please help!


  • Reyhan
    Reyhan Posts: 269 Staff member 🤠

    Dear ESMIT,

    Thank you for your post, we are currently working on this issue and we will post an answer once we have figured out a solution. :smileyhappy:


    Did my reply answer your question? Please accept it as a solution to help others, Thanks.
  • dferrari
    dferrari Posts: 1

    Version 12 works good for me on Windows 10, but I have same problem than ESMIT on Windows 7 x64