link icon
Ask The Community

Black screen

Hi, my parents have teamviewer host on their android tablet and I have teamviewer remote control in my android tablet. Untill recently it worked fine, but now I get a black screen. Although I cant see anything,  I can still see that my parents device reacts on my moves (scroll, tap etc) (i have both devices at my home). What's going on?! Manja


  • Hi there, I have purchased a samsung tablet for my grandmother who is in a nursing home to show her pictures of her grandchildren remotely, etc.. Teamviewer is for the most part working fine on this device. The only issue I am having is that when I connect to the device via an iphone or ipad after the device's screen has turned off, I am unable to unlock the device, and I will only see a black screen no matter how many times I swipe the screen, or any buttons I press on the keyboard. If I connect to the android tablet via my mac computer, I don't encounter this issue at all. Instead, if I connect when the screen is turned off, I am able to swipe up on the screen or tap it a few times, and the device will unlock fine on its own. Does anyone know how to resolve this problem on iphone or ipad?

  • TeamViewer Host worked just fine in Android 9, but after the update to Android 10 it no longer works.

    The screen in the client session is entirely black. Galaxy S5e Android 10 t720 t725


  • Yes, I have the same issue. Anyone has a solution please?

  • AlexAA
    AlexAA Posts: 1


    I'm using HOST on an Samsung Tablet A (Android 10, SM-T510), to help my aged mother . I like HOST because she doesn't need to activate it.

    However, since the July update of Android, when I connect to the Tablet from a Windows 10 PC (or another android), I just get a black screen (although.. once in a  while, it seems to work like before). It was working for months before that.

    However, if she starts Quick Support and gives me the autorization, I can see the tablet screen. I have some trouble with the cursor/mouse, but at least I can see the screen.

    I've seen many posts on the black screen issue. However, since Quick support works, but Host not, I have the impression that it's not a big technical issue  in my case, and that Host should be able to work also, inspite of the issue with Knox, etc...?

    Did somebody experience the same problem, or does TW help has a solution?

    Thanks and best regards,


  • ArasG
    ArasG Posts: 1

    Hello! I have installed the most recent versions (as of 2020-08-31) of Teamviewer Host and Quick Support on my Galaxy Tab A 8.0 SM-T290 running Android 10. 

    Yesterday - before a bunch of Android updates auto-installed on the Tab, I was able to remote control (with some issues) the Tab from my PC. Today, after the Android updates, I have several major issues and cannot remote control any more:

    1. I need unattended remote control using Host. It connects fine, but the Tab asks for permission for "Exposing sensitive info during casting/recording"... so... I cannot do this unattended. File Transfer seems to still work ok.

    2. When I go into remote control, I see the mesage on my PC "This Device Supports Screen Sharing Only." I cannot naigavate/click/swipe... I can only control the position of the arrow, and when I click a little blue hand displays.

    3. When the Tab locks, I get a black screen on the PC and can't do anything.

    Any help? I've read a lot of threads, with no real solutions. This is a VERY popular tablet, I'm surprised I'm having this many issues. Thank you!

  • TotalPC
    TotalPC Posts: 87 ⭐Star⭐

    Hello @ArasG,

    Since it was working before, you should have either the Samsung or Universal add-on installed along with the QuickSupport app. Remove the current add-on from your android device and try using the other add-on to see if that works for you. If not, switch back and try again, reinstalling the add-on may help too.

    Samsung Add-On:

    Universal Add-On:

    More information can be found here in the community.

    Hope this helps. If not, do you have any more details?


    TeamViewer user since version 6 (2010). We used other remote software programs (TVNC UVNC PCAny) for many years before.
  • I have run into the same problem. Black screen with Host, but not with QuickSupport.  Galaxy Tab A 10.1 2019 Edition.  Same whether accessing it from a PC or another Android tablet.  Would be very interested to know if you (or anyone else) has found a solution.

  • brettborowski
    brettborowski Posts: 2 ✭✭

    Noticed a similar thing on my SM-T510 but worked out some interesting things.

    If my tablet is vertical, I can connect, see the screen and can control it properly.

    If I rotate it to horizontal, I can see the screen but clicks are in the wrong place. I confirmed this by turning on "Show taps" and "Pointer lcoation" in Developer Mode. ("Show Taps" is probably not necessary.)

    If I rotate back to vertical, everything works again.

    On the other hand, if the tablet is horizontal when I start the TeamViewer connection, I get a black screen. The screen stays black even when I rotate back to veritical. Taps in horizontal mode do not land where you'd expect similar to as described above when I can see the screen because I started the connection when the tablet was vertical.

    It's like the cursor position on the tablet is being scaled improperly in both directions from the controller side. If upper left corner is 0,0,  Clicked have-way down the client, puts the cursor 32% down the left edge of the tablet. Clicked in the bottom left of the contoller puts the cursor 63% down from the top on the tablet.

    Clicking halfway across the controller puts the cursor 77% across the tablet. Clicking the controller 62% across puts the cursor at the rigth edge fo the tablet.

    Rotating the table back to veritical, the clicks end up exactly where you'd expect even though the screen is still black.

    (I do not have any of these problems with an SM-P610, btw.)




  • ADH1
    ADH1 Posts: 3

    I have been using Teamviewer Host on a Samsung Tab a 10.1 for a couple of months and then when I logged in all I got was a black screen. If the table was restarted when in the horizontal orientation, Teamviewer would work for a few seconds and then the screen would go black.  After that the screen was always black when teamviewer was started. I set the tablet next to my Windows 10 computer used to control it so I could see what was happening.  The tablet was connecting, the tablet screen would wake up,  but using the mouse was hit and miss.

    I also found ( after reading this post) that turning the tablet into the vertical orientation eliminated the black screen and allowed me to control the Samsung Tab A 10.1.  It also seems to allow Teamviewer to maintain contact.  I had problems with Teamviewer disconnecting after a couple of minutes or less.



  • ADH1
    ADH1 Posts: 3

    I found I can get by the black screen by tapping the space bar on the controlling computer.  The screen becomes visible but "grayed out".  May have to try different tempo or timing on the taps until it works.

    There is a"<" at the left bottom swipe it left with a  left mouse button depressed. The screen comes goes to full color, not gray.  Then swipe up quickly before the screen goes black again.

    This seems to work for me, at least for today.

  • ADH1
    ADH1 Posts: 3


    I found I can get by the black screen by tapping the space bar on the controlling computer.  The screen becomes visible but "grayed out".  May have to try different tempo or timing on the taps until it works.

    There is a"<" at the left bottom swipe it left with a  left mouse button depressed. The screen comes goes to full color, not gray.  Then swipe up quickly before the screen goes black again.

    This seems to work for me, at least for today.

  • Hi thanks for creating this wonderful application, I am a new owner of a Samsung S7+, unfortunately I can't get TeamViewer host to work correctly as a host. 

    On my win10 computer, I only see a black screen when accessing the tablet, and nothing seems to fix the issue. Are you aware of this issue? And are you working on a solution? I use TeamViewer regularly for my classes so that I can share my work, it's an essential part of my learning as a student in University. Please let me know if we can correct this issue, happy to offer more information or help in whatever way that I can.

    Thomas Balcom

  • JeanK
    JeanK Posts: 4,509 Moderator

    Hello @Manjah @tom0779 @ADH1 @brettborowski @ThatManAgain @jdavis3810 

    Thank you for your message and welcome to the TeamViewer Community! ?

    I have merged your posts into one main thread to make sure you all get our latest information regarding this issue.

    This black screen behaviour is unfortunately a known issue affecting some devices.
    Samsung is already working on a fix and will be released through a firmware update.
    Please make sure you update your device regularly.

    Note: Unfortunately, we cannot tell you when this update will come. We thank you in advance for your understanding.

    You will find all the information you need on how to update your device in the following article:

    Stay safe and sane! ?

    Best regards


    French Community Moderator
  • jdavis3810
    jdavis3810 Posts: 5 ✭✭

    Windows 10 client PC connecting to Samsung Tab A running Android OS 10. Using Teamviewer Host on Android tablet for unattended remote control.

    I can connect to endpoints when tablet is vertical but horizontal it shows as a black screen of death.

    when will you fix this? not using QS as it must be unattended access. This worked in the past without issue.

  • jdavis3810
    jdavis3810 Posts: 5 ✭✭

    @JeanK what specifically is the issue that falls under Samsungs responsibility to fix?

  • JeanK
    JeanK Posts: 4,509 Moderator

    Hello @jdavis3810,

    Thank you for your message and welcome to the TeamViewer Community! ?

    Currently, we are not able to provide you with this information.

    We thank you in advance for your understanding.

    Best regards


    French Community Moderator
  • Hi,

    Thank you for the information regarding a potential fix from Samsung to resolve this issue.

    Will we be notified on this thread when such an update will be available and is confirmed as working?

    Thank you

  • itm60
    itm60 Posts: 4 ✭✭

    I've found that the black screen doesn't happen when the tablet is in portrait mode. So I use Tasker + Autonotification to force it into portrait mode whenever there's an incoming Teamviwer Host connection

  • jdavis3810
    jdavis3810 Posts: 5 ✭✭

    can you detail how you configured tasker to recognize the incoming connection?

  • itm60
    itm60 Posts: 4 ✭✭

    You'd need to set up a profile with the following conditions:

    • an "autonotification intercept" event that when it detects the creation of a HOST notification with a certain text (in this case the notification that tells you screen sharing is currently active)
    • (the condition that screen orientation needs to be in automatic?)

    Once these conditions are true then you set a task that switches the orientation mode to PORTRAIT.

    Also set up a Tasker profile to intercept notification for app: "Host", text "The session with xxx is finished". Set Display Autorotate back to On for this profile.

    For this Tasker needs to be granted permission to Write Secure Settings on your device.

    • You have to set up adb as explained here:

    • And you have to grant permission to write secure setting as explained here:

    adb shell pm grant android.permission.WRITE_SECURE_SETTINGS


  • jdavis3810
    jdavis3810 Posts: 5 ✭✭

    Too many steps for the fleet of tablets we have. The November 2020 version of **Third Party Product** Stremer and Splshtop Stremer addon for Samsung Knox works. Use the 'system screen capture' in the add-on not 'auto'.

  • abri
    abri Posts: 2 ✭✭

    The solution is to allow the Teamviewer Host app to show notifications. It'll bleep on the phone/tablet and show its icons and but you're now able to unlock the black screen.

  • Klockins
    Klockins Posts: 4 ✭✭


    A new phone(Samsung A12) was purchased 2 weeks ago.The teamviewer host program was installed into them. First week the program worked without problems. I normally can connect and unlocked the phone(Samsung A12)with remote control from my phone (samsung s10e ). Now I can connect to the phone, but the screen cannot be unlocked, it is always dark. I press any buttons the screen does not work to "wake up" as before. In the settings was not any correction. Why did the program stop working remote control( can't unlock)?

    When phone is unblocked I can remote him. how to fix this problem( unlocked phone then I am connected with Team viewer)?


Sign In or Register to comment.