teamviewer.com link icon
or
Ask The Community

Error: The application "TeamViewer" is not open anymore on MACOS

Hello EveryOne,

I have upgraded to the Big Sur in MAC and have a problem using the TeamViewer. I am constantly getting an error:

The application "TeamViewer" is not open anymore

on the latest installed version of the TeamViewer. Please help

Alexander

Tagged:

Answers

  • MoreCoffee
    MoreCoffee Posts: 22 Staff member 🤠

    @parallax1957 When exactly are you getting that error? Is it in response to any specific action?

    In case you have "Start TeamViewer with system" turned on and get this error when you attempt open the TeamViewer app from the Applications folder, TeamViewer is likely already running and the error message might be due to a change in macOS Big Sur behavior.

    As a quick workaround, here are some ways that you can use to open the TeamViewer window in that situation:

    Check for the TeamViewer icon in menu bar on the upper right corner of your screen, or check for a "running app" icon (with a small dot below it) in the Dock. If you see either one of those, use them to open the TeamViewer window.

    In case there is neither a (running) app icon in the Dock, nor a menu bar icon, please open Activity Monitor (Applications > Utilities). From the menu bar choose View > All Processes. Find the TeamViewer_Service process in the list, and quit it. That should restart TeamViewer and you should be able to access the TeamViewer window from menu bar icon or the Dock, as described above.

  • parallax1957
    parallax1957 Posts: 2 ✭✭

    Thank you for your response. After the number of the installation/de- installations of the TeamViewer v15.13.6 (MAC), as well as the repeat installations of Big Sur, I have managed the installation of the TVr on my MAC Book Pro.

    I have noted that I could not de-install TeamViewer and could do it only with the CleanMyMac un-installation module. So, there is still a problem with the TVr and Big Sur. It seams that the TVr software is not as flexible on the MAC as on the Windows. I still use it though.

    Thank you again,

    Alexander

  • jackneely
    jackneely Posts: 1 Newbie

    I keep getting the dialog box saying "The application "Teamviewer" is not open anymore" and have performed all the recommended steps. I tried to uninstall it using CCleaner, but it won't uninstall because it says the application is still open.

    What can I do?

  • MoreCoffee
    MoreCoffee Posts: 22 Staff member 🤠
    edited April 23

    @jackneely When are you getting that dialog box? When you attempt to open TeamViewer? Or when performing a different action?

    Two additional things you might want to try if you don't see the TeamViewer icon in the dock or in the menu bar:

    1. Restart your Mac.
    2. If after restarting, you can neither see the TeamViewer icon running in the Dock, nor in the menu bar in the upper right corner of the screen, please open Activity Monitor (Applications -> Utilities), select View -> All Processes from the menu, search for TeamViewer. Which / how many processes with TeamViewer in the name do you see?
  • twtoal
    twtoal Posts: 3 ✭✭
    edited April 23

    I have same problem. The Teamviewer Icon is not in the menu bar like it usually is. I click on the Teamviewer icon in the doc and get that message. I restarted my Mac, same thing. Activity monitor shows two instances of TeamViewer and one instance of TeamViewer_service open. Previously, after the first reboot, it showed only one instance of TeamViewer and one instance of TeamViewer_service.

    I force-quit those instances and tried running the TeamViewer icon and got the same message. Then I rebooted again and got the same thing happening again.

    At some point I may have exited the Teamviewer app completely, and I'm thinking this may be the cause of it not working.

    I have BitDefender installed but Bitdefender Shield and Bitdefender VPN are both disabled.

    I redownloaded and reinstalled TeamViewer (without attempting any kind of uninstall), and the same thing still happens. When I click on the TeamViewer icon in the dock, I got a popup: The application “TeamViewer.app” is not open anymore.

    Okay, I fixed it by logging in to the management console at Teamviewer.com. That console showed the computer I'm trying to connect to as available, so I tried to connect to it, and I got a popup asking if the web page could run Teamviewer.com and I said yes. Nothing seemed to happen. But, when I then tried to run Teamviewer from the icon in the dock, it worked. I rebooted and now the Teamviewer icon appeared once again in the menu, and it worked fine.

  • Yinzara
    Yinzara Posts: 1 Newbie
    edited April 26

    I'm having the exact same problem as this however I have been unable to use the workaround of using the management console on TeamViewer.com to login. When it launches I get the same "The application 'TeamViewer.app' is not open anymore". When I open the Activity Monitor I see only one process listed for TeamViewer. If I "ps -ef | grep TeamViewer" in the console, I see there are 4 processes running. I've tried killing each one individually but they just automatically restart and no icon shows in my system tray. I am running OS X Mojave 10.14.6

    I am also unable to uninstall TeamViewer as it says "The item 'TeamViewer' cannot be moved to the trash because it is open".

    I was able to work around this issue by deleting all files in /Library/LaunchDaemons and /Library/LaunchAgents that started with "com.teamviewer" then restarting my PC then deleting TeamViewer from my Applications then reinstalling it again from the web.

    I had this problem on both of my Mac PCs and one runs Mojave and one runs Big Sur so this is a pretty ubiquitous problem that's hard to resolve.

  • KelvinLuk
    KelvinLuk Posts: 1 Newbie

    Got the exactly same problem.

    Just one simple step has fixed.

    • Press “Cmd+ Opt+ Esc” buttons simultaneously to go to the Force Quit window.
    • Force Quit TeamViewer


Sign In or Register to comment.