Debian 9 Black Screen on login

I am able to establish a connection on my Debian 9 PC via Teamviewer 12, and I see the login screen. After I enter my credentials the screen gets stuck on the login screen. If I exit the session and try to establish a new session I get a black screen.

I am running the default Gnome Display Manager.

Thank you


  • ChristianCay
    ChristianCay Posts: 182 [Former Staff]

    Dear asteroth,

    Thank you for contacting TeamViewer.

    To be able to troubleshoot your issue. Are you using Host version or Full version?

    We are looking forward to your comments.


    Best regards,


    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • Both of them (Host or Full) lead to the problem. My Debian service encounters the same problem.

    Best Wishes


  • mmiat
    mmiat Posts: 13

    me too with Ubuntu 16.04 Gnome and gdm3

    i login, and then black screen

    with lightdm it works

  • Hello,

    Did this ever get resolved? I am experiencing the same issue (I believe) with my Debian instance.

    When I TeamViewer in when I am logged in I get the screen the user sees; however, when I Teamviewer in when the user is logged out I only get the black screen.




  • mmiat
    mmiat Posts: 13

    no, i've not solved, but i've not tried any more

    i think it's something related with dm: lightdm/gdm etc, some works, others not

  • Soooo... after digging on the web I have found another similar issue.

    I am launching Teamviewer on a headless system. It looks like Teamviewer won't launch if the system doesn't have a monitor detected. 

    The workaround I discovered was to install an HDMI "dummy" plug. I am going to try it over the weekend and we will see if it works!

    Here is the board I found the supposed solution on if anyone finds themselves in a similar situation.

    Teamviewer only connects when a monitor is attached

    I should note that when a monitor was plugged in I was able to reach the machine without any issue.