teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

Cannot control remote PC - Cannot Assign Device

Colton6ix
Colton6ix Posts: 4 ✭✭
edited May 5 in Linux only

Hello,

I have been trying for a couple weeks now, on why I cannot assign a device to my account. Further to that, that same device, I cannot control certain options like sending CTRL-ALT-DELETE or rebooting the device remotely etc. It appears to be a permissions thing but I am running TM as SUDO on the device (Debian - Q4OS), and on my desktop that I am using to remote into the device is admin by default (WIndows 10).

When I try to assign the device to my account, I get "Administrator verification required" in red bold letters.

How can I fix this??


Answers

  • wbuck3
    wbuck3 Posts: 1 Newbie
    edited September 10

    I deleted computer assigned to account and uninstalled teamviewer. I then reinstalled, added computer to account, enable easy access and it worked. During the adding to account I was prompting in linux for permissions (sudo) to make modifications.

  • Colton6ix
    Colton6ix Posts: 4 ✭✭

    The response that I got back from TeamViewer was that it wasn't supported in Linux.

    However, that's actually not true because I reinstalled Linux however when I reinstalled TeamViewer after the installation of Linux, I did it differently the second time around using the command line to install it (at least I think that's what I did versus using GDebi to install the deb file). And then I was back on track and able to control it from another computer.

    Now I could be wrong, it could have been the other way around, so I apologize I can't remember exactly. I've since switched back to Windows because Linux was constantly giving me problems to use it as a media server. I'm using Windows 11 now and I've literally had no problems.

    If you're going to test my example, could you confirm once you're finally able to control / assign it to another device to help others please?

    I do know for a fact that it is something that can be done and that the answer I got was wrong but I had nothing to go on when I got that answer and I had to believe them at the time. It wasn't until I had reinstalled Linux and then reinstalled TeamViewer where it worked the second time around, that's when I realized that it depends on how it's installed.